Repeated requests to update HiSuite software

  • 22 November 2018
  • 22 replies
  • 15460 views

Userlevel 1
Hello. I have a Huawei P20 Pro and have downloaded the Huawei HiSuite PC software to my windows 7 PC to use as an interface tool to my phone. The HiSuite software downloaded, version HiSuite 8.0.1.300_OVE, and then immediately asked to update itself, which I confirmed and it then became 8.0.1.303_OVE. There was also a window which said 'software not fully installed' which indicated the MTP was not loaded. I have turned on the 'HDB Allow HiSuite' option on the phone.
Every time I try to use the HiSuite software I get the update request, which if I accept and install shows success but still doesn't allow the HiSuite interface to work.
I can connect and manage the phone contents through the Windows Explorer connection but not using the graphical UI.

The settings/device connection/USB is already set to 'Device file manager (MTP)'.

FYI, I always have to click the 'Transfer Files' button on the phone (it's set to 'charge only') each time I plug it in, even though it's set as default as above.

After setting 'Transfer Files' I can manually manage the files etc. on the phone from the PC Windows Explorer software but not using the Hi-Suite GUI.

Again, if I set the 'allow HDB' in phone security settings each time I plug in the phone then (after updating the _303 software again) I can sometimes use the Hi-Suite GUI to view contacts, photos, apps, etc. (as it should do automatically of course) but as it doesn't it is obviously impractical and a nuisance.

Note, I've also set the 'Huawei Share' and 'Computer Share' buttons (and the same network google password) but these are time limited and drop out when not used.

What do I need to do to fix the repeated software update request and the 'Transfer Files' default setting? Any help please?

22 replies

Userlevel 7
Badge +6
Hi AlanAliwoood,

If you can please pm me with the details of the phone you are connecting and a few followup questions I will do my best to assist you in this matter.

Best wishes,
Max
Hi

i have the same problem with p9 .
have you find a solution?
thanks
Userlevel 1
Hi oubakir1,
No, the problem remains the same.
Co-incidentally, today I got a phone request to update the EMUI software in the phone, which I did, it is now at build CLT-L09 8.1.0.159(CLT782).
I had hoped this may fix the issue but alas, not. The same procedure occurs as described above.

BTW - I did send the details in a message to Max, as requested, but I heard nothing further from him or anyone else in Huawei or this community. Although I'm reasonably pleased with my phone, I'm not very impressed with Huawei at this point. I think I'll stay with Samsung when my phone next comes up for renewal.
could it be because i am using the company laptop as a user and not an administrator ?
are you in the same situation ?
Userlevel 1
HI again, it depends on your problem with using the Hi-Suite software. If it's the same situation as I described in my initial post then it doesn't sound like it matters that it's a company laptop. However, most big corporate companies lock down their laptops so you're not allowed to load your own software, administrative rights are controlled by the company (legitimately, so it reduces the risks to their software, data and security). If this is the case then I doubt whether you'd have been able to download the Hi-Suite software at all, hence the 'request to update' situation (as mine) wouldn't be the same. Hope you get it sorted, otherwise, give up on Hi-Suite and just manage your phone using Windows Explorer (as I do now).
thanks dear i can install the program and update it through special allowance but it has the same problem you described as it always ask for update.
i am using the window explorer also.
Userlevel 2
Recently bought a Mate 20 Lite, and I have the same issue. Connected to phone via USB and HS suite asks for connect now, click and everything for finding HDB comes up. Everything is set up on my phone?
Any help much appreciated.

Jeff
Userlevel 7
Badge +6
Hi all,

In regards to the situation you are currently facing, we would recommend the following steps below:

1. Changing usb ports. - may seem unimportant, but in fact it is step one since a usb driver update can affect the performance of a device that was plugged in at the moment of update.
2. Make sure that upon connecting the device MTP(Media transfer protocol) protocol is enabled . In some cases this might also require enabling or disabling USB debugging .
For USB debugging on the device, go to Settings > About . Tap the Build number seven times to make Settings > Developer options available. Then enable the USB Debugging option.
3 Check that HDB (allow HiSuite to connect using HDB) is enabled. Try to revoke HDB permission from your PC, enable and try to connect again.
4. When USB isn't connected, disable USB debugging, revoke USB debugging authorizations, enable Always prompt when connecting USB (all of them on developer options) and attempt to connect.
5. If the device can connect to another PC or Laptop then check Windows Firewall and device manager for administrative permissions or programs that are blocking the connection.
6. Uninstall Hisuite from the Pc/Laptop and reinstall a fresh copy from https://consumer.huawei.com/minisite/HiSuite_en/
7. If the issues still persist, backup the device via other means such as sd card or cloud; perform a factory reset and attempt connecting the device afterwards to the PC/laptop.

Also for a more visual guide on Hisuite Connections please have a glance at this link from our website : https://consumer.huawei.com/en/support/how-to/detail-use-skills/?resourceId=en-us00432169

Let us know of the outcome after giving the above steps a try!
Best wishes,
Max
Hi all,

I think and hope that I can provide you with some quite helpful information regarding your question:
“What do I need to do to fix the repeated software update request?”
The workaround which I have designed a few days ago fixed the “repeated update request problem” at least on my Win10 Home installation. And I’m quite sure that the workaround is also applicable to Win10 Professional installations. Standard users without admin rights will need the assistance of an admin. Regrettably I do not have the technical resources to check and verify it in a Professional environment.

I am running German localisations of Windows 10 and HiSuite. Hence, some of the paths and menu items may have slightly different names compared to your installations. Additionally I’m not a native speaker. So please excuse my mistakes in advance.

While searching the internet for information regarding the “repeated update request problem” I saw so many people looking for a solution. So I think it's worth publishing my workaround here in this forum.

My current Win installation is Windows 10 Home, Version 1809. It has 2 defined users:
-1 admin user (with admin rights)
-1 standard user (without admin rights)
The admin user is only used for PC administration, e.g. installations.
The standard user is used for all other computer work, hence also for running the Huawei HiSuite.

In order to find out what is wrong with the current HiSuite version I monitored and traced the runs of the HiSuite installation program as well as the runs of the HiSuite application program itself several times using “Process Monitor” from “Windows Sysinternals”. Afterwards I analysed and compared thousands of lines in the generated log files.


Here are very briefly the results of my analysis:

After starting the installation program the user is asked to allow the installation of HiSuite by entering an admin password. Having entered the password the installation begins. Subsequently all the update and version information is stored to what the contents is of the Windows environment variable LOCALAPPDATA at start of the installation program. Because the admin user is the owner of the installation process the path is set to:
C:\Users\*myAdminUsername*\AppData\Local.
As long as the Hisuite session is not terminated everything works fine.

When the standard user is starting the Hisuite program for the next time all information will be read from what the contents is of the Windows environment variable LOCALAPPDATA at start of the application program. Because the standard user is the owner of the application process the path is set to:
C:\Users\*myStdUsername*\AppData\Local.
(Please note the difference!)

Hence, the updated version information cannot be found, because it is in the personal profile of the admin user *myAdminUsername* used at instalation time. This is the reason why the (standard) user is asked to update HiSuite endlessly.

IMHO this is a severe conceptual fault in the data modelling of the HiSuite software. In case of using multiple users on one Windows machine –as I do it and all Win10 Professional owners do- all important information –especially update and version information- must be made available to all(!) Windows users! This information mandatorily has to be stored in what the contents of the Windows environment variable ALLUSERSPROFILE is. And the content in both cases always is:
C:\ProgramData

The Huawei developers and testers didn’t do a good job (*understatement*). From my point of view it is 100% sure that they definitely tested the HiSuite installation and application programs only with one user having full admin rights. They didn’t test it -not even once- with a standard user! Otherwise they must had found the current error before deploying it to the public.

Of course, Max’s recommendations 1 to 5 mentioned above are important to consider. But for me it is a shame that the "poor" application users are requested to reinstall the application software and do a factory reset of their smartphones. Recommendation 6 and 7 will definitely never fix the problem with the current issue.

I’d very much appreciate if someone from Huawei Development fixes the above analysed and extensively described severe conceptual fault immediately.
_____________________________________________________________

Here is my workaround in 14 steps:

1. Download the latest HiSuite-Version from the English Huawei page
(as of 28.01.19: HiSuite_8.0.1.300_OVE.zip).
http://consumer.huawei.com/minisite/HiSuite_en/

2. Log on with your admin user.

3. Unzip and install the downladed HiSuite version

4. This step and step #8 are currently necessary only because Huawei is not able to keep their download website up-to-date.
- the latest version on the Huawei download website is(as of 28.01.19): HiSuite_8.0.1.300_OVE
- the latest version found by the Hisuite application is(as of 28.01.19): HiSuite_9.0.3.300_OVE
The purpose of this is step to retrieve the version 9.0.3.300 installation file and save it to your disk.

Run HiSuite, let HiSuite search for updates and save the installation file by searching in
"C:\Users\*YourAdminUsername*\AppData\Local\Hisuite\userdata\LiveUpdateHisuite\
full\HiSuite V500R001B007D30SP00C06\11469A986FD21AA5"
(Letters and numbers in the directory name may be different)
for the installation file the newest HiSuite version (as of 28.01.19: HiSuite_9.0.3.300_OVE.exe).
Copy/save it to a separate directory (e.g. Downloads).

5. Terminate HiSuite.

6. Open Windows Services and terminate the Windows service „HuaweiHiSuiteService64.exe“

7. Open the Windows Task Manager, select „Details“ and terminate –if existing- all processes belonging to HiSuite or with "HiSuite" in their names.

8. See step #4 in order to check whether this step is necessary.
Execute the install file previously saved in the separate directory

9. If existing, rename the directory
"C:\Users\*yourStdUsername*\AppData\Local\Hisuite“ to
"C:\Users\*yourStdUsername*\AppData\Local\Hisuite.bak
(only for backup reasons; directory can be deleted later if everything works well)

10. Copy the complete directory
"C:\Users\*yourAdminUsername*\AppData\Local\Hisuite\*.*“ to
"C:\Users\*yourStdUsername*\AppData\Local\Hisuite\*.*“.

11. Re-start the Windows Service „HuaweiHiSuiteService64.exe“.

12. Log on with your standard user.

13. Start HiSuite and check the displayed version. It should be up-to-date now.

14. Important:
Last not least manually update the paths shown under „Options -> Screenshot“ und „Options -> Backups“ to a directory where the standard user has read/write permissions (e.g. to
„C:\Users\*yourStdUsername*\Documents\Hisuite\backup” and
„C:\Users\*yourStdUsername*\Documents\Hisuite\Screenshot“
Without write permissions HiSuite will raise an error message. Creating backups or screenshots will not be possible!
Hi

we don't pay your devices to get the above lengthy and hard to follow solutions. Please correct your Hisuite software. Simple!
Userlevel 7
Badge +6
Hi @alihormati,

Could you please tell us what situation you are facing with the HiSuite?

A brief description and screenshots (if possible) will come in handy.

Looking forward to your reply!

Best wishes,
Max
Hi @Max

please read all previous posts in this thread from @AlanAliwoood, @oubakir1, @Jeffb and me (@NorbyB). We all -including @alihormati- have the SAME problem with HiSuite:
"Repeated requests to update HiSuite software" (see topic of this thread!)
There is no need to describe this buggy situation again and again.

And the best for you is that the bug in the installation procedure and application program is already analysed and located! You can find the analysis and my workaround in my post above from 31.01.2019 (see here).

I am repeating my request from above:
I’d very much appreciate if someone from Huawei Development fixes the above analysed and extensively described severe conceptual fault immediately.

So please do us a favour: Print out this posting, send it to your Huawei Software Development and let them fix the bug!
Userlevel 2
Id also like to see a update to hisuite to system restore CLT-L29 I see other p20 pro handsets are on the supported devices list I believe this will fix my major issue with my p20 pro @Max that I am still waiting for a response after being asked to PM you
Userlevel 7
Badge +6
Hi all,

Thank you for taking your time to report on the situation and providing us with further information.

We have taken your feedback, opinions and comments into account and escalated the provided information further to the appropriate departments.

Should we have any news, we will keep you updated on the situation!

Have a lovely day!
Max
Hi Max!

I have the same issue. The difference is that, when i created a new profile on my pc (win 10), it worked fine for 3-4 days.
But i dont want to create profiles every week to use my phone with connected pc.
Do you have any solution yet?

Thanks

G
Hi Max!

I have the same issue. The difference is that, when i created a new profile on my pc (win 10), it worked fine for 3-4 days.
But i dont want to create profiles every week to use my phone with connected pc.
Do you have any solution yet?

Thanks

G

@Max : missed the @ 🙂
Hi all,

a few days ago Huawei Development released the new HiSuite version 9.1.0.300_OVE ☺. Unfortunately they didn't fix the conceptual error which we described here in this thread and even provided a solution ☹☹☹

In order to repair the new version 9.1.0.300_OVE on my computer I had to repeat the
steps 2, 5, 6, 7, 9 to 14 of my workaround
as described above (see link) after the automatic HiSuite update had been performed.

@Max: What is the current status of this bug which you "escalated...to the appropriate departments" on 13.Feb.2019? This is already more than 3 months ago without any further information...

Cheers
NorbyB
Here is the solution i downloaded the latest version and installed it doesnt ask for updates anymore

https://androidfilehost.com/?fid=6006931924117883305 (HiSuite_9.1.0.300_OVE.exe)
I have just run into the exact same problem. HiSuite is trying to update to 9.0.1.303_OVE. This thread contains a very clear and detailed description of the software DESIGN FAULT that prevents Hisuite from updating when run on W10 as a standard user (i.e. a user without admin rights). It is very disappointing that in 8 months Huawei have not fixed this.
i have a P30 pro it is always doing this... what do i do? all apps are updated...
I'm also have this problem with hisuite looking for latest update, is there any solution for this problem as I can't backup my phone.
Norby's analysis is correct, this a basic programming error caused by not following Microsoft Windows development guidelines regarding permissions and folders.

10 months and 14k views later, can we assume the Huawei has no intention of correcting this software bug that prevents HiSuite from updating?

Or are you just going to continue to ignore it?

Reply