Question

VPN Compatability

  • 3 June 2019
  • 9 replies
  • 817 views

Have tried a number of VPN apps. Clicking on connect causes the phone to reboot. Have tried adding exemptions to battery management as well as clearing cache and factory reset. As the same apps run on my Media pad, I can only conclude that there is a compatiblity issue with the new version of Android and or the EMUI.

9 replies

Userlevel 7
Badge +7
I recommend protonmails VPN it's free

Also consider trust.zone but that is a paid service

Both have standalone apps that work without needed to manually configure
Userlevel 4
Badge +1
@RevSJM Also give Tunnelbear a go. You get 500MB free per month and another 1GB if you send their promotional tweet The subscription price is reasonable, not the cheapest though.
I've had good experiences with them on a number of devices.
Tried Protonmail. It's not a connection / setup issue. When I select a country to connect to the phone reboots. So it seems that initiating a VPN connection is causing some conflict with either the O/S or EMUI. I have also tried other VPNs with the same result. All work fine on my Media pad which is running an older version of both Android and EMUI.
Userlevel 6
Badge +4
@RevSJM , Can you confirm which device you are having issues with. Are you having connection issues when you try to add the VPN via Settings> Wireless & networks > VPN > Add VPN network. Thanks.
The device is Y6 2019. System logs in original post. The issue is not with creating a VPN connection. I'm a network engineer and have successfully created these across multiple devices and o/s'.

Once installed and logged in, you then go to select a country you want to use as your tunnel for VPN. Once selected the connection initiates, then seconds later the phone reboots. It is not the connection dropping although that has occurred with some VPNs but that once on VPN the phone reboots.
Userlevel 6
Badge +4
@RevSJM , thanks for clarifying. I've flagged for the support team to see if they can provide any insight on this issue.
Userlevel 7
Badge +11
Hi @RevSJM,

Sorry for the lack of replies! Are you still having these issues? Or did you manage to solve it in the meantime?

If not, please contact our support team directly as the community does not seem to have an answer for you.
Hi @RevSJM,

Sorry for the lack of replies! Are you still having these issues? Or did you manage to solve it in the meantime?

If not, please contact our support team directly as the community does not seem to have an answer for you.

Yes, but I have now changed my phone. The issue in my opinion is caused by the battery optimisation software used by Huawei as I have had similar issues on other devices.
This can be moved to closed.

Reply