Answered

Huawei Mate 20 Pro - Camera - Portrait Mode - Impossible to Swipe and Change Effect

  • 18 May 2019
  • 3 replies
  • 834 views

Hello Huawei team and users,

I have recently received new Huawei Mate 20 Pro. On the first day I tried all of features and it took me very short time to see this problem.

On Camera and Portrait mode I try to change and select different options. When I open Effects for the first time, it works fine and I am able to choose any effect by swipping between them. Unfortunately, when I try to change effect for the second time, it is impossible to swipe. It gets stuck all of the time. I need to restart my camera (by force stopping the app) to fix this. But once I try again, it is always the same. Please see video for better understanding.

Have you ever faced this problem? Any ideas how to fix it?

Video link:
https://youtu.be/ZOMT0_9F_bs
icon

Best answer by DeividasDagilis 10 June 2019, 21:33

Hello,

Solved!

Reset of factory setting helped.

However, after reset, I changed few parameters once again and received the same issue. Then I decided to dig a little bit deeper. The real problem is that there is some kind of a bug, when you switch off "Animation" (Settings > System > Developer Options > Drawing Section and Animations). I set all off them to "Off" and noticed that the same problem repeats immediately.

So, if you set everything to "Off", bug re-appears.
If you set everything to "1x" as a default setting, everything works fine.
If you set "Window animation scale" to "Off", "Transition animation scale" to "Off" and "Animator duration scale" to "0.5x", everything works fine.

Conclusion, "Animator duration scale" cannot be set as "Off", if you want to avoid this "bug".

It would be really nice to see if this can be checked on the other devices. Receiving a feedback is really appreciated!
View original

3 replies

Guess I need to send it for warranty repair. Cannot find the same problem in whole internet..:/
Userlevel 7
Badge +11
Hi @DeividasDagilis,

Welcome on the community! Before you send it for repair, please take a look at this thread. A simple reset might do the trick.

Will you keep us updated? 🙂
Hello,

Solved!

Reset of factory setting helped.

However, after reset, I changed few parameters once again and received the same issue. Then I decided to dig a little bit deeper. The real problem is that there is some kind of a bug, when you switch off "Animation" (Settings > System > Developer Options > Drawing Section and Animations). I set all off them to "Off" and noticed that the same problem repeats immediately.

So, if you set everything to "Off", bug re-appears.
If you set everything to "1x" as a default setting, everything works fine.
If you set "Window animation scale" to "Off", "Transition animation scale" to "Off" and "Animator duration scale" to "0.5x", everything works fine.

Conclusion, "Animator duration scale" cannot be set as "Off", if you want to avoid this "bug".

It would be really nice to see if this can be checked on the other devices. Receiving a feedback is really appreciated!

Reply