Question

Dead pixels on Mate 20 Lite camera sensor

  • 29 November 2018
  • 1 reply
  • 398 views

Userlevel 4
I've only had this phone for a few weeks. Why are there dead pixels on the camera? What sort of low-quality parts are being used on this so-called flagship series?

Since the image will be compressed, here's a full-sized version of an image: https://imgit.org/im/zep

Here's a bit of that image cut out (I swear it's not the game Asteroids!).
  • Each one of the badly-drawn circles represents one area with a faulty part of the sensor
  • Each one of these shows on all photos with dark backgrounds.
  • Quite a few, especially the large clusters, are very easy to see on the screen (where I noticed this at first)
  • This was taken on 'Pro' mode, although the same happens with all modes
  • Rear camera
  • Section shown is approx. top 1/5 of image. The rest of the image is not as bad, but still another 50-100 areas like the ones shown.


1 reply

Userlevel 7
Badge +6
Hi Piers,

Sorry to hear of the situation. In this case i would recommend that you do a backup and then a factory reset to the device and also inspect and see if any dust particles are upon its glass.
If the images remain the same we would have to book the device in for service and have our technicians take a more hands on approach.
Within the UK region we offer a postal repair service, a booking for which can be made either by mail,chat or hotline at https://consumer.huawei.com/uk/support/ . Or if you preffer i can assist you in this regard via PM

Hope this helps,
Max

Reply