Dual SIM problem. I pick SIM 2 to make a call but phone uses SIM 1

  • 7 November 2018
  • 18 replies
  • 23958 views

I've got dual SIM version LYA-L29 and two cards inside. One is UK Three with international calls barred and one is foreign T-Mobile. I tried to make a call using SIM 2 but everytime I try it phone displays info "SIM 1: Call forewarding active". Why I can't use SIM 2 despite choosing SIM2 to make a call?

18 replies

Userlevel 7
Badge +6
Hi MMirkat,

The Mate 20 pro Dual SIM version Lya-L29 is a Hibrid stand-by dual Sim which will allow only one Sim to be the main active one.
To change to the SIM2 you should go to Setting and touch Dual card management. You can configure both SIM cards as desired.
From there you could enable or disable a Sim card and also you could select the default one for the data services.
If you disable a SIM card, you will be unable to use it to make calls, send messages or access the internet.
Also if you select Dual SIM calling, you can configure whether you want to select a SIM card manually or use the default SIM card each time you make a call. If you choose to use the default SIM card, your phone will use that SIM card for all outgoing calls.
Hope that will help you configurate your main SiM.

And as always if you need any further assistance please feel free to contact us via forum or via mail, chat or hotline at https://consumer.huawei.com/

Best wishes,
Max
Hi Max,

I have same problem, and the problem is that even after switching to SIM 2 as default one, it still makes calls from SIM 1. It seems that SIM 2 is used only for receiving calls no matter how it is configured in phone settings.

I also tried not setting default SIM, then I have 2 buttons to make calls (SIM 1 and SIM 2), when clicking on SIM 2, it still calls from SIM 1.
I have the same problem, saying that this phone is blah blah hybrid stand by is nonsense. When we buy a dual sim phone, it should be dual sim. Not even one supplier is talking about this 'hybrid' thing. This phone should work as advertised.
My Mate 10 did that TRICK without any issues.
Swapping the sims does'nt work. When calling my customers i have to shut off SIM 2. Very convienent for sure. Better have two phones then lulz..
I have the same problem... and SIM 2 does not make outgoing calls even when I shut off SIM 1

I can only receive calls from SIM 2, however it does not make outgoing calls.

I have already racked up a huge bill on my other SIM card for making international calls thanks to HUAWEI!!!!!

Why do you release phones when you are not sure about the functionality!!
Userlevel 7
Badge +6
Hi all,

The dual sim hybrid setup has been a staple for several years, but i do understand the confusion it creates. I will forward this topic as feedback to our R&D and Marketing teams to avoid further misunderstandings in the future.

Best wishes,
Max
Hi Max,

So you're saying we're all screwed buying a 1000EUR phone that isn't 'real' dual SIM as advertised?
I mean, Huawei should replace my phone for a full capable dual sim, just like my Mate 10 Pro was before it fell 12m and shattered to bits.
I mean, i expected it to work the same or better, not worse.
Btw i checked my bill 243,82 EUR for calls made with my private SIM instead of the buisiness SIM. Thanks for that 🙂

If i select my work SIM for calling, it doesn't even notice me that it is calling trough the other SIM card.. I only noticed after a week because one of my customers asked me why i was calling with a number he doesn't know..

Thanks for your reply on this one.
Hi Max,

We understand the meaning,there is no confusion, however it is not working, As in the features in the settings DO NOT WORK !!
Its not an understanding issue, its a fault !

SIM 2 (outgoing) does not work even when SIM 1 is disabled... there is a genuine fault!
Userlevel 7
Badge +7
@Mate20pro83

So reading thread I put in 2nd sim.

These are my settings.

Sim1 is my personal sim and sim2/works

When I click on a contact it asks me which sim to dial from...

Tested, called a contact using both sim1 and sim2 and works as intended.

Checks:

Do you have the dual sim version?

Single sim has same sim tray but it's only for nm card.

Is your device unlocked?

If it's locked only main sim provider may work.





My build is

Yo,

When i dial with my work number (work sim turned off) it states 'mobile network not available'. Texting and using data are OK.

When i turn on the sim and choose to dial with the work sim, it dials with my private sim without warning that it's using another sim.

Again, to be clear... Though, data, texts (both incoming and outgoing) and incoming calls working without issues, again to be CRYSTALCLEAR just can't call with that sim, first i thought it was an issue with the card, so i've got it replaced. Didn't work.

See attached pic.
Userlevel 7
Badge +7
I think it's your carriers compatible with device.

Is your device loved to one network or did you buy device sim free?
Simlockfree, both sims are from the same carrier, if i phisically take out my private sim i can call in either two of the slots. My dual sim settings are the same as yours.

@chillphone it's the same settings as you, it does not work, at first I thought there was a problem with my SIM card so I tried it in another phone and it dials out, however either tray it only recognized the Sim and allows incoming calls.
Userlevel 7
Badge +7

@chillphone it's the same settings as you, it does not work, at first I thought there was a problem with my SIM card so I tried it in another phone and it dials out, however either tray it only recognized the Sim and allows incoming calls.

Your device must be locked by network provider.

Try second sim as same network as the first.

I bet it will work
It's unlocked .. I am using 02 and lycamobile on a three handset
@chillphone you just don't have this problem so can't relate. My issue has been escalated by Huawei support Benelux at this time.. Hope they sort it out. This costs me alot of money..
Hello mmirkat

I've had the same problem and for me hard reset / wipe to factory data helped (when phone is turned off, turn it on with volume up button pressed), probably there is some bug in system software. Please remember to make backup before that operation (ex. with HiSuite on computer). Try it out and please let me know if it helped.

Best regards,
Lukasz
Oh, boy..

Thanks @Lukasz, a factory reset in the normal options didn't do the trick, the hard reset via bootloader did the job. Thanks a lot.

Cheers!
Userlevel 7
Badge +7
Oh, boy..

Thanks @Lukasz, a factory reset in the normal options didn't do the trick, the hard reset via bootloader did the job. Thanks a lot.

Cheers!

I'm glad your issue is resolved however I've edited your post, please refrain from posting abusive messages.

Reply