Question

Huawei Mate 20 Pro not connecting to public wifi

  • 28 February 2019
  • 16 replies
  • 5716 views

I've been trying to log into my school's wifi and I am unable to.

Usually on an iphone, I can click on the service, a screen will pop up that I can type my user & pass into, and then it verifies the connection and all is well.
But, with my new phone, I can't even connect. I click the wifi I intend to use (named TenisonWLAN), it tries to connect for a little while and then it stops, telling me that the connection timed out and failed.
I've attempted changing the method, but nothing seems to work. I've restarted my device, reset my network settings, i've done everything.
Connecting to a wifi service at home is fine, but I think because to log into my school's wifi using a user and a password that pops up on a webpage, it's having a struggle figuring it out.

Could someone please help? I don't want to always resort to using my data.

16 replies

Userlevel 6
Badge +5
Sounds like you've tried a few things already - did you try to forget the network?

Settings/Wireless & Networks/Wi-fi/Tap on the network and choose Forget.

Fingers crossed....

Steve
Userlevel 6
Badge +7
Hi @kellymvree

I've seen a few other people have this issue and it's something to do with how the public WiFi is handling security certification or something like that, the phone won't connect as it's trying to keep you out of harm.

I just copied his answer here for you and hopefully that helps, regards Jase

Best answer by @Redous in this thread.
Hi,

So i have found a work around on how to get public WiFi working. I downloaded several browser applications and found that only 1 browser identified there was a certificate problem but giving me the options to allow me to go through and bypass the security. I am glad this security is in place but its a pain in the backside not being able to bypass it.

Download Firefox and it will allow you to choose an option to add the address to safe list which will then bypass any security protocols.
Hi @kellymvree


I've seen a few other people have this issue and it's something to do with how the public WiFi is handling security certification or something like that, the phone won't connect as it's trying to keep you out of harm.

I just copied his answer here for you and hopefully that helps, regards Jase

Best answer by @Redous in this thread.
Hi,

So i have found a work around on how to get public WiFi working. I downloaded several browser applications and found that only 1 browser identified there was a certificate problem but giving me the options to allow me to go through and bypass the security. I am glad this security is in place but its a pain in the backside not being able to bypass it.

Download Firefox and it will allow you to choose an option to add the address to safe list which will then bypass any security protocols.

this is an unclear response, I did download Firefox but idk? what to do now? ahhh
Sounds like you've tried a few things already - did you try to forget the network?

Settings/Wireless & Networks/Wi-fi/Tap on the network and choose Forget.

Fingers crossed....

Steve

yeah I'd done that one over and over as well, seems I've tried most everything at this point
Userlevel 6
Badge +7
Hi @kellymvree I've done a little bit of research and think I've found how to fix this for you.
I don't have the exact same phone as you but I think the process should be pretty much identical.

First open up settings,
Then click on apps,
Click apps again,
At the top right hand side of the screen you should see three vertical dots, click them,
In the drop down menu click show system processes,
Scroll down the list and click on captiveportallogin,
Now click storage,
Then click clear data.

You will likely need to re enter any WiFi passwords you have but try this first and if it works awesome, if not there's another step we can try.

Regards Jase
Hi @Jase

I've tried your method and it hasn't worked. It wont let me connect at all, every attempt is a connection time out and fail. I cant go into google to log in or anything, or firefox. Nothing seems to be working 😕
Userlevel 6
Badge +7
Ok try this next,

go to settings - apps - select Chrome and disable it. You'll get some warning messages, don't worry, you'll be able to restore Chrome again when this problem is fixed.

Now, to confirm that everything is ok open the Play Store, tap on the search icon (magnifying glass) top right, type 'Android System WebView', make sure it's enabled and update to the latest version if the 'Update' button is available.
Restart your phone and see if you can login to public network.

I just googled your problem and method seemed to fix the issue for others , I hope it works cause I'm not sure what to try next if I'm honest.

Regards Jase
Hi! @Jase I've fixed it lol, I had to manually put everything into the system and it eventually allowed me to connect. Thank you for your replies!
Userlevel 6
Badge +7
Hi! I've fixed it lol, I had to manually put everything into the system and it eventually allowed me to connect. Thank you for your replies!
Oh that's great and no worries, I'm quite good at not actually fixing stuff lol
Hi, @kellymvree I'm glad you solved the issue. I've been having the exact same problem on my Huawei mate 20 pro I've tried all the steps mentioned on this post and nothing seems to work. Could you please explain how you manage to fix it?
Many thanks
Hi @DGamez,

You just need to do these steps and it should connect (I'm pretty sure this is how I did it, It's the weekend so I'm unsure if this is completely correct but,, I'm pretty sure)

  1. Add Network
  2. Type in Network name (whatever it pops up as)
  3. set the 'Security' to '802.1x EAP'
  4. change EAP method to 'PEAP'
  5. Phase-2 authentication to 'MSCHAPV2'
  6. CA certificate to 'Do not validate'
  7. put your user into the 'Identity' section (if this doesnt work then try the 'Anonymous identity' section)
  8. put your password in and hit enter
If this isn't correct I'll tell you the proper way as soon as I'm back at school tomorrow 🙂
Thanks for the quick reply @kellymvree, I tried your steps earlier today but my public WiFi doesn't have a login or password. It's always open and all it asks is to accept the terms and conditions to be able to access the WiFi. That's where the problem is, the terms and conditions site never loads up on my Huawei phone but did on my older phones. I've attached a few screenshots so you can see what's happening.
If anyone could guide me into a solution I would greatly appreciate it!
Thanks again

@DGamez
I work in the same place as you given your Wi-Fi list and am having the exact same problem. Have you managed to find a work around?

Or anyone else for that matter?
I've tried to download Firefox but can't seem to find out how to addthe conectivity link to my safe list
I haven't solved the problem yet, @Yohan56. This as been going since December when I got the Huawei device, I've contacted our IT department and they are aware of it but they can't help us Huawei users with this matter. It's getting really frustrating to the point where I'm thinking of swapping to another android device.
@DGamez

Try logging into UHCWCORP with your credentials - not as good as public WiFi but I can at least get WhatsApp messages and emails coming through
Hi,
I had the same issue. I went on vacation with 3 Huawei 30 Pro (my sons have these devices as well). Mine worked like a charm in first try. The two others were not working. This was never related to the device itself It was related to Google Chrome, which is the default browser. What I had to do, was do deactivate Google Chrome, and restart the device. After initial setup of the browser, it went straight to the Hicloud check page and moved forward to the login page. It took some time to figure out. My sons were killing me cause they were offline 😉

Reply