Question

Huawei Mate 20 Pro Signal Issue

  • 14 December 2018
  • 11 replies
  • 6284 views

  • Opening Fortune Cookie
  • 1 reply
I have been using my Mate 20 Pro for about 2 weeks now, after buying it second hand, with nearly no problems. Now, I have no signal. I use Virgin Media, but I have tried with another SIM to no avail.

I have tried restarting the device, cleaning the housing and the tray, clearing the cache partition, and even to the point of factory resetting it, but none have worked. Is there a solution to this?

11 replies

Its not network locked?
No, it's been working perfectly fine before this. I used to have a Google Pixel 2 before this, and the Mate 20 Pro had hugely exceeded it for signal strength prior to this, but now I can't get a single bar, ever.
Then , maybe you need to visit a service center, because I think is just software problem not hardware one. Good luck.
Userlevel 2
Badge
Hi @Isaac !

We are sorry to hear about the situation which has prompted you to write to us.

Regarding your query, we recommend you follow the steps below:

1. Settings > Apps > Apps > More > Show system process > Dialler > Storage > Clear data/Clear Cache, go back and select Force Stop.

2. Then you have to return to Settings > Apps > Apps > More(up on the right side appear 3 dots) > Reset app preferences.

3. Settings > System > Reset > Network settings reset > Network settings reset again to confirm. At the end of the process restart the phone.

I trust this information is of assistance. Should you have any further questions, please do not hesitate to contact us.😀

Julian
Userlevel 4
Bumping an old thread, I've just got a Mate 20 Pro and have the same/similar problem. When the sim card is inserted the phone recognises it, allows me to choose the APN (Vodafone contract) but I don't have a mobile signal. The sim works perfectly in another handset and I have a full strength 4G signal. I've tried the process in the post above without success.
Userlevel 7
Badge +6
Hi @AndrewD71,

Regarding this inquiry, can you please PM me the serial number of your device so I can look into this matter further?

You will find the serial number either on Settings > About phone > Status or on the box of the device.

Looking forward to your reply!

Best wishes,
Max
Hi there, having very similar issues to the people above.

Basically, my mate 20 pro won't show any signal at all. When i place my same giffgaff sim card in another phone it works without any issue. I also have tried all of the advice from above.

Can a Huawei member please help?

Many thanks,

Tom
Userlevel 4
Badge +4
Hi @tomcutajar @AndrewD71 and @Isaac
All of you are facing a situation similar to whats on this thread: https://uk.community.huawei.com/other-smartphones-35/no-network-problem-4670

the most likely cause is that the antenna inside is loose or the motherboard needs changing as per above thread.

The best course of action is to contact huawei for repairs/replacement under warranty.

@Isaac: let us know if you managed to solve this issue!
Hi

I just made a switch from Samsung Galaxy J5 to Huawei Mate 20 pro and i had notice a huge difference in signal strength. The same sim card, same place and on Samsung i had 4g and full bars and on Huawei i have no service, its happening indoors, seems fine outside. I notice Huawei is a lot worse then my old Samsung in this matter. I read that some phones have issues with antenna. So i wonder if mine is faulty or it is just how a mate 20 pro is :D

Regards
Userlevel 6
Badge +4
@virek555 I moved your post here as it's a similar issue and will to avoid duplicate threads. Please try Julian's suggestion:

Hi @Isaac !

We are sorry to hear about the situation which has prompted you to write to us.

Regarding your query, we recommend you follow the steps below:

1. Settings > Apps > Apps > More > Show system process > Dialler > Storage > Clear data/Clear Cache, go back and select Force Stop.

2. Then you have to return to Settings > Apps > Apps > More(up on the right side appear 3 dots) > Reset app preferences.

3. Settings > System > Reset > Network settings reset > Network settings reset again to confirm. At the end of the process restart the phone.

I trust this information is of assistance. Should you have any further questions, please do not hesitate to contact us.😀

Julian
Hi all,

what to do when the "> Dialler" part of the above mentioned solution is not on your Mate 20 Pro? I've set my phone to US English but that doesn't do the trick and I have the same issue as above.

In the city, outside, with no/just 1 bar of 4g, sometimes dropping down to 3g even. While the Iphone XS of my wife is crazy fast... Really annoying.

Thanks for any help in advantage!

Reply