Question

Mate 20 Bluetooth permissions and sound notifications

  • 12 March 2019
  • 26 replies
  • 2885 views

I've not seen the following mentioned in other posts, but problems I have with the phone include:


1) Bluetooth permissions missing.

I have software that tries to automatically turn Bluetooth on or off (Automateit). The problem is that each time the software tries to switch on Bluetooth, the phone always prompts for confirmation to allow Bluetooth permissions. It does not remember that this permission was given. On my previous Samsung Galaxy phone this did work.

This is frustrating, as I'd like to have this automatically done.

Looking at the app permissions menu on the phone, there is no option for Bluetooth permissions, so this cannot be set by default. Please can this be included.


2) Sound Notification per apps.

I have a secure app from a bank that receives emails. The problem is each time an email arrives, it makes a sound. I have gone into the Notification settings on the phone and set all notification sounds to None, yet this still does not silence the phone when a new email is received. The only way I've found to silence it is to completely disable notifications for this app completely.

I'd still like to receive visible notifications, so please can you resolve this issue by allowing sound settings per app, i.e. to select a unique notification sound per app / or even to switch off sounds completely for a specific app.

Thank you.

Peter

26 replies

I agree, for this reason I won't be buying another Huawei phone. It's basic functionality that's just been disabled.
so bad from Huawei not to fix the biggest bug, please explain why we should buy phones when u don't give a crap About customers!. Also 6 phones Huawei in family all is same after android 9 and emui, other manufacturers works not happy but love the phone
Hi,

I've used automateit on a few phones over the years to switch Bluetooth on or off automatically. Very disappointed I can't do the same on my most expensive phone yet, the Mate 20 Pro.
It's a massive oversight of Huawei to leave this feature out. Android 9 also has a feature to enable Bluetooth when driving using a developer mode setting... But sadly it is not available in the Mate 20 Pro...which would be more pro if it allowed such features.

Please make it so Huawei.

Steve
Bought also P30 and same problem. It's very boring to spend 600 euros to have a phone with this limitation.
I usually do not use bluetooth function on always, and i want it only when i'm driving. I don't want to risk during driving because i must unlock the phone, pull down option menu and click on bluetooth icon to start it.
I use app like Macrodroid and Automate it just to forget to change bluetooth state when i'll get into the car.

Huawei please do something for us or tell us why you decide to lock bluetooth enable function to 3rd part app (wifi have not this problem).
Android auto will stay open and running until you will close it
I know that from Oreo and above , any app which is not foreground , android kill it .
What do you mean?
But will Android kill off stuff that isn't needed on its own ?
Yes...let me know. Now i am working to finde the way to kill Android Auto when not necessary
Thank you for trick
Therefore from my custom app , instead to turn on bluetooth , launch Android Auto . I will try .
I agree with you that problem is EMUI. I have also other phones (S10e and MI9 SE) and this problem is not present on them.
Actually the only solution that i have found for who use Macrodroid or Autometeit, is to make a macro that will start Android Auto app.
In Android Auto's setting there is the possibility to switch on bluetooth everytime app start running and in this case no prompt to allow this are shown.But this means that you must close Android Auto when you want to use your phone.

But this is better than nothing at now, hoping that Hawei will solve this.
I have tried on a Pixel 2 XL with android 9.0 and this problem does NOT exist.
So this issue is child of EMUI 9.x 😂.
Updated my Mate 20 Pro to EMUI 9.1 and the issue of Bluetooth permissions still remain.
I think that solution to this problem doesn't interest 😞.
I have a MATE 20 Lite and after latest update at EMUI 9.0 , I have the same issue .


I use an user app to turn on/off Bluetooth automatically when I am into car , but every time Bluetooth auto turn on/off by user app , an user permission pop-up appears to confirm action .


So I am obligated to unlock the device and press OK . Major distraction while driving .


Have anyone a solution to solve the problem ?


Thanks
Some news about bluetooth matter?

Thanks
That's great, thank you @Max

Really looking forward for a fix in the next update
Thanks Max! Great if Huawei could provide a workaround for these issues.

I hope this also includes a fix for the other issue I mentioned, i.e. that there is no separate volume control for notifications.
Userlevel 7
Badge +6
Thank you @PeterRoux and @jappish for bringing this to our attention.

We'll forward your feedback to our research&development department and we'll try to add this feature in the next system update.

I apologise for any inconvenience this may be causing in the meantime.
I have the exact same issue with bluetooth automation on my P20 Pro since the update to Android 9 (worked fine on 8.1). I'm using Macrodroid and I have made sure it has permissions to write system settings, and also granted "Device administrator" privilages.

@Jase I have shared screenshots of the pop-up and also a simple way to reproduce the issue if you are interested.

A simple search on the web shows that many users are complaining about this "feature"

I wish there atleast was a way to "remember choice for this app" checkbox

Userlevel 6
Badge +7
You can set different volumes for media(which include your notifications) and ringtones. Just hit the gear icon when turning up your volume and adjust each to your preference.

I'm not sure how to fix your other issue but could you maybe let me know exactly what your trying to do within the app and then I can download it to try replicate your issues.
Regards Jase

Edit, sorry I just realised that although media volume does turn the volume of notifications up and down while previewing the sounds it doesn't actually affect the volume under normal use 🙈
Hi Lizzie / Max,

Thanks for your help, but I believe issue is that Phone and Notification sound settings are joined. You cannot currently set a different volume for notifcations vs for phone calls. According to what I have read, this is an Android default for some reason, but some manufacturers (e.g. Samsung), have implemented that these can be set separately. It would be good if Huawei could also implement this change.

As for the Bluetooth, if I go to Settings->Apps->Permissions, there is no "Bluetooth" permission setting to set. @Max, regarding your "Quick Solution", please note that I can only get to this "Write system settings" options by going to Settings->Apps->Apps-> Then I select AutomateIt Pro app -> Advanced. However this is already enabled, but still does not make any difference, Whenever it tries to follow a rule to enable Bluetooth, the system prompts for permission to do so. I have also downloaded another app named "Automate" and tried to similarly have Bluetooth switched on programmatically and this also does not work, again asking for permissions by the system.

I would love to have a solution to these 2 issues, and thanks again for your help.
Userlevel 7
Badge +6
Hey @PeterRoux , welcome to the community!

Some apps have access to change system settings and some apps don't. That's the reason why Automateit can't enable/disable Bluetooth and that's also the reason why your banking app overwrites the notification settings.

For a quick solution, please open Settings > Apps & notifications > Apps > Look for Automateit and make sure "Write system settings" is enabled, then do the exact opposite on the banking app or try to find notification settings within the app.

Please let us know if this helped!
Max
Userlevel 1
☺
Userlevel 1

Hi @PeterRoux, maybe the function "do not disturb" is helpful for your problem, please feel free let me know if it is effective.Thanks Lizzy but that won't work as I do still want to receive other notifications. I just need then silenced.


This function will only ban the ring and viberation, you can still recieve the notification bar, please try to open Settings and go to Sounds > Do not disturb. Toggle on the Do not disturb switch, some third-party apps may continue to ring when Do not disturb mode is enabled. Configure the in-app settings to mute notifications from these apps.
Hi @PeterRoux, maybe the function "do not disturb" is helpful for your problem, please feel free let me know if it is effective.

Thanks Lizzy but that won't work as I do still want to receive other notifications. I just need then silenced.

Reply