Question

Mate 20 Pro does not use data over WIFI if it is also connected to Mobile data


  • Fearless Explorer
  • 5 replies
First of all - i do not use much mobile data when on the move. Had the same subscription plan for years and never ran low on mobile data.
But a few weeks ago i installed a ring camera. This lets me view live video from my yard on my phone.
After having tested the camera just after installing it - it got a text from my provider that i was almost out of mobile data.
That was funny i thought, since i was at home, and connected to my WIFI network.

After investigating what app draws data, and checking the WIFI data tab and the Mobile data tab - ALL data on my phone, chrome, ring, etc etc have been pulled over mobile network. Even when at home, at friends or at work. All places where i am connected to wifi. (to clarify, the log shows all data going over mobile data well before the ring cam was installed - as far as i can see it has never used wifi).

I talked to my brother who got the exact same phone (bought on my recommendation) - but lives in a different house, with a different router, etc. - he has the exact same problem!

Now we both have tried all kinds of options turned on and off. First suspect was WIFI+ . On or off makes no difference. Voice over LTE - on or off - makes no difference. Also tried to force it to only use 3G - no difference (have excellent 4G LTE coverage in my house).

Also - if i DO turn off mobile data completely - it pulls data over wifi just fine. No problem at all. Turn back on mobile data - all data again goes over cell network.

Shouldn't make a difference but both me and my brother is on high speed fiber network with high end routers.

Have anybody experienced anything similar? Any solutions?

11 replies

One more thing - thanks to this issue i have now used up my data quota for may - and the provider have throttled data speed to a crawl (65kb or some such). If i am on mobile data and wifi - things move at a crawl.

Forget about viewing video - forget about viewing ring cam. Super slow. Turn OFF mobile data - and all works super fast again (it then starts to use WIFI...which has been on and connected all the time).

Reason i mention this is that if the system somehow considers mobile data faster and more responsive than my WIFI....well that cant be the case.
Userlevel 6
Badge +7
Just checked and my apps are predominantly pulling data over wi-fi and not using mobile data while at home, I'm also on the mate 20 pro and have fast fiber at home. Could you check that the apps you are using have appropriate network access in the settings. You can find it under data usage, in the wireless & network settings.

Regards Jase
Yes all apps have all options for access to "on". I also tried (and my brother) to reset network settings. I also checked the developer settings for the "always use mobile data" setting - but it was off.
Just tried something - i havent had mobile data on for a while due to being over limit and it is slow then. So i turned mobile data "on" - here at home while being on WIFI. Started ring app. Takes a while and i get "you have poor network connectivity - try connecting to wifi - (retry)". I pull down the settings and turn mobile data "off" - boom - image from camera shows up instantly.

I.e. the phone seems to think that it should ONLY use mobile data if it is on - regardless of WIFI status.
Userlevel 6
Badge +7
That's really strange, if you were having issues connecting to your wi-fi I'd have thought it would have been something to do with that, but you don't have any problems when you switch off your mobile data, so it's not that either 🤷.
I wonder if anybody else has got an ideas?
Sorry I'm stumped

Regards Jase
Userlevel 6
Badge +7
Just tried something - i havent had mobile data on for a while due to being over limit and it is slow then. So i turned mobile data "on" - here at home while being on WIFI. Started ring app. Takes a while and i get "you have poor network connectivity - try connecting to wifi - (retry)". I pull down the settings and turn mobile data "off" - boom - image from camera shows up instantly.

I.e. the phone seems to think that it should ONLY use mobile data if it is on - regardless of WIFI status.

It's it just with the ring app this happens?
No happens with every app - but the ring app in its nature is very data intensive - pulling hundreds of megabytes in a few minutes. In for example chrome - it is just slow to load images. Turn of data - and chrome is lightning fast.

My brother claims he noticed this issue a while back after an update. I didnt notice anything, but then again the only data i really pull (before ring) is web browsing - and thus never got close to my data limit.
Userlevel 6
Badge +4
@Jarls , Thanks for joining the community. I've flagged your post to the support team to see if they help. You can contact them direct via the hotline:

  • Hotline: 08000 886 700
  • Support Language: English
  • Support Time: Mon - Fri 09:00 - 21:00, Sat. 9:00~17:00 (Except bank holidays)
  • Remarks: A note of the IMEI and the Serial Number of your device is necessary before you calling.
Userlevel 4
Badge
Just a quick question as I'm concerned about this, but where are you able to see and distinguish between mobile data usage and wifi data usage. When I look all I see is DATA usage and there is no split
Under data usage tab - you get a list of apps. Click an app and you will see the data usage of that app. On that same page on the top you can select "mobile" and "wifi".

Reply