Question

Mate 20 pro Hide Whatsapp content

  • 7 January 2019
  • 8 replies
  • 4753 views

Hi,

I purchased my Android (Huawei Mate 20 Pro) on Saturday, have had an iPhone since day one!

I am really struggling to hide the contents of the WhatsApp messages, I have clicked hide but show contents on all of the WhatsApp settings but it still shows up. Any ideas?

Thanks in advance.

8 replies

Userlevel 6
Badge +6
Hi,

I purchased my Android (Huawei Mate 20 Pro) on Saturday, have had an iPhone since day one!

I am really struggling to hide the contents of the WhatsApp messages, I have clicked hide but show contents on all of the WhatsApp settings but it still shows up. Any ideas?

Thanks in advance.


Hey @PWJohnson29

Congrats on the Mate 20 Pro. I made similar shift from iPhone myself. Are you trying to hide the WhatsApp message content on lock screen? If so, go into phone settings > security and privacy > face recognition > toggle on 'smart lock notifications'. That should do the trick.
Thank you, yeah just trying to hide the content of the message so it just says WhatsApp message without the start of the message.

Thanks, I have done that, it's worked but it doesn't say who the message is from? And do I need to keep face recognition on?
Userlevel 6
Badge +6
Thank you, yeah just trying to hide the content of the message so it just says WhatsApp message without the start of the message.

Thanks, I have done that, it's worked but it doesn't say who the message is from? And do I need to keep face recognition on?


Ah, yes, I don't think it will display sender if 'hidden'. If you also select 'slide to unlock' in face recognition settings then face recognition will show content of your messages (and sender) but not open phone until you slide up. You do need to have face unlock activated for this though.
Thanks mate.

I don't understand why show but hide contents don't work? Really confused!
Any ideas anyone?
Userlevel 7
Badge +6
Hi PWJohnson29,

Welcome to android and sorry to hear of the initial rough start with it.
From notification management > [The app you wish] >Lock Screen notification > switch those to hide and remove the banners - that should do the trick.
Also check within the app itself if it has any privacy settings that you can tweak.

Best wishes,
Max
Userlevel 5
Badge
Hey @PWJohnson29

I wonder the recommendation shared by @Max helped you? Also @Jmoon and @Yummy shared some tips (here and here) how to handle this issue. It would be great to hear your feedback.

Cheers
Kat

Hi,

I purchased my Android (Huawei Mate 20 Pro) on Saturday, have had an iPhone since day one!

I am really struggling to hide the contents of the WhatsApp messages, I have clicked hide but show contents on all of the WhatsApp settings but it still shows up. Any ideas?

Thanks in advance.
Hey @PWJohnson29

Congrats on the Mate 20 Pro. I made similar shift from iPhone myself. Are you trying to hide the WhatsApp message content on lock screen? If so, go into phone settings > security and privacy > face recognition > toggle on 'smart lock notifications'. That should do the trick.

Thank you very much! it helps me with my notification problem, i appreciate!

Reply