Answered

Mate 20 Pro microphone keeps not workin


Any ideas how to stop it cutting out randomly and then not working till I restart it...
icon

Best answer by jabiralsaidi 7 December 2018, 20:00

Hello dears,

Sorry to delay reply, but I was revived and update (9.0.0.142(C185E10R1P16)) this week, so I think take a while till reply to this topic.
After using the phone more than 4 days, I can say the issue wase resolve after this update, now I can use the MIC.

Thank you all

View original

18 replies

This is a problem for me too, but it only seems to occur after returning to main space after being in private space. Also causes problems when unlocking phone with 'ok Google'.
Amen
Userlevel 6
Badge +6
Hi all,

Sorry to hear of the issue you are both experiencing with the Mate 20 Pro, if you both are willing there a few troubleshootings that i would like to attempt with you and see how they go.
The first one would be stopping the battery management AI. To do this please go to Phone Manager > Battery > App Lunch and swtich it to manually manage.

Please let me know how it acts afterwards.

Best wishes,
Max
Hello all,
I face same issue here, i don't know what is the reason, some time work , some time not.
In whatsapp i cannot send voice message.

Dear Max, i try your advice, but i stuck in App lunch, you mean switch all apps to became manual?
Because there is no battery management AI in this list.

Thank you
Userlevel 6
Badge +6
Hi jabiralsaidi,

Yes, if you switch all apps to manual management then the AI chip that governs and learns from the devices usage will stop.

Please let me know how it acts afterwards.

Best wishes,
Max
Hiya, I have been having this issue (don't have too many details as I only got the phone last night). I have tried your fix, Max and it seems to be working, for now. My concern is the impact of turning off the battery management will have.
Max wrote:

Hi jabiralsaidi,

Yes, if you switch all apps to manual management then the AI chip that governs and learns from the devices usage will stop.

Please let me know how it acts afterwards.

Best wishes,
Max


Hello Max,

After one day of switch from automatically to manual, I see the issue is gone, but I losing the AI feature for battery controlling.
May be I can only switch specific app to manual?

Thank you
Userlevel 6
Badge +6
Hi jabiralsaidi,

Glad to hear the troubleshooting worked. You can turn the apps on to auto-management one by one, but there is more then likely one app that has a feature for the microphone that monitors and turn its on constantly.
That particular app is the one that causing the AI to stop the mic since it registers as a high constant consumer that is not being used.
After you identify the particular app you can remove its permission for the microphone if its not of importance for your daily use of course.

Hope you found this helpful.
Best wishes,
Max
Userlevel 1
K. Will try this.

Any luck on the green tint in the corners?
Userlevel 1
While I'm thinking of it.

I couldnt find any info.

Is there a way to disable the power button.
Where its located is so frustrating because I'm constantly knocking it off. Because the way I hold the phone. My hand is always over it. Or if I go to do volume I always hit it.

Be grrat if there a way to disable it.

If not. For future reference. Power button on the top please 😊
Userlevel 6
Badge +6
Hi Mate20pro,

Thank you for the feedback I will forward it to our dev. and R&D department. 🙂

Best wishes,
Max
Hello dears,

Sorry to delay reply, but I was revived and update (9.0.0.142(C185E10R1P16)) this week, so I think take a while till reply to this topic.
After using the phone more than 4 days, I can say the issue wase resolve after this update, now I can use the MIC.

Thank you all
Hi. I have same problem. If i return from private space, OK Google no longer hears me.
I'm on 9.0.0.153 and still doesn't work.

Thanks
Incidentally.
I use another google account on private spaces. I've turner all voice options off. But ok Google won't work when i return to main space
Userlevel 6
Badge +6
Hi @Sparkybarky,

Have you tried the above troubleshooting steps in regards to the situation you are facing?

Please do let us know!
Max
I will definitely remove mic permission from every app in private space and try again..
I let you know
It works for a while.. But now same problem even though no apps in private space have muc permission.
Only solution is to restart phone
Userlevel 6
Badge +6
Hi @Sparkybarky,

Sorry to hear about the situation persisting.

Could you kindly perform a factory reset of your device? You can find the steps on how to do this here .

Should you have any further questions, please do not hesitate to contact us!😀
Max

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings