Question

Mate 20 pro wifi switch mobile data bug


Anyone come across one of these before? I switched off my WiFi and was using the mobile data and only to find some of the apps cannot get connect to mobile data. My first discovery was google map. Works fine if its connected to wifi but not the 4G mobile data. I thought it was the access point where you can allow or disable them to use mobile data. Tried to set them with permission to all use mobile data and background data etc. Still nothing shown up on the map except cannot connect. I even tested with wifi off and bluetooth off to see if there any interference. No result. I used chrome broswer to see if i can get access to the internet on 4G and wifi. It works. I tried also with other web broswer. Samsung internet browers works. The firefox broswer cannot connect to mobile data however it works on wifi.
I've reset a numerous of times and now getting no where to resolve this. I think the switching between wifi and 4G in huewei is bugged and need attention. Most of the apps failed to use because of this flaw in the design of this phone that failed to switch them to use 4G when wifi is off.

If anyone found a solution that would be great. If its a known issue then its a shame on huewei to put thier latest mate pro 20 in the gutter.

15 replies

Userlevel 7
Badge +6
Hey @Imadomo,

thank you for taking your time reporting this!

Could you tell us how did you reset your device? Was it a simple factory reset from the settings? Did you try a Hard Reset?

We suggest trying the network settings reset if you haven't already. You can do that from Settings > System > Reset > Network Settings Reset.

Let's hope this will help! 🤞
Max
Hey @Imadomo,

thank you for taking your time reporting this!

Could you tell us how did you reset your device? Was it a simple factory reset from the settings? Did you try a Hard Reset?

We suggest trying the network settings reset if you haven't already. You can do that from Settings > System > Reset > Network Settings Reset.

Let's hope this will help! 🤞


Max


I tried network setting at first to see if its possible as suggested but no work. I previously tried to restart the phone and waited for about 10 min for everything to load and nothing. however when i tried today restarting and immediately go and use my app. it works fine again. I even tried it with other apps to make sure and it works just like i said. What got me curious even more is that i'm getting the feeling its the wifi mobile data switch is a real bug cause google map wont work unless i reset the phone and immediately select the app after reset.
This is really a big bug. No wonder i'm ending up costing so much data when i got confused. I think the new update may be the cause of it.

Ps: google map was the one that caught suspicion when it says as below. I think most people don't know yet until they see thier high data bill. Unless you want to try it out be my guess and find me a solution cause its irritating not be able to use apps that need internet. Also to note, no i dont use WiFI+ cause it will eat my limit data, and the reset i did was simple reset. Google map wasn't alone as i tried with other apps

Userlevel 6
Badge +7
Hi @Imadomo ,
I think you might be mistaking what max is asking you, restarting your device is different from resetting and there's also two different methods of resetting your device, a factory reset from within settings and also a hard reset. I see that you have reset network settings but have you done either the factory or hard reset of the actual device? I assume that's what max is meaning for you to try to fix your issues.

Regards Jase.
Hi @Imadomo ,
I think you might be mistaking what max is asking you, restarting your device is different from resetting and there's also two different methods of resetting your device, a factory reset from within settings and also a hard reset. I see that you have reset network settings but have you done either the factory or hard reset of the actual device? I assume that's what max is meaning for you to try to fix your issues.

Regards Jase.


yeah i have tried factory reset. Works like a charm. But when i left the phone on say over night and use it outside on my 4G. It doesn't work anymore. And sometimes in some interm it does n't work. I wonder its a defect on the apps or something making it not reliable
Userlevel 7
Badge +6
Hi @Imadomo,

In that case, can you try the SIM card on a different device to see if it's still having the same issue?

I need this to understand whether the issue is related to the phone itself or the SIM card.

Best wishes,
Max
Hi @Imadomo,

In that case, can you try the SIM card on a different device to see if it's still having the same issue?

I need this to understand whether the issue is related to the phone itself or the SIM card.

Best wishes,
Max

Hi max,

I found the solution to my problem. I set the Carrier aggregation to off thinking it might be whats causing the problem, and it was the culprit. By switching it off the phone is working normal like brand new when i got it. So if anyone had this problem before this will be the best method to start it.
Then again i don't know how carrier aggregation works on huewei. does it uses 2 sim card to use this method or is it just the band wave?

I got a new isssue regarding to mobile data where apps are abusing my mobile data and the frequent sync they do. I'll post this in another thread

cheers

Hi @Imadomo,

In that case, can you try the SIM card on a different device to see if it's still having the same issue?

I need this to understand whether the issue is related to the phone itself or the SIM card.

Best wishes,
Max
Hi max,

I found the solution to my problem. I set the Carrier aggregation to off thinking it might be whats causing the problem, and it was the culprit. By switching it off the phone is working normal like brand new when i got it. So if anyone had this problem before this will be the best method to start it.
Then again i don't know how carrier aggregation works on huewei. does it uses 2 sim card to use this method or is it just the band wave?

I got a new isssue regarding to mobile data where apps are abusing my mobile data and the frequent sync they do. I'll post this in another thread

cheers


Actually, i lied when i said i think i found the answer to this issue, now i can't get into google play store and firefox. The new update seems to made it worst than i originally thought
I'm having the same issue, I wonder if it is due to having strong settings to prevent excessive data use but nothing seems to change it, I can get messages just not maps or images downloading. Where was your carrier aggregation?
Userlevel 4
Badge
Could it be related to roaming settings? The second SIM appears to be roaming..
I'm having the same issue, I wonder if it is due to having strong settings to prevent excessive data use but nothing seems to change it, I can get messages just not maps or images downloading. Where was your carrier aggregation?


Actually i think i found out that this phone has an ongoing problem with the battery saving features which i think it's the cause of the problem, making me thinking its the switching problem, i hope this is the case. The emui stop apps from launching because of the battery saving features, there is a section where you can manually tell it not to stop apps that are automatically launched. I've only tested this in several occasions where i have not put it in power saving mode and it works in most cases. But when you switch it on, the emui stop many of the apps working. I think that is why chrome was able to work and not like firefox or maps because it recognise it shouldn't be blocked. However the features where you tell it not to block the app from lauching doesn't seems to stop emui from blocking your apps. Someone correct me if i'm wrong cause this is an ongoing with huewei products. I only learn recently from reddit when ppl are complaining about how emui power blocking the app launching even when you tell its setting not to.
Could it be related to roaming settings? The second SIM appears to be roaming..
nah it can't be. Otherwise chome won't be online.
Userlevel 6
Badge +4
@Imadomo , sorry the community hasn't been able to resolve this for you. If you are still having issues, you might want to contact the support team direct to see if they can assist you.
I've been having a similar situation, so ill be watching this forum if there are any actual fixes.

what usually happens with my mate 20 pro, sometimes whether im on 4g or wifi, it just does connect, and I'd have to turn on airplane mode, then turn off... then everything works like normal again... it happens to me MANY times a day.

I've tried network reset, factory reset non of these solved the issue... my sim card works perfectly fine in a Note Edge,

Loving the Mate 20 Pro, but having to switch on and off airplane just to access facebook (whether on wifi or cellular) every now and then is becoming quite mundane
I have just got the same issue. Has anyone found a fix to this? My 4g says it has full signal, but when opening anything online it will not load. When i switch airplane mode on and then off i get data for a few minutes then it goes again.
Really appreciate any can give.
Userlevel 6
Badge +4
Hi @NickB86, to resolve the problem it is best to contact the Support Team directly: https://consumer.huawei.com/uk/contact-us/

Reply