Question

Messages "enhanced chat features" (RCS) (iMessage for Android)

  • 4 January 2019
  • 3 replies
  • 3797 views

Userlevel 4
For those of you with a carrier who supports this, are any of you able to get it to work? The option to enable this simply doesn't show up (Messages->Settings->Advanced->Enhanced chat features)

This feature wasn't originally supported on dual sim phones such as the Mate 20 Pro, but according to this article which mentions a user in my country using the same provider as me, allegedly has it working.

I asked my provider about this, but the support guy I talked to didn't seem very informed and couldn't tell me for sure, so I'd like to ask other users here if it works for you.

3 replies

After 4 weeks of debugging: Heureka

statements of Support from Huawei and untrained support of Telekom: we dont support RCS/never heared about it/we send you an email about your question (never arrived)

Device P9 EVA-L19 rebranded to VIE-AL10 running Android 8.0 with EMUI 8.0, european radio and face unlock active, rooted and safety net check ok and playstore certified and device policy not compromised ;)

Sim Providers:
SIM1 4G: blue mobile on Telekom Hungary network
SIM2 2G: Telenor Hungary

I will only answer questions that are precise and longer than 100 words where you exactly provide all your details.

Good luck.

In 100 words or less (or more) - Precisely how did you get yours working?

I have an Huawei Mate 10 ALP-L29 model with stock EMUI 9.1.0 and I cannot get Android Messenger chat features working.

I have confirmed with my Australian cellular provider (Telstra) that RCS is enabled and I got a notice on the phone that it was enabled and I have a version where chat features are shown but cannot be enabled.

This has to be an OS issue or something as everything else required is in place.
Good day

best to try with the following parameters, read until end and then start:

  • only ONE SIMCARD in slot 1, MUST be on LTE/4G, slot 2 NO SIMCARD/empty or deactivated
  • Google LLC Messages Should be setup for default messaging APP, best to uninstall and reinstall the APP in order to be sure to get the latest version.
  • Turn on flight mode and turn off WiFi, if it is connected (no internet connection!)
  • Go to Messages App and in Settings/Chat features switch OFF Enable chat features
  • Clear Cache/Data in following APPs *need to show systems apps*: Messages, Google Services Framework, Carrier Services, YOU WILL NOT LOSE ANY DATA
  • Reboot your phone
  • Switch off flight mode, connect to WiFi should be enough but better connect to Data on Mobile Provider (Telstra i your case) and be sure that it uses LTE/4G, it does not work on 2G or 3G
  • Go to Messages App and in Settings/Chat features switch ON Enable chat features
  • It should start to Connect by showing Status connecting:
  • on my current phone (Pixel 2 XL) it needs 5 seconds to change to Status Connected
  • on my P9 it needed sometimes 1 hour. so if it writes Connecting, or Setting up, take your time... wait at least 1 hour until you give up...
GOOD LUCK MATE!

Reply