Answered

Notification sound even on vibrate mode and do not disturb mode, Mate 20 Pro


As the title says, my phone is still making all the notification sounds, even in do not disturb mode and vibrate mode! Very frustrating.

I have reset the phone countless times and can't seem to find a reason as to why this is happening.

Any help is much appreciated.

Thanks,
Dani
icon

Best answer by craiglambie 7 June 2019, 16:03

Wanted to share, I spoke to support like this similar thread Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

Try First: Clean your cache

  1. To wipe the cache of the device , you simply have to power off the device in question.
  2. Once it is off please press and hold the Volume Up Key and the Power Button for about 30 seconds.
  3. The device will then boot into a new menu with only 3 visible options. The first option from the top is the one that we are looking for in this list.
  4. Once the process has ended the device will come back to this menu.
  5. In order to leave the menu simply tap Reboot System Now ( the last option on the bottom of the list )
No luck: Hard reset your phone (I luckily didn't have to do this)
  1. If this will not help then we recommend a factory reset. This will erase all data on the internal storage and will turn the device back to its factory settings.
  2. Therefore, before doing this, make sure that you back up all of your files and data (documents, photos, videos, contacts, notes, media files etc.) on the SD card (in Settings > Advanced settings > Backup & reset, or via the Backup App), on the PC (using HiSuite), or on the Google account, and that you know the Google account and password with which you have previously signed in or remove it in Settings > Accounts > select the account > Remove.
Hope that helps someone. - I also posted it on the similar thread https://uk.community.huawei.com/p30-series-30/p30-pro-not-honouring-silent-mode-or-do-not-disturb-mode-5296/index2.html#post29935
View original

15 replies

Hi all,

I've recently started having problems with the notification sounds on my P20 Pro. I've noticed 2 main issues.

1) Any notification I receive when my phone is set to silent, sounds, which is very annoying. And not only does it sound, it does a double, almost overlapping sound. Very odd. The only way to stop this is to turn my media volume down to zero, which I shouldn't have to as my phone is set to silent!

2) When my Sony Bluetooth headphones are connected, and I'm listening to music/streaming video etc. and my phone is set to silent, all notifications still sound and interrupt my music/streaming volume! Very frustrating again!

I hope this isn't a serious issues, and that I'm missing something in my settings. I hope you can help, as I'm very happy with my phone which I have owned for about a year, but these issues are starting to annoy me!

Thanks in advance!
Doug
Userlevel 7
Badge +11
Hi @danivaz,

Welcome on the community. 🙂

Sorry to see that you are having issues with you notifications. Is it the same issue as the issue in this thread?
For the last few days my Huawei p20 has been playing loud notifications for everything despite being in silent mode. Anything else having this issue?
Userlevel 4
Badge
As you've not had a response yet we'd suggest you reach out to our official support channels here https://consumer.huawei.com/uk/support/
Hi @danivaz,

Welcome on the community. :)

Sorry to see that you are having issues with you notifications. Is it the same issue as the issue in this thread?

It is yes. Shame it looks like it's not being resolved. Will have to look at switching to an alternative phone if this carries on.
Same thing has started happening to me recentlly on my mate 20 pro. Set to DND overnight with no priority overrides but still get a notification sound. I have to turn phone off which means I can't use it anymore for my alarm
Hey there.

Same thing happened on my Mate P20. I thought it was just me, that I missed something with the last software update, but it seems to be widespread. It'd be good to have a patch or a fix to this issue, as it's very annoying.
I have a UK phone which has the following patch level. O9

I am sitting on the 9.0.0.285(C636E2R1P12), on an Australian one
Userlevel 7
Badge +11
Hi all,

I replied in this thread this morning:

Hi all,Back to the issue:there is a variety of settings around DND. First and foremost head to Settings> Sounds >Do Not Disturb. Ensure it is turned on, not scheduled, ensure settings for calls and messages are correct. Secondly head to Settings> Apps> Apps>(chose an app)> Notifications and ensure "allow interruptions" is not selected.


If all of that still fails then you may have a bug or a badly coded third party app. Please contact our official channels for more info: https://consumer.huawei.com/uk/support/
Hello everyone. Someone else mentioned Sony headphones, so I started doing some testing. So after a fresh reboot, my phone is fine. Notifications and vibrate and silent mode work fine. However, I have the Sony WF1000X, and as soon as I connect them, it causes the problem as many mentioned above.

After using my headphones, on normal notification mode, there is a double notification tone. On vibrate or silent, there is a single notification tone. Reboot the phone, back to normal.

I've tried with other Bluetooth headphones, and it is fine. I've tried with the Sony Headphones app un-installed, and re-pairing the headphones, the issue still comes up.

However this does seem to be a new issue, and I see the Sony Headphones app was just updated recently, so I think that app has caused something.

So I think I'll stop using these headphones for a bit (I don't really like them anyway).

Best of luck.
Hi evannadeau, this also happens with my bose headphones. As soon as I use them, they initiate the double notification sound... I'm assuming it may be to do with the Google assistant but can't pinpoint what it is exactly!
That's great to know @Tim93ktc thanks. The other headphones I tested with do not have assistant capabilities, so perhaps that is it. I'll try re-configuring my Sony's tonight to not use assistant. Thanks.
Wanted to share, I spoke to support like this similar thread Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

Try First: Clean your cache

  1. To wipe the cache of the device , you simply have to power off the device in question.
  2. Once it is off please press and hold the Volume Up Key and the Power Button for about 30 seconds.
  3. The device will then boot into a new menu with only 3 visible options. The first option from the top is the one that we are looking for in this list.
  4. Once the process has ended the device will come back to this menu.
  5. In order to leave the menu simply tap Reboot System Now ( the last option on the bottom of the list )
No luck: Hard reset your phone (I luckily didn't have to do this)
  1. If this will not help then we recommend a factory reset. This will erase all data on the internal storage and will turn the device back to its factory settings.
  2. Therefore, before doing this, make sure that you back up all of your files and data (documents, photos, videos, contacts, notes, media files etc.) on the SD card (in Settings > Advanced settings > Backup & reset, or via the Backup App), on the PC (using HiSuite), or on the Google account, and that you know the Google account and password with which you have previously signed in or remove it in Settings > Accounts > select the account > Remove.
Hope that helps someone. - I also posted it on the similar thread https://uk.community.huawei.com/p30-series-30/p30-pro-not-honouring-silent-mode-or-do-not-disturb-mode-5296/index2.html#post29935
Wanted to share, I spoke to support like this similar thread Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

Try First: Clean your cache

  1. To wipe the cache of the device , you simply have to power off the device in question.
  2. Once it is off please press and hold the Volume Up Key and the Power Button for about 30 seconds.
  3. The device will then boot into a new menu with only 3 visible options. The first option from the top is the one that we are looking for in this list.
  4. Once the process has ended the device will come back to this menu.
  5. In order to leave the menu simply tap Reboot System Now ( the last option on the bottom of the list )
No luck: Hard reset your phone (I luckily didn't have to do this)
  1. If this will not help then we recommend a factory reset. This will erase all data on the internal storage and will turn the device back to its factory settings.
  2. Therefore, before doing this, make sure that you back up all of your files and data (documents, photos, videos, contacts, notes, media files etc.) on the SD card (in Settings > Advanced settings > Backup & reset, or via the Backup App), on the PC (using HiSuite), or on the Google account, and that you know the Google account and password with which you have previously signed in or remove it in Settings > Accounts > select the account > Remove.
Hope that helps someone. - I also posted it on the similar thread https://uk.community.huawei.com/p30-series-30/p30-pro-not-honouring-silent-mode-or-do-not-disturb-mode-5296/index2.html#post29935


Problem has restarted... Haven't tried the factory reset yet, as that is a massive time investment... Will report if it is a longer term solution

Reply