Answered

Speaker problem Mate 20 pro - Main speaker vs earpiece speaker


Ok so i have a speaker problem with my mate 20 pro. The problem consist in shifting the audio from the main speaker to the earpiece. When in landscape mode on youtube the main speaker decides to lower the volume output and so you hear the earpiece speaker more pronounce. If i close the app without changing the phones position and relaunch the app the speaker works normally. This happens sometimes even when held normally, the main speaker decides to lower the volume and you hear a slight hiss sound from the speaker if you bring it to you're ear. Any thoughts? Software or Hardware?
icon

Best answer by bobo 17 January 2019, 13:08

Hi, kevdeiu, according to your description, it seems that you have turned on the stealth stereo, you can go into "Settings - sound - more sound Settings - stealth stereo", you can try to turn off the function to see if it is effective.

View original

16 replies

Userlevel 7
Badge +9
Hey Kevdeiu,

Welcome on the community! Thank you for sharing your issue!

Have you tried to reset your phone? A simple reset can solve a lot of issues. You can find a how to on this page.

Please keep us updated. 🙂
Userlevel 2
Badge
Hi, kevdeiu, according to your description, it seems that you have turned on the stealth stereo, you can go into "Settings - sound - more sound Settings - stealth stereo", you can try to turn off the function to see if it is effective.
Hi, bobo, i can't find "stealth stereo" that you mention but i will try and look for it if not i hope that with a software update the problem will be fixed. Thanks !!
Userlevel 2
Badge
kevdeiu wrote:

Hi, bobo, i can't find "stealth stereo" that you mention but i will try and look for it if not i hope that with a software update the problem will be fixed. Thanks !!

You can search "Stereo+" from the top of "Settings."
So update to the " problem " i could not find the " stereo+ " from the top of settings with search or anything else but what i discovered is that when you raise the volume more then 50% the main speaker starts to get louder as it should to the point where is normal for it. And if i reduce the volume back the shifting does not occur . But if it does that is what i do to fix it. By the way at 70-100% volume the problem does not occur. Thank you anyway for the help bobo!!
Userlevel 2
As the charger port speaker is stronger its difficult to be sure but when I tried this myself on my phone I was unable to say for sure however turning the phone does appear to shift the sound, as the speaker is also changing location it sounds different.

To test I covered each speaker to listen to the other when rotated to landscape, I'm unsure I could detect a significant change.

As for those settings mentioned, it's not to be seen on my mate device also.

Seems there are a few bugs to fix!
Did you find a fix. My speaker problem is slightly different. Top speaker is pretty much very very very low vs bottom speaker. I did same test as you and covered the bottom speaker and then I put volume on 100% and I can only just hear the sound from top speaker so it's pretty much useless when watching videos or listening to any music.
I have the exact same problem, @kevdeiu . Did you find any way to sort it out?
I took my phone to a Huawei store and their answer was to wait for a new update and see if that solves it, which at least the .187 didn´t.
It´s a shame that a phone of this quality has all this problems...
Same here also. Little volume on top earpiece speaker, even during calls. No aspect change either. Just very quiet all the time.

Phone is less than a month old. Not good Huawei.....
Userlevel 6
Badge +6
Hi all,

Have you tried @bobo's suggestion?

If it is still not working, can you please PM me the serial number of your phones so I can look into this further?

You can find this information either on Settings > About phone > Status or on the box of the device.

Looking forward to your replies! :)

Best wishes,
Max
some time main speaker not working only second speaker (Near of front camera) working and it's very quiet or soft and I have to restart again and again my device than after the main sound speaker is working. It's making me irritating. Mostly this issue I am facing when I use Huawei talk band 5 for Bluetooth headphone.
Userlevel 7
Badge +9
Hi @sidh, Welcome on the Huawei Community! :)

I moved your question to this topic. Please read the previous comments and let us know if you need further assistance.
Hi Amy,
It's not showing "Settings - sound - more sound Settings - stealth stereo", you can try to turn off the function to see if it is effective. when I check more sound setting "stealth stereo" is not showing in my device.
Userlevel 7
Badge +9
Hi @sidh, Thank you for the reply. I asked our support team to assist you on this matter.
@Amy hello, I also do not have stereo+ option. I have mailed max my serial number...and await a solution, before I ultimately have to send this phone away for 2 weeks to be repaired.
I hope its quick. As I'm thinkngn of canceling the whole contract. I don't want problems in the future.
Userlevel 6
Badge +6
Hi all,

Could you kindly perform a Sound diagnose of your device and tell me the results that come up?

You can do this by going to HiCare > Smart diagnosis > Manual > Speaker and Earpiece.

After the diagnosis is done, you will see the results posted on your device screen.

Best regards,
Max

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings