Voice recording has no sound Mate 20 Pro

  • 25 December 2018
  • 47 replies
  • 11704 views


Show first post

47 replies

I have a Mate 10 Pro and also suffer the issue with the microphone failing. I can confirm that this happens at the OS level as I've tested it across all applications that rely on the mic (eg. Sound Recorder, WhatsApp, Video Recording where sound is absent) while the fault is present. Yes, it resolves itself after restarting the phone phone. I do however agree that this issue is likely related to switching to/from the Private Space. I've had this phone for just over a year now, and have only just started seeing this issue since I started using Private Space. Huawei really need to fix this ASAP as it appears to be present across all your flag ship phones. I want to continue to use the Private Space function and this is more than just an inconvenient issue. Thank you Support for escalating this further to the Dev Team to fix.
Hi all,

If you are having the same issue after performing the diagnosis, can you please PM me the serial number of your devices?

In that way, I will be able to look into this further.

You can find the serial number is Settings > About phone > Status or on the box of the device.

Looking forward to your replies!

Best wishes,
Max

Serial-LCL0218718000794 same problems with microphone as others

Please help🙈🤷‍♂️
@Max
Hello, I just bought the new P30 Pro phone and I have the same frustrating issue. No sound working for not only the Whatsapp but also all other applications including Snapchat where voice recording is there.

Please help to fix this issue. Thanks
This is a problem with the private space function. I too had the same problem with video not recording sound and also location reminders not working. Once I deleted the private space the problems stopped. It is a problem that needs sorting as I found private space a useful way of letting my young son play the on my phone without worrying about him spending money or using apps he shouldnt.
Come on Huawei sort it out, this is happening across all of your phone's it seems and is not acceptable
Having the same issue on my p20 pro... Records only the first milliseconds and the mic stops working on all apps even on calls, Needs restart to fix.
Userlevel 4
Badge +4
Having the same issue on my p20 pro... Records only the first milliseconds and the mic stops working on all apps even on calls, Needs restart to fix.

a possible solution for your problem is here: https://uk.community.huawei.com/p30-series-30/p30-pro-sound-when-recording-videos-3686#post24970
Got mine sorted, I turned the Bluetooth off, turned the WiFi off then turned the phone off then back on again and its working fine now even with the Bluetooth and WiFi on. The first time I turned it off and on again I didn't turn the Bluetooth and WiFi off and it didn't work. So try turning Bluetooth and WiFi off then phone off and then back on again.Hope this helps
Hi
I had this problem since I bought my Huawei Mate20 pro. When i record my voice either by using the Voice Recorder app or by making voice messages in Whatsapp, I almost have no sound. You can hear the first milliseconds of my voice and the rest is silent. I can record very low sounds without any problem but the minute I increase my voice to normal, the recording goes silent.

I went to Phone Manager app and changed the battery App launch from Auto to Manual and disabled all, but no change for my issue. I also went to App permission/ Microphone and kept only the phone main apps to use the microphone such as Phone and Voice Recorder, but still the same problem.

The voice recording problem disappeared only when I restart my phone and only for a while before it comes back.

I'm frustrated and really need help please

Hello

Did you solve this problem? I had it too
Userlevel 6
Badge +4
Hi @Tarek Msnsour , Did you have any luck with this suggestion?

Smudge wrote:
Got mine sorted, I turned the Bluetooth off, turned the WiFi off then turned the phone off then back on again and its working fine now even with the Bluetooth and WiFi on. The first time I turned it off and on again I didn't turn the Bluetooth and WiFi off and it didn't work. So try turning Bluetooth and WiFi off then phone off and then back on again.Hope this helps
Hi

Has there been any update on this issue.
I have tried the solution (Got mine sorted, I turned the Bluetooth off, turned the WiFi off then turned the phone off then back on again and its working fine now even with the Bluetooth and WiFi on. The first time I turned it off and on again I didn't turn the Bluetooth and WiFi off and it didn't work. So try turning Bluetooth and WiFi off then phone off and then back on again.Hope this helps)


It is OK so far, two days now,
I've got a p20 Pro and have the same problem, I take plenty of videos for memories and rarely go back and check them straight away, just realised today that I have a load of holiday videos and birthdays that have a millisecond blast of sound and then completely muted.

This thread has been going for months and they really haven't fixed this yet?
Same problem with my huawei mate 20 pro but the voice recording is good only recording videos has no sound sometimes, when I take a video the voice go and come back also I heard strange sound like the sound of water in the video sound. I have reset all sittings but nothing changed
Please help
Userlevel 6
Badge +4
Hi @MOHAMMED BABAGRAN , can you check the microphone is not obstructed (by a case for example) and the microphone is clean. This might be causing issues with the sound.
@Danjl I did, it's clear
I solved it now

, I turned the Bluetooth off, turned the WiFi off then turned the phone off then back on again and its working fine now even with the Bluetooth and WiFi on. The first time I turned it off and on again I didn't turn the Bluetooth and WiFi off and it didn't work. So try turning Bluetooth and WiFi off then phone off and then back on again
Userlevel 6
Badge +4
@Tarek Msnsour , great news you resolved the issue. Thanks for sharing so others can try this to resolve similar issues too.

@MOHAMMED BABAGRAN , does this work?

I solved it now

, I turned the Bluetooth off, turned the WiFi off then turned the phone off then back on again and its working fine now even with the Bluetooth and WiFi on. The first time I turned it off and on again I didn't turn the Bluetooth and WiFi off and it didn't work. So try turning Bluetooth and WiFi off then phone off and then back on again
@Danjl unfortunately not, I tried it now, then I took video but still the voice go and come back
@Danjl I have took videos under water but I think the problem not from that because the phone has under waterproof also the microphone still working good only the problem with recording videos
I solved it now

, I turned the Bluetooth off, turned the WiFi off then turned the phone off then back on again and its working fine now even with the Bluetooth and WiFi on. The first time I turned it off and on again I didn't turn the Bluetooth and WiFi off and it didn't work. So try turning Bluetooth and WiFi off then phone off and then back on again

Thanks a lot Can you make a tutorial vídeo on you tube help The people, if you make copy The link here.
I had the same problem. Did the “turn off bluetooth - turn off wifi - restart phone” procedure. Seems to have fixed it for now. Problem is i have no confidence in it staying fixed.
There is no indication that the ‘mic has stopped working. More often than not it is not possible to “reshoot” a video.

Very disappointed that this still appears to be a problem.
Especially given the other bad press that huawei have recently been the subject of.
If this happens again, i will be returning the phone and going back to samsung.
Userlevel 7
Badge +11
Hi all,

If the issues still persist after the troubleshooting steps in this thread, please contact our support channels to get assistance: https://consumer.huawei.com/uk/ (UK) or https://consumer.huawei.com/en/worldwide/ (worldwide).
Same problem here with Mate 20 Pro!!!
There is no recording audio (in video, whatsapp vocal message ecc) when i switch between private space and main space.
It's incredibile that after almost 2 years the problem still isn't resolved!!!
I think that's my first and last huawei phone, i'll switch back to Xiaomi because that's a really big bug that huawei dont resolve...
Very very disappointed...

Reply