Answered

Wifi Calling on Vodafone

  • 19 November 2018
  • 34 replies
  • 4690 views


Show first post

34 replies

Userlevel 7
Badge +11
Hi @Dexter,

I moved your question to this thread.

@all Please take a look at this page on the Vodafone website. There is a F.A.Q. on that page and one of the questions is about setting up Wi-Fi calling.
I have recently joined Vodafone but the signal at my home is virtually non existent. I’ve been told by Vodafone that I can use WiFi calling with my P10 lite but I dont appear to have the option for WiFi calling in my Phone’s menu. Can anyone advise?

Experiencing the exact same thing on an unlocked p10 lite that has previously been on ID and Three. Phone has no option for WiFi calling with a Vodafone sim but reinserting the ID sim brought it back. Huawei say it is the carrier, Vodafone say that it is because I have put another operators sim in first and walked away from discussion.
I may have just found an answer. Cannot take credit. I have now been able to call while connected to WiFi in airplane mode. Modified from similar instrictions for a different phone


1] install Nova Launcher and set it as your default launcher. You can go back to Huawei's front end later

2] in some blank space on the desktop, long press and choose Widgets

3] hold the Activities button and place the icon on your desktop

4] you'll be asked to to pick an activity. Scroll down until you see 'settings'. Expand the list and find wi fi calling

5] click on the new icon and enable wi fi calling

6] change your launcher back now if you wish

7] to test, turn on airplane mode to disable cellular comms. Turn on and connect to WiFi. You should now get Vodafone WiFi Calling Enabled notification

Seems to work for me. Hope this helps. Even though the option still is not present in the Huawei settings menu it appears to still be enabled.
Userlevel 7
Badge +11
Thanks for your reply @Andy2000x! @Max , can you confirm if this solution is the right one?
Userlevel 7
Badge +6
Hello,

Thank you for providing those troubleshooting steps, @Andy2000x ! I can confirm that these are what's needed to be tried on your device!

Best wishes,
Max
Why doesn't WiFi calling work in ireland on Vodafone
In order to be able to use wifi calling I need to be able to turn it on. I am unable to do so because the facility does not appear in Settings - it is not shown in More either. How can solve this problem?
Userlevel 6
Badge +4
@GLK I moved your post here as this topic covers wifi calling. Which network are you on, as folks are experiencing issues. Try @Andy2000x , solution:

I may have just found an answer. Cannot take credit. I have now been able to call while connected to WiFi in airplane mode. Modified from similar instrictions for a different phone


1] install Nova Launcher and set it as your default launcher. You can go back to Huawei's front end later

2] in some blank space on the desktop, long press and choose Widgets

3] hold the Activities button and place the icon on your desktop

4] you'll be asked to to pick an activity. Scroll down until you see 'settings'. Expand the list and find wi fi calling

5] click on the new icon and enable wi fi calling

6] change your launcher back now if you wish

7] to test, turn on airplane mode to disable cellular comms. Turn on and connect to WiFi. You should now get Vodafone WiFi Calling Enabled notification

Seems to work for me. Hope this helps. Even though the option still is not present in the Huawei settings menu it appears to still be enabled.
Userlevel 2
In order to be able to use wifi calling I need to be able to turn it on. I am unable to do so because the facility does not appear in Settings - it is not shown in More either. How can solve this problem?

If you are on Vodafone just contact them on 191 and ask them to enable Wifi Calling. I had the same issue that it wasn't appearing in my settings. I thought I was losing the plot.

You can also enable it within the MyVodafone app but that didn't work for me I had to contact them and they pushed an update to my handset which then sorted it.

Then restart your phone and it should appear in settings and then be active.

Hope it works 😎

Reply