FreeBuds Sound Issues


Hi all
Just bought a set of FreeBuds in an auction. Left is working perfectly, but the right is very dim! Any help?

This topic has been closed for comments

5 replies

Userlevel 1
Have you tried factory reset the freebuds?

If my memory serves me correctly you need to put them in the case and keep the case open whilst pressing and holding the button on the back of the case, you should see the LED on the front of the case flash RED, GREEN and BLUE I cannot remember how long to press for but I believe its around 10 seconds
Hi Ozomax. I've actually done this twice and nothing has happened. Really struggling as I know the reply will be 'take them to Huawei Service centre' but my local one is in Kent, England and I am in Northern Ireland!
Userlevel 1
I am in the same situation, my p20 pro appears to be stuck on a odd firmware (updated via system update in settings) I can't send my phone off either due to medical reasons I can not be without a phone my honor 8 is smashed or I'd be using that in the meantime, luckily it is due for an upgrade so I may send the phone off then. I understand your stress. I had a similar issue but it did work for me have you contacted customer care?
Sorry to hear that. I haven't contacted them yet as I'm at work but will call later.
Userlevel 7
Badge +8
Hey both,

I closed this topic because there already is a topic about problems with the right Freebud. Please also check the search function for other threads with Freebuds issues and reply in another thread if you need assistance. 🙂

Cookie policy

By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

Accept cookies Cookie settings