Answered

Pictures don't upload to Onedrive

  • 6 September 2018
  • 13 replies
  • 1516 views

Please can anyone on here to solve my problem. I have changed from kindle to Huawei but since I have put my MSN onedrive on here the pictures I take from say Facebook do not upload to onedrive!
Thanks in advance
Lord Uhtred
icon

Best answer by Max 20 September 2018, 16:30

Hi Lord Uhtred!

Sorry to hear about your issue.

In this case, what you can try to do is resetting the Onedrive app. To do that, simply follow the instructions below:

1. Go to Settings > (Apps & notifications) > Apps > Onedrive
2. Storage > Clear cache > Clear data > Go back one step > Force stop
3. Go back another step, to the apps list > Three dots (More) > Reset app preferences
4. Restart the phone

If the issue persists, you can also contact the app's developer, so they can be made aware of the issue. As manufacturers, we do not provide support for third party applications.

Hope this proves useful!

Max
View original

13 replies

Userlevel 7
Badge +6
Hi Lord Uhtred!

Sorry to hear about your issue.

In this case, what you can try to do is resetting the Onedrive app. To do that, simply follow the instructions below:

1. Go to Settings > (Apps & notifications) > Apps > Onedrive
2. Storage > Clear cache > Clear data > Go back one step > Force stop
3. Go back another step, to the apps list > Three dots (More) > Reset app preferences
4. Restart the phone

If the issue persists, you can also contact the app's developer, so they can be made aware of the issue. As manufacturers, we do not provide support for third party applications.

Hope this proves useful!

Max
So sorry Max but I followed your instructions to the letter but to no avail. Thank you for trying
Lord Uhtred
Userlevel 2
Badge
Hi Lord Uhtred!

Have you tried re-installing the OneDrive App? Sometimes that can fix similar issues.

If you need any more assistance, feel free to contact us!
Julian
Thank you Julian just tried re installing it but alas no joy. Thanks for trying
Peter
Userlevel 7
Badge +6
Hi Lord Uhtred!

Sorry to hear that the instructions provided didn't help :(

Please tell me, have you checked the app permissions, to see if OneDrive has permission to access your storage?

Please let us know if you have any updates in this matter

Max
Hi Max, I have done what you said but to no avail, the strange thing is that if I open it in Google chrome it works just fine but no joy with the app!
Thank you
Yours
Peter
Userlevel 7
Badge +6
Hi Lord Uhtred,

Just a quick follow up to see if the app with the current November update is behaving normally.

Best wishes,
Max
You need to turn on camera upload in one drive settings and if you want to include additional folders like Facebook you do it from settings too
Hi

I have a similar issue with the One Drive app. when photos are taken they do not automatically upload to one drive.
as far as I can tell permissions are set correctly, one drive has access to storage and is set to upload the camera folder.
As soon as the onedrive app is opened it starts to upload the photos straight away.
I have logged fault tickets with Microsoft support, however they have been sent logs etc and have made several suggestions i.e. reinstall app, etc but nothing has resolved the issue so far.

I am wondering if it is some deep seated security setting that does not like the camera or storage accessing the app in the background.
Userlevel 7
Badge +6
Hi @BB_P20MatePro,

Sorry to hear about the situation.

Have you tried the steps I advised above about resetting the Google Drive application?

Please let us know!

Best wishes,
Max
Yes I did try the steps listed earlier in the post but unfortunately to no avail
Userlevel 7
Badge +6
Hi @BB_P20MatePro,

Thanks for letting me know.

Could you kindly PM me with the Serial Number of your device so I can further look into this?

Thank you!

Best wishes,
Max
Hello

I have finally found the answer to this issue, this fixed the problem on my Mate20 Pro.

After a lot of playing with various settings I have found one setting which once changed means that now when I take a photo on the phone, OneDrive uploads the photo within seconds of being on WIFI without any further intervention.

The setting is buried deep in the battery optimisation settings,

Settings -> Battery -> App Launcher -> slide the button next to OneDrive to turn off Automatic management for that app.
select OK to allow it to launch in background

its been changed on my phone for 2 days, photos upload when they are taken (providing WIFI is on, as per my onedrive settings) I haven't noticed any real decrease in battery life.







Reply