Answered

P20 lite doesn't connect to open wifi

  • 2 November 2018
  • 10 replies
  • 15082 views

I am not able to connect to a public free open network when out & about. I can scan for the network, connect to it, but I don't get the gate way /login page to accept T & C's to then be able to use the WiFi. I have tried loading an internet page on Chrome & Firefox browser to no avail. I have network reset & factory reset. Still same issue. Connecting to private network with password etc is fine. Only public hotspots affected. Phone is running on latest 8.0.0.

icon

Best answer by Redous 5 February 2019, 19:40

Hi,

So i have found a work around on how to get public WiFi working. I downloaded several browser applications and found that only 1 browser identified there was a certificate problem but giving me the options to allow me to go through and bypass the security. I am glad this security is in place but its a pain in the backside not being able to bypass it.

Download Firefox and it will allow you to choose an option to add the address to safe list which will then bypass any security protocols.
View original

10 replies

Thank you Redous, I installed Firefox and fixed the problem. thx again.
@Ghislaine,

I've moved your post here as this thread covers issues with access to wifi - so I hope it helps.


Many thanks
Userlevel 6
Badge +4
@Ghislaine,

I've moved your post here as this thread covers issues with access to wifi - so I hope it helps.
Hi all,

I just bought Huawei Y9, this is my first time using this brand of phones.

it connects normally to all wifis, but when I'm at work, it doesn't show the open network there, while my old phone did, and my colleagues phones do as well.

I tried to check all the settings, look in the internet to find a solution but unfortunately nothing could solve this issue.

Can anyone please assist me here, and share if they 're facing the same issue.

Many thanks in advance.
Userlevel 7
Badge +6
Hi @Redous @Mattwinter,

Thank you very much for this suggestion in this matter! @Mattwinter can you please try @Redous' method in your inquiry?

If you have any other difficulties, please let me know.

Best wishes,
Max
Hi,

So i have found a work around on how to get public WiFi working. I downloaded several browser applications and found that only 1 browser identified there was a certificate problem but giving me the options to allow me to go through and bypass the security. I am glad this security is in place but its a pain in the backside not being able to bypass it.

Download Firefox and it will allow you to choose an option to add the address to safe list which will then bypass any security protocols.
Hi,

Tried this option and still no joy, when i click on the "i" in config it says that this link is unsecured and each time i click connect it opens another tab to the same link. there is no option to click allow this connection or any option to allow unsecure connections.
Userlevel 7
Badge +6
Hi @Redous,

In regards to your inquiry, could you please try to perform a network settings reset of your device?
You can perform a Network Settings Reset by going to Settings > Tap on the search bar and input: "Network Settings Reset" > Tap on it > Restart your device.

Keep us updated of the outcome!
Max
Any further update to this as I have the same issue, 192.168.1.1 doesn't work I found that my IP should be 172.16.0.1 however it then comes up with a fault saying certificate not recognized connection blocked for security reasons.
Userlevel 7
Badge +11
Hi @Mattwinter,

Welcome on the community! I've had this issue and I get your frustration! Did you try to forget the WiFi and add it again?

I've been googling a bit and found this article: "If you head to 192.168.1.1, the most common default router IP address, I’ve found that nine times out of ten I’m immediately redirected to the login page."

Please try this and let us know if it worked. 🙂

Reply