Answered

Annoying wifi scanning popup


  • Opening Fortune Cookie
  • 1 reply
Hi there,

Since a day or two ago I've started getting an annoying popup on my P10 (Android and EMUI versions 8.0.0) that says:

By turning on Wi-Fi scanning apps and services can scan for Wi-Fi networks at any time, even when Wi-Fi is off.

Any ideas on how to stop this? I've tried turning of wifi scanning in settings.

Appreciate your help!

Ash
icon

Best answer by Max 3 September 2018, 13:53

Hi everyone!

Thank you for sharing this matter with us. It is most unfortunate, though.

In addition to the Wi-Fi scanning instructions mentioned above, I wish to add an option should the issue still persist after deactivating the feature. That is deactivating the Wi-Fi+ feature.

This can be done by going to Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > Make sure that it's switched off.

As a representative of the manufacturer, I can inform you that we've been made aware of this matter and we are actively working to have it fixed for you as soon as possible. All your feedback is duly noted and taken into consideration.

Max

View original

12 replies

Ash wrote:

Hi there,

Since a day or two ago I've started getting an annoying popup on my P10 (Android and EMUI versions 8.0.0) that says:

By turning on Wi-Fi scanning apps and services can scan for Wi-Fi networks at any time, even when Wi-Fi is off.

Any ideas on how to stop this? I've tried turning of wifi scanning in settings.

Appreciate your help!

Ash


Me and my friend also facing the same problem so it must be some software problem

Found a thread on androidcentral, seems to be a Huawei only problem - https://forums.androidcentral.com/general-help-how/906588-annoying-wifi-scanning-popup-wont-stop.html
Userlevel 7
Badge +6
I have the same issue at the moment, it's definitely affecting Huawei devices.
Userlevel 7
Badge +6
Ok I seem to have fixed it in my phone. Go to settings } security and privacy } location settings then click the 3 dots in the top right corner, choose scan settings and then enable WiFi scanning.

So far I haven't had the pop up since.

same issue on the Huawei P smart😞
Userlevel 4
I had the same issue, but only on one day. I dont know how I fixed it.
Userlevel 6
Badge +6
Hi everyone!

Thank you for sharing this matter with us. It is most unfortunate, though.

In addition to the Wi-Fi scanning instructions mentioned above, I wish to add an option should the issue still persist after deactivating the feature. That is deactivating the Wi-Fi+ feature.

This can be done by going to Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > Make sure that it's switched off.

As a representative of the manufacturer, I can inform you that we've been made aware of this matter and we are actively working to have it fixed for you as soon as possible. All your feedback is duly noted and taken into consideration.

Max
Same technical issue pop up auto scanning wifi for my Huawe Mate10 (2weeks mate10user) all the way from the Philippines.
Max wrote:

Hi everyone!

Thank you for sharing this matter with us. It is most unfortunate, though.

In addition to the Wi-Fi scanning instructions mentioned above, I wish to add an option should the issue still persist after deactivating the feature. That is deactivating the Wi-Fi+ feature.

This can be done by going to Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > Make sure that it's switched off.

As a representative of the manufacturer, I can inform you that we've been made aware of this matter and we are actively working to have it fixed for you as soon as possible. All your feedback is duly noted and taken into consideration.

Max



Hi Max,

Actually it's a great feature. we just don't like the notification. please remove the notification but not this feature in huawei next update. Just leave the option Wifi+ = on / off so the users can choose by themself
Userlevel 6
Badge +6
@comel

Don't worry. Our research and development team is currently working on removing this constant popup, which is undoubtedly annoying, so the Wi-Fi+ option will remain on the phones and will not be affected.

Max
Hi

I also have this problem on p20 pro even with wifi+ OFF.

Turning wifi+ on and off didn't help either. Wifi location scanning automatically turns itself off even when I go to location settings and turn the feature on myself.

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings