Huawei P20 doesn't recognise public wifi


Hi. So with my Samsung S8 the device would recognise a public network, eg. a coffee shop or gym, and ask me to sign in on the first occasion. I would sign in to the network, by clicking 'login' so no password required on these networks, and I would be up and running. Next time I walked into the gym the device would recognise the network and sign in. Convenient. With the P20 it remembers the network but asks me to sign in every time, so it doesn't automatically connect. Inconvenient. It's anyone else noticing this? Can Huawei address this in an update?

12 replies

Userlevel 2
Badge
Hi Dalangs84!

We are glad that you have chosen a Huawei device.

In response to your query, we recommend that you follow the steps below:

1. Settings > Wireless and networks > Wi-Fi > Configure > Keep Wi-Fi on during sleep > Always.
2. Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > you must disable it.
3. Settings > System > Reset > Network settings reset > Network settings reset again to confirm.

I trust this information is of assistance. Should you have any further questions, please do not hesitate to contact us.:D

Julian
Done. Fingers crossed!
Userlevel 6
Badge +7
If this doesnt work when it conencts click on the wifi icon and then forget the wifi, reconnect and it should ask to sign in , f not visit google .co.uk or similar and it should direct to the free wifi login, also some free wifi setups expire after a period requiring you to log in again.

maybe your going to the gym more often! 😃
chillphone wrote:

If this doesnt work when it conencts click on the wifi icon and then forget the wifi, reconnect and it should ask to sign in , f not visit google .co.uk or similar and it should direct to the free wifi login, also some free wifi setups expire after a period requiring you to log in again.

maybe your going to the gym more often! :D



I want to stop having to sign in, not sign in more often. I go every other day! 😝
Julian wrote:

Hi Dalangs84!

We are glad that you have chosen a Huawei device.

In response to your query, we recommend that you follow the steps below:

1. Settings > Wireless and networks > Wi-Fi > Configure > Keep Wi-Fi on during sleep > Always.
2. Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > you must disable it.
3. Settings > System > Reset > Network settings reset > Network settings reset again to confirm.

I trust this information is of assistance. Should you have any further questions, please do not hesitate to contact us.:D

Julian



Hi. I've done this, but still having to sign in to public wifi everytime I connect πŸ˜•πŸ™
Userlevel 7
Badge +8
Hey Dalangs84,

I just spoke with our support team about this issue. I wanted to let you know that this is an ongoing issue and we unfortunately still don't have a proper workaround. I'm sorry!
Hi,

Any update to this, I have just been on web chat and they have opened a new ticket for my phone. I have the P20 Pro on contract.

All other WiFi works fine however Public WiFi that requires login credentials does not work. I created a guest WiFi on my home system which had no credentials required and was able to connect fine.

Please sort this.
Userlevel 6
Badge +6
Hi @Redous,

Have you tried the steps @Julian provided in this topic?

Please let us know if they proved useful!

Best wishes,
Max
Happy ish new owner of a p20 pro but the WiFi issue is frustrating and basically others have same issue months ago and no fix, so I will be returning device as defective and going with another provider.
Userlevel 7
Badge +8
Hi @Greywolverine,

I moved your topic to this thread. Sorry to see that you are having these issues. Please try the steps above and let us know if you still need assistance.
Amy wrote:

Hi @Greywolverine,

I moved your topic to this thread. Sorry to see that you are having these issues. Please try the steps above and let us know if you still need assistance.




😥 Got reply from Huawei UK - Have'nt tried it yet!

In response, we would like to let you know that sometimes when you try to connect to a public network, for security reasons, you are not allowed to access that specific network.

You can try to login using Modzilla Firefox. Please download it on your phone and install it. After that, copy the link from Chrome and paste it into the Modzilla and register.

Before connecting to Wi-Fi, open Chrome > tap on the Three dots > Settings > Site Settings > Allow pop-ups.

After doing this, connect to Wi-Fi and check if the browser opens automatically requesting credentials or registration. If not, open Chrome and check if it redirects to the login site.

Please make sure you have forced stop the Chrome application before you open Modzilla. To do so go to Settings > Apps & notifications > Apps > open Chrome from the list > Force stop.

After that reset the Network settings > Settings > System >Reset > Network settings reset > Network settings reset again to confirm.

Finally, open Wi-Fi and connect using Modzilla Firefox.


😎🤗🤐
Userlevel 7
Badge +8
Thanks for sharing @Greywolverine.

Please let us know how it goes when you try it! 🙂

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings