Problems in Australia


Hi. Just returned from a holiday in Australia and wonder if anyone can shed any light on the problems I had whilst over there. I have a P20 lite which I use on the three network. I have an Advanced plan which gives me calls, texts, etc whilst out in Australia.
The problem I had was the phone would connect to a network but would drop after a couple of minutes. If I turned flight mode on then off it would reconnect but drop soon after. When the network dropped I couldn't see any old texts, the phone attempted to load the text screen but then went back to main screen. The phone also was very, very slow. It could take anything up to a minute to load the camera or photos in gallery. It also hung quite often and only way to get over this was to hold button down forcing a restart. The battery life changed dramatically for the worst and the phone keptcrestrting itself when it was on recharge over night.
Since I have got back in the UK it is fine. I stopped on Singapore on the way over and the phone worked fine.

Is it possibly something unique to Australia?

1 reply

Userlevel 6
Badge +6
Hi Popeye,

Sorry to hear of the situation, and a truly strange one it is.
So back in the UK region the phone is acting normal, no issues what so ever?
If you could please PM me with the IMEI and build number with the #Australia, there are several questions and details I would like to ask you about

Looking forward to your reply,
Max

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings