wish: Make Huawei phones android auto compatible



Show first post

43 replies

So I have a mate 20 Pro and can't use it via USB cable in my audi. It looks like I need to download the android auto app so I'll try that.
From Richie B's post above he said he downloaded it while the USB cable was plugged in the car.
Do you need to be plugged into the cars USB port via the cable while downloading the app for it to work properly?
Give it a try, though I'm not sure if it actually makes a difference James. You definitely need Android auto app before trying to connect using the usb cable. This assumes the Audi system requires/ is compatible with Android auto. Also check if Audi do their own in house app . .. you never know!
Hello I have recently got my Mate 20 Pro and for some reason when I try to connect it to my car stereo it's saying device not compatible however it supports Android.

https://www.sony.co.uk/electronics/in-car-receivers-players/dsx-a310dab

The link above is my radio, is there a setting up need to change for this to work? Thank you
Your Sony set up says it supports Android Open Accessory 2.0.

Try downloading an AoA 2.0 app from Google play to see if that works. Possibly Android auto might do or on of the others that comes up from the Google play search
Hi I have what I thought was the best handset I've ever owned until I tried various if not all of the apps for linking to my pioneer head unit android auto, mirror link, app radio, not one works,
In this day and age you would expect a flagship model to have this function, so was eagerly awaiting the mate pro only to read people having same issues?????
Really??? Come on Huawei please sort this now?
really want to stay with you but I'm growing impatient and want to make the most of my pioneer head unit.
Looks like I will have to sell the p20 pro and jump ship 😪
P.s what's mirror share and how can I get that working with pioneer
Hi

I have had my hauwei mate 20 pro for just under two months now and I love it.

I recently got a new car, a 2019 Ford Figo and I am having issues with keeping the connection with regards to the Bluetooth.

It connects perfectly but after about 30seconds the Bluetooth disconnects and the car says trying to reconnect.
I have no problems when connecting an iPhone to the Bluetooth, so I figure it must be the hauwei.

Please help
I'm having problems with my mate 20 pro too! it's completely not connecting to my car (Audi A3 2017) i've tried different cables even using the original cable.

PLEASE HELP!
Userlevel 4
Badge
@MrSlaymaker Our testing team is working on reproducing this issue and testing it on various devices.

Thanks for sharing a very detailed feedback as it's very important for us to understand what car, phone model and software version you use.
Hi @Kat please can you look at my issue above and advise?
I also have the mate 20 pro. I can pair with my head unit on my Peugeot 108.
It connects to the phone via Bluetooth & imports the contacts and messages. But for some reason the audio only pairs as a removable device, meaning that although it get sound, there is no song or artist info or album art displayed in the screen.
Pluging in using the supplied cable has no effect at all.

Im guessing that the reason so many people are having issues is that there is no mirrorlink software built in to Huawei phones, so all that happens when you plug in to the car with a USB cable is charging.

You don't really need a car with Android Auto, most touchscreen Car head units connect via the mirrorlink protocol, your car has it, but your phone doesn't.
See here https://mirrorlink.com

Unless Huawei plan to release an update with mirrorlink included then nothing is going to change.
Hi @Viking_beard

My car does not have the touch screen or mirror screen. It is just a normal Bluetooth standard system.
It connects but disconnects after 30 seconds and then it says trying to reconnect on my car stereo
Userlevel 4
Badge
Sharnew wrote:


Hi @Kat please can you look at my issue above and advise?



Hey

Just checked the Android Auto pages and found this: https://www.android.com/auto/ford/
It looks it's not compatible with Ford Figo:(

Let me know if your case is related to Android Auto in particular.

Kat
I'm having a similar issue. Received new p20 Pro last week didn't work went plugged into 66 vauxhall corsa using original cable).
Downloaded android auto and added permissions etc.
Once plugged in the phone restarts many times then comes up with a warning advising to reset to factory settings. Once unplugged it resrats in safe mode.

Took the phone back and got a replacement but having the exact same issue. Used a family members p20 Pro and had no issues in the car so thinking that rules out the car being at fault.
Also phone won't connect over Bluetooth, car can't find phone and vice versa.

Can anyone advise how to solve the problem.
hi @Kat
to follow my original post and your request, my handset is a p20 pro car stereo is pioneer avh 2700bt
not one in car conection app works mirrorlink android auto not even pioneers own app app radio Bluetooth is ok though thank god or phone would be gone, really want to stick with Huawei if this issue is sorted but already looking at other handsets.
thanks
jools
Userlevel 4
Badge
Joolsey wrote:

hi @Kat
to follow my original post and your request, my handset is a p20 pro car stereo is pioneer avh 2700bt
not one in car conection app works mirrorlink android auto not even pioneers own app app radio Bluetooth is ok though thank god or phone would be gone, really want to stick with Huawei if this issue is sorted but already looking at other handsets.
thanks
jools



Hey Joolsey.

Unfortunately tt looks Pioneer avh 2700bt which is in your car does not support Android Auto app.. Take a look at this page to see more information.

Best,
Kat
Userlevel 7
Badge +8
Hi all,

I created a F.A.Q. for issues with Android Auto. Please try the troubleshoot in this topic if you are having issues with Android Auto and with connecting your device to your car.
Hi Kat and Amy, I have still not received response from Huawei on my Nova3e (P20 Lite) phone issue with Android Auto. Everything else works properly but phone dialling does not work. I have updated to 8.0.0.162 but still same problem. Please advise.

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings