Question

Connecting to Wifi

  • 3 August 2019
  • 6 replies
  • 57 views

Hi,
Just recently my p20 pro phone has decided that on WiFi networks that I've connected to previously i.e home and my parents it will connect but showing now network but then next to the network name it says login authentication required but then a android notification appears asking me to sign in I click it and it takes me to a virgin troubleshoot page saying click here to fix which I do, it then goes around as a percentage but then says unable to fix. After a while it connects as normal. Is this a normal thing to happen or should I be worried.

6 replies

Userlevel 6
Badge +5
I had the same problem with my Virgin Router. It's not the phone it's the router. Contact Virgin. You may need an engineer to come around.
Userlevel 3
Odd to happen at both locations & recently happened, Both are virgin I guess?

I think more testing is needed, is it fine on non virgin wifi networks?

I have access on vm with a mate 20 pro & my brother uses p20 pro, both has never encountered this on virgin.
Userlevel 6
Badge +5
For me is fine on non Virgin WiFi. I still have have Wifi issues on my Virgin Router.
Userlevel 3
I see, Their software isn't ideal & did you try factory reset your router as well?

I had issues with wifi on virgin with chromecast and a tv, worked fine through another router while vm hub was on modem mode. Used for a while then factory reset and everything worked after.
Userlevel 6
Badge +5
My router won't factory reset believe it or not. Tried a few times. Router issue.
Userlevel 3
Oh dear, thats bad, isn't there a physical button & software factory reset via login?

Reply