Answered

I have a P20 Pro with no signal

  • 17 June 2019
  • 1 reply
  • 349 views

Hi there I have a P20 Pro on a tesco contract and I haven't had signal for over 3 weeks now l, I have tried to factory reset my phone I have tried going through the APN settings and still to no avail. I have also contacted tesco mobile directly to see if there is anything wrong with the network or other factors that I am unaware of and I also sent it off for repair and got the phone back within a week with a letter saying that it could not be repaired as they didn't know what was wrong with it, I have been told that I will have to send it of to Huawei directly and that it will cost me a further £85 and I have full insurance, I'm allreay paying nearly £30 a month for my contract but had no use for 3 weeks now can anyone help me please any guidance would be grateley appreciated. Thankyou in advance Simon
icon

Best answer by Amy 17 June 2019, 10:23

Hi Simon,

Sorry to see that you are having issues with your device. :(

Since you have already tried a factory reset etc, I recommend that you contact the support team directly: https://consumer.huawei.com/uk/support/

Please let us know how it goes.
View original

1 reply

Userlevel 7
Badge +11
Hi Simon,

Sorry to see that you are having issues with your device. :(

Since you have already tried a factory reset etc, I recommend that you contact the support team directly: https://consumer.huawei.com/uk/support/

Please let us know how it goes.

Reply