P20 Emergency Calls Only

  • 5 September 2018
  • 50 replies
  • 38699 views


Show first post

50 replies

Hi everyone - I purchased a P20 lite back in June, and was delighted with it until my first trip abroad. I live in London and travel frequently. Unfortunately, because the issues only arise when I travel abroad and I'm usually busy, I never have time to look into too far into the issue and then when I'm back in London things get resolved so I forget about it...until my next trip.

When I'm abroad, my phone loses signal - I get a "no service" over a SIM card icon and the phone loses other functionalities too when it's like this - it often ceases to be be touch sensitive and often I have to restart it to get anything out of it. It just completely slows down.

Toggling airplane mode on and off is helpful for anywhere between a few minutes to an hour, but it seems to lose service if I use the phone. So I might be able to make/receive a phone call/text, and then it loses service. In addition to this, the battery drains very quickly, I might run out completely within 8 hours of NOT USING the phone (phone on, without service). Keeping it on airplane mode with Wi-Fi on allows me to receive internet related information with normal battery usage.

When I went abroad for the first time, I had service but no internet but was able to follow some recommended settings changes which eventually got me to get internet...intermittently...along with intermittent service.

I thought it may have been an issue with my SIM card so I ordered a new one but the same issues continue.
My partner uses the same service provider with a different phone so we swapped SIM cards while travelling and my phone was still having the same issues so it's definitely an issue with the phone.

I travel too often (and am currently abroad for two weeks), and this has become a major problem. Reading the amount of people who are having the same and similar problems makes me just want to replace my phone with something else - I don't have time to be resetting my phone or trying to resolve issues with something that should be plug and play. My phone is set to automatically upgrade software so whatever version I have is always the latest.

Can someone explain to me what I should expect as I intend to return my phone and purchase something completely different? I purchased it through Amazon and from experience, since I've had it for more than one month, they will have me deal directly with Huawei.

Thank you.
I've had the same issue since being on holiday. Constantly losing signal, works for about 10mins before dropping off despite full bars of signal, then had to restart phone to get it working again-for it to last 10 mins before going again etc. Julians suggestion didn't work for me but on another forum someone said turning off location services sorted it for them. As soon as I turned it off signal returned and has remained 🙂
Thanks Gem78 - I've just turned off location services to see if that helps, but I take it that means that I can't use services such as Google maps when driving through a busy city I'm not familiar with, or navigating territory I'm not familiar with... Meaning the phone might work as it should so long as I turn off something I consider a main feature 😕
Unfortunately, turning off location services hasn't worked and I'm once again with no service 😞
Userlevel 7
Badge +6
Hi all,

Sorry to hear that after following the troubleshooting steps you are still facing the same situation. In this case I would kindly recommend to have the device inspected by our professional engineers at our official service center.
For the UK region you can arrange the service booking via mail chat or hotline (at 08000886700 free of charge of course) via https://consumer.huawei.com/uk/support/

Hope you found this helpful.
Best wishes,
Max
Hi Max,
Thank you for this, but honestly, as it takes being abroad to find out whether the phone is working properly or not, this isn't going to work for me. How can I go about getting a refund? I'm really tired of the problems and of only being able to test whether the potential solutions work when I'm travelling and either needing to deal with business, family or navigating unfamiliar territory without a proper phone.

Thank you,
J
Hi cravocanela,

Thank you for your detailed write-up. I had exactly the same issue with the phone when I was in Tenerife for a week just before Christmas. I got the phone in July 2018 and was in France for 3 weeks in August 2018 with no issues. The phone was perfect before Tenerife and has been perfect since I got back to London.

I called up Huawei support on the 0800 number provided by Max. They told me that this is a known software problem (nothing to do with phone or SIM) with no workaround. They are aware of this trail and are escalating to get a solution.

I have provided the e-mail sent to me below with reference number.

I absolutely agree with your assessment that the phone does not work and customers should not be asked to try various supposed solutions.



Thank you for contacting Huawei Customer Support.

As discussed on the phone, please find below the reference number for our conversation: SR320190102130329380

I will get in touch with you, as soon as we receive an update in regards to your inquiry.

If you have any other questions or inquiries, don't hesitate to contact us.

Best regards,
John
Huawei Customer Care Representative
I've got the same problem.Last Friday morning I've got a text message, but after that it showed emergency calls only. Removed the sim, put it back, same. Restarted the phone, same. Put my sim into my wife's phone worked fine in her phone. Tried to put her sim into my phone, it worked, so I thought my sim had some problem, so I ordered a replacement sim from my provider. But my wife noticed my phone shows again emergency calls only with her sim card too, but On Saturday it worked with her sim card. I have the ANE-LX1 8.0.0.151(C782) update ion it, but I put this update on it around 2 months ago. Contacted Huawei by e-mail and chat, both said to factory reset the phone, but as previously some of you wrote it didn't help, I won't waste my time doing it, e-mail also said to send it into Huawei for an inspection, and they try to repair or fix it, the chat told me the developement team will try to make a hotfix and send it manually to my device as an update patch. I was asked to provide the imei sn and build numbers. So will see what happens... Hopefully they sort it out soon as the last post before mine is 23days old, so Huawei knows this problem.
Hi guys. Same problem. Bought the Huawei P20 lite from Argos. Definitely going to fight for a return. Took the phone to holiday and now the screen has been damaged by the heat it seems. There is a permanent black line on the edge and the lights flicker. Although no internal screen damage or cracks can be applied.

But before that even happened, I got the famous preferred network closed signal. I called up three. They couldn't find any faults with my IMEI. Put my sim into my old phone and it worked which means the SIM card is not damaged. I have tried factory resetting this phone, network resetting, resetting all data, resetting all cache and no luck in the slightest.

Very very frustrated. Never encountered this problem ever. Very Sad as I had bought a huawei P10 lite version previously however from the experience I have mind you I've only had this phone for 2 months that you stay well clear away from it!
Userlevel 7
Badge +6
Hi @steveo,

Sorry to read about the situation.

Prior to the update, have you performed a factory reset after this? We strongly recommend performing a factory reset of your device after a major update.
You can find the steps on how to do this here .

Keep us updated in regards to the situation!
Max
No, haven't wasted my time doing factory reset as just 3 previous posts said they did factory reset but the emergency calls only was still there...also I got the update when I bought the phone around 2.5months ago, and it worked fine until last Friday. You should find a solution with the software and send them to the affected phones and not saying this silly factory reset things which doesn't help! The first post about the problem is not new and you are still unable to sort it out!
Update to my situation:

I bought a micro sim to nano sim converter and put my SIM card into my sony Xperia Z2 phone and an Acer phone. I was able to use mobile data, receive text messages and make calls. Therefore it is definitely not a issue with the SIM. I also noticed whilst connected to Wifi on the Huawei P20 Lite I was able to send texts and make calls only when connected to WiFI using the 3 Wifi calling (Which the 3 network allows you to do). Once disconnected from WiFi, I had no data and got the emergency calls error with the preferred automatic network closed.

Therefore this definitely confirms that this is not a error with the SIM but with the phone itself. Perhaps it is the Update. My phone was working fine up till January 19th when things went bad, when i went abroad. No amount of factory resetting, network resetting, app cache clearing or resetting all data will change everything as I tried this multiple of times. Even the staff today at Argos who tried doing it today no luck.

I returned the phone regardless (since my screen was also messed up) but either way, I think its a software bug specifically for P20 phones that Huawei need to sort out. Because when I had the P10 lite, I did not have this problem.
I inserted my sim card to my wife's phone, I popped in to EE, shop assistant tried my sim with his phone, in both phones worked well, just not in my P20 lite...
Userlevel 7
Badge +6
Hi @steveo,

Sorry to hear about the situation.

Have you tried the steps I provided above?

Best wishes,
Max
I've had my P20 mate pro since December and by the start of January I've been getting the "Emergency calls only" error! Mine mainly happens when someone calls me or mid call and need to restart my phone everytime. Its honestly the most unreliable phone I've ever owned. The camera sometimes says an error "can't connect to camera" and again I need to restart the phone.
These issues need sorting immediately as it's disgusting having to pay £53 a month for something that only partly works!!
I've tried every single solution and nothing at all works.
The longest it went without getting sim error was when I manually changed my provider in network settings and changed the data from 4G to 2G
I had exactly the same problem when I was in Tenerife in December 2018. I have described in a post above.
I am now in France and have had no issues.
Huawei support are a total waste of time. There is no point setting or resetting anything on the phone.
I have no idea how the problem arose in Tenerife and has not appeared when France, and it looks as if Huawei don't either.
Has anyone had any luck in solving this issue?? I've had this same problem in my P10 Plus since 2 days ago and I've tried everything possible to fix it and still no luck.

I've had the phone for more than a year now and everything was working fine and now I just can't get 3G or 4G working on the phone. The only network that is still working is 2G which is mostly just for receiving and making calls since the internet speed is so slow you just can't use it.

I've tried every solution available here. From restarting, to reseting the network setting, manually changing the carrier and even, as a last resort, factory reseted my phone but the problem remains.

Since I live in Brazil and have imported the phone, there's no technical support nearby I can use. I just don't know what else to do. I can't have a phone that only works with wi-fi and 2G.

Can anyone help me?? I'm getting desperated here
IT WORKED!

I got my phone around October last year. It was working really well until last week. I remember using my phone as usual that day and then it suddenly showed "no service" on the top left side of the screen. I tried to restart my phone and switch my sim card on the slots a couple of times but nothing happened. I decided to get a new sim card thinking it was the problem. And when I finally put the new sim card, I was so worried because it didn't fix my problem. I felt desperate and so I looked for ways (I was led to this forum) to try fixing it on my own. I just don't have the time to do a factory reset, and set up my phone once again (plus, the others said it doesn't work either).

I just tried my luck and chose the "network settings reset" instead. IT WORKED, you guys! Give it a try. I was so relieved and so I thought this might help fix your problem as well!
IT WORKED!

I got my phone around October last year. It was working really well until last week. I remember using my phone as usual that day and then it suddenly showed "no service" on the top left side of the screen. I tried to restart my phone and switch my sim card on the slots a couple of times but nothing happened. I decided to get a new sim card thinking it was the problem. And when I finally put the new sim card, I was so worried because it didn't fix my problem. I felt desperate and so I looked for ways (I was led to this forum) to try fixing it on my own. I just don't have the time to do a factory reset, and set up my phone once again (plus, the others said it doesn't work either).

I just tried my luck and chose the "network settings reset" instead. IT WORKED, you guys! Give it a try. I was so relieved and so I thought this might help fix your problem as well!


Unfortunately, that didn't work for me. Still having the No service problem. Only working on the 2G 😩
Userlevel 4
Badge
We are sorry, unfortunately the community do not seem to have an answer for your query. We'd suggest you reach out to our official support channels here https://consumer.huawei.com/uk/support/
I just had the same problem. I have resolved it and hope it will help others.

What is happening on my phone (P20 lite) is when it does a restart sometimes it does not unlock the SIM card. On other phones when doing a restart I would be asked for the SIM PIN and the Phone PIN but on this I am only asked the phone PIN.

I went to the SIM settings to find it was not activated (mine is dual sim so both not active) I activated one of the SIMs (my main one) and then got asked the PIN for the SIM. Once entered it was working again.

There must be a bug after a restart that is either not restoring the SIM with the last used PIN, or stopping the phone from asking to enter the SIM PIN, or perhaps it should not be deactivating the PIN for the SIM when shutting down. Either way it is a bug.
Syvers what do you mean by "activating the sim"? Mine is a dual sim too, they both went grey, "no sim" and i cannot use the toggle bar to "activate" i guess... They worked totally fine for over a year, and for 4 months in Lebanon, and today morning suddenly gone for no apparent reason.. Switched the phone on and off, my UK sim came back for like 3 minutes and ever since it's "sos only", so i cannot use my phone now in a country where i would particularly need it...

Reply