Answered

P20 Microphone not working when loudspeaker is ON

  • 7 June 2019
  • 3 replies
  • 1985 views

I've got Huawei P20 for almost a year now, and about 3 weeks ago I sent it in for screen replacement for three dead pixels.
The device came back yesterday with a new screen but I've noticed that when I make calls the receiver can't hear me talking when I'm using the loudspeaker on the phone. They can only hear me when the loudspeaker is OFF.
This situation is like this whether I'm doing a normal phone call / Whatsapp call / Messenger call / video call.
Loudspeaker ON means the microphone not working!
  1. I did a factory reset on the phone but the problem persist.
  2. I tried to test is again with my recovered backup but no luck.
  3. I googled for a similar problem but it seems that other people have the opposite problem!
  4. Checked for software updates but as of today's post I'm using the latest version build 9.0.0.261 (C185E2R1P12).
  5. Tested to use the recorder app to see if its a mic issue but it was working perfectly.
  6. I'm not sure if this info helps but when I got my phone back it said on the report that the service centre did 5 system software upgrades (Surprisingly as I always do my System software upgrade up-to-date). Not sure if this current update is glitching somewhere with mic and speakers.
  7. I checked for apps permission and still no luck, specially after factory reset.
  8. I'm sure that I had no issue with a mic and speaker before replacing the screen. It always used to work.
  9. I don't use private space or google sound assistant.
I'm not sure if there is one mic of two in the phone, probably a mic embedded with a speaker that doesn't work when speaker is ON! (faulty).
Could it be a problem after the service centre did a screen replacement and forgot to reconnect something?

Any help please before I book it in again with a service centre.
Thanks all.
icon

Best answer by iTeacher 10 June 2019, 09:53

@drhouse Not helping, I had to send it for Huawei service center, they say it could be a hardware issues, will keep this post updated to assist people in the future for similar issues.
View original

3 replies

Userlevel 4
Badge +4
Hi @iTeacher and welcome to the forums!

From the sounds of it, this seems to be hardware related. But before you send out to the service centre, can you restart your phone in safe mode and make a call to see if the above is still the case. details in this post: https://uk.community.huawei.com/p30-series-30/p30-pro-camera-not-working-4935#post26951
@drhouse I followed your way of putting the phone into safemode but my recovery doesn't have the safemode option. Maybe it's a different way for P20?
I'll Google safe mode
@drhouse Not helping, I had to send it for Huawei service center, they say it could be a hardware issues, will keep this post updated to assist people in the future for similar issues.

Reply