Answered

Problems with the Google Assistant on my p20 lite


I'm having issues with the setting that allows me to say "ok Google" to activate the Google Assistant instead of clicking on the Google Assistant app
icon

Best answer by Tony 13 August 2018, 10:02

Hi @Narners

There could be a number of reasons why this is happening. I see you're on WiFi, does the same thing occur if you disable that and set it up using 3G/4G?

If so then try going into settings, apps & notifications, apps, tap on Google, then Storage, Manage Space then tap Clear All Data. Once you've done that go back one step then also tap Clear Cache.

Go back to the apps section and this time locate Google Play Services then do the same thing. Once that's done restart your phone and try to setup OK Google again.

Let me know if that doesn't fix it.
View original

14 replies

Userlevel 7
Badge +7
What exactly is the issue? Is it simply not opening when you say "Ok Google"?
This happens every time I try to set it up

Userlevel 7
Badge +7
Hi @Narners

There could be a number of reasons why this is happening. I see you're on WiFi, does the same thing occur if you disable that and set it up using 3G/4G?

If so then try going into settings, apps & notifications, apps, tap on Google, then Storage, Manage Space then tap Clear All Data. Once you've done that go back one step then also tap Clear Cache.

Go back to the apps section and this time locate Google Play Services then do the same thing. Once that's done restart your phone and try to setup OK Google again.

Let me know if that doesn't fix it.
Userlevel 2
Badge
Hi Narners!

We are glad that you are using our device.

we recommend that you also try with mobile data to see if it works. Another thing you can check that the Google Assistant is activated(Settings > Google > Search > Voice > Voice Match > and enable Say "Ok Google" any time).
Then you have to go to the main screen and press on the circle for 4 seconds (the button that comes in the bottom) and it should work.

I trust this information is of assistance. Should you have any further questions, please do not hesitate to contact us.:D

Julian
Google assistant was working well until about a month ago, now it does not respond. The microphone works, and Google has permission to use it. I've deleted my voice model and when I try to re-record a new model, nothing happens. I mean, it is at step one of asking me to say Ok Google, and it never heard me. I've deleted all Google data, cleared the cache, reinstalled Google, reset the phone, and swore a few times... Nothing has helped. Any ideas? Oh, it's a P20 Lite.
Dave
Userlevel 7
Badge +11
Hi David, - Welcome on the community! 🙂

I moved your topic to this thread. Please read the comments above and leave a comment if you need any assistance.
Hi Amy,
I didn't add to this thread since it is marked as solved and none of the suggestions fixed my problem. But no matter, as long as I can find a solution. :)

I've also tried removing Google's permission to use the mic, resetting the phone and giving permission back. Nope.

What else could I try?
Userlevel 7
Badge +6
Hi David,

Sorry to hear the issue you are experiencing with the Google assistant. From what you have described you have done a pretty intensive and meticulous troubleshooting to the device.
May I ask what software version you are currently ruining on it ? Also, when you mentioned 'reset' do you mean a factory reset or a soft reset of the device?

Looking forward to your reply,
Max
Hello there,
I've placed a phone info screenshot below.

Google: 8.59.7.21
Google Play Services: 24.7.99

The reset was holding down power and volume up for 10 seconds.

Could it have anything to do with having "only" 6 GB free?

Thanks a lot for your time,
Dave
Userlevel 7
Badge +11
Hi Dave,

I deleted your screenshot because it has your IMEI number on it and it's against community guidelines to share personal info, such as your IMEI.
Hi Amy,
I didn't add to this thread since it is marked as solved and none of the suggestions fixed my problem. But no matter, as long as I can find a solution. :)

I've also tried removing Google's permission to use the mic, resetting the phone and giving permission back. Nope.

What else could I try?

HI David I'm a fellow P20lite user, you problem sounds similar to one of mine. Make sure your Google app has permission to use storage, that's how I got it to hear my voice when training the assistant. Hope it works
Hi MrLaw,
Thanks for taking the time to help me. Unfortunately that didn't solve my problem. I also freed up about 10 GB of space, in case more storage space was needed. Nope.

Every time I try to train my voice, I say "Ok Google" and my cat meows. At least he's listening. 🙂
Hi MrLaw,
Thanks for taking the time to help me. Unfortunately that didn't solve my problem. I also freed up about 10 GB of space, in case more storage space was needed. Nope.

Every time I try to train my voice, I say "Ok Google" and my cat meows. At least he's listening. :)

Cats will always be there when technology fails us lol, and I've only found problems like this on the P20 lite, assistant works perfectly on my P10, hope you get the issue solved somehow.
Hi David,

Sorry to hear the issue you are experiencing with the Google assistant. From what you have described you have done a pretty intensive and meticulous troubleshooting to the device.
May I ask what software version you are currently ruining on it ? Also, when you mentioned 'reset' do you mean a factory reset or a soft reset of the device?

Looking forward to your reply,
Max

I've re-added a screen shot of my s/w versions, removed sensitive info.

Reply