Question

Stuttered sound over bluetooth with AptX codec

  • 20 April 2019
  • 2 replies
  • 757 views

Hi, I just bought the Audiocore AC830 bluetooth audio receiver and paired it with my P20Pro phone. The sound I hear from my audio system this way is stuttered (sliced).

I tested the same reciever with other phones (iPhone, Samsung Galaxy S6) and it works perfectly (no stuttering/slicing the sound or any other sound quality problems). So the bluetooth receiver device itself works well.

This audio receiver supports AptX codec and other codecs like SBC and AAC. The connection between P20Pro and this AC830 is with AptX by default and with this codec the sound stutters (is sliced) so heavily that it is not possible to hear to anything.

I activated Developers Options and changed the codec to SBC. It helped somehow, but not in 100% - the sound is not so sliced, it plays smoothly at about 95% of time, but once in few minutes it stutters for few seconds - it is annoying enough to spoil the experience. The same is when I use AAC codec - better than with AptX but still not ok.

I observed, that the sound starts to stutter when I do something on the phone (browsing internet). Please note, that on other devices (iPhone, Samsung Galaxy S6) there is no such problem of stuttering or any other distortion of the sound transmiting to my AC830 during doing something on the phone.

The results I achieved trying to solve this problem allow me to listen to music from for instance Spotify when I do nothing more with the phone (however with annoying stuttering once in few minutes) but it does not work for the case of for instance watching the Youtube - as the phone is bussy with video task the audio stuttering is so heavy that it has no sense to hear.

By my observation the problem may be in the priority of the process/thread which codes/decodes the sound for sending it to this device. So maybe some tweaking in process priorities, maybe somwere in the area of power management could solve it?

Please let me know if you have any solution or idea what to do next with this issue, how to solve it?

regards
Jumper

2 replies

Userlevel 6
Badge +4
Hi @Jumper ,

Welcome to the community. Sorry to hear you're having issues with audio. I've flagged this for the support team to see if they can help.
Userlevel 7
Badge +6
Hey @Jumper, welcome!

Thanks for letting us know about this! It must be very annoying. We apologize about any inconvenience this might have caused!

Have you tried resetting the network settings? In some cases this can be caused by Bluetooth or other network settings being changed accidentally.

To do that please open Settings > System > Reset > Network settings reset > Tap on the button!

Please check if the issue is solved after this!

Let us know if this helped!
Max

Reply