Answered

Connecting to router, no internet

  • 6 April 2019
  • 20 replies
  • 20261 views

  • Opening Fortune Cookie
  • 1 reply
Hello. I have a P30 Pro. It connects to the home router / wifi, but has no internet access.
Tried resetting the router a few times.
Resetting the phone.
Other devices (including a P20 Pro) connect and have internet access.
Any other suggestions?
Thanks
icon

Best answer by Tony D 9 May 2019, 19:54

I found this elsewhere and it worked a treat...I use BT

1. Open a Web Browser Window.
2. Type the BT HUB 5 router homepage address (192.168.1.254).
3. Type in the Admin password
4. Click on Advanced Settings
5. Click on Home Network
6. Look for the Enable Smart Setup Wizard tab
7. It's likely to be already enabled (i.e. Yes is ON). If it is, click on the No button and select Apply. This switches OFF the Smart Setup Wizard
8. Switch off your phone's Wi-Fi. Wait for a few seconds. Switch it back on.
9. Search for your BT HUB 5 and reconnect.
10. You should find your P30 works perfectly with the Wi-FI (whether it's the 2.4Ghz or 5GHz channel).
View original

20 replies

Hello. I have a P30 Pro. It connects to the home router / wifi, but has no internet access.
Tried resetting the router a few times.
Resetting the phone.
Other devices (including a P20 Pro) connect and have internet access.
Any other suggestions?
Thanks

Having exactly the same issue, just received my P30 today, tearing my hair out! Any help would be greatly appreciated, have also tried resetting router/ phone several times. Cheers
My partner figured it out.
My way that didn't work - The phone was searching for wifi, it found our network, so I just added the password, but it wouldn't get internet access.
When she done it, she manually added our network name, then selected WPA/WPA2/FT PSK in security, then the pass and it connected with internet access.

Try that. Hope it helps.
Many thanks, glad it worked for you! Gave it a go, same results. Will call the Huawei help line when it re-opens on Mon, cheers.
Hi, I am having the same Issue! It's driving me mad. Anyone found a solution? 🤔
I spent a full day trying to work this out.I have tried factory resetting my phone, resetting my router. i was even tinkering with my router settings on my computer, It was very frustrating but i may have a solution. If you type in your IP address into your google chrome or internet explorer (on your P30) then it opens up parental controls and asks you whether you'd like them or not. I said no, signed into my BT account and from there it connected instantly.

Really hope this helps someone.
JSaunders17, you are an absolute legend! Just gave that a go, problem solved. Cheers!
Going to give this a try. Where do I find My IP address please? I am struggling without WiFi!
Userlevel 6
Badge +5
Well that's pretty strong parental control - no Internet at all 🙂
I have the same problem on my workplace Wifi: It works for some time and then the dreadful "no internet connection" appears and there's nothing to do from that point but forgetting the network and connecting again.
Which IP do you have to insert in a navigator exactly, the phone or the router to connect to?
Userlevel 7
Badge +6
Hi all,

Sorry to hear about the situation you are experiencing. In this case, I would recommend trying to set up a static IP.

  • If you are connected to a Wi-Fi network, touch and hold the network name, go to Modify network > Show advanced options > IP settings, select Static, and set the static IP address parameters.
  • If you are not connected to a Wi-Fi network, touch the name of the network you wish to connect to, then go to Show advanced options > IP settings, select Static, and set the static IP address parameters.
Set the following static IP address parameters: IP address (usually 192.168.1. ***), gateway address (usually 192.168.1.1), network prefix length, and domain name (DNS address). If you require more details, check either with your Internet provider or the router's parameters.

When setting the static IP address, you may find that the connect button is grayed out and you cannot connect to the Wi-Fi network. This is to protect the bandwidth of the router. To address this, you need to enter the router password again.

Hope this proves useful.

Best regards,
Max
Userlevel 4
Badge +1
If you are in the UK on BT, make sure you turn off captive portal for first use for new devices. Or at least be aware that it might stop you getting Internet access. Not sure if other ISPs have this feature as well.
I'm having this exact same issue. New p30 pro and anytime I connect to the WiFi it slows everything making everything run extremely slowly. If I want to use my phone I need to use my data which isn't ideal. I'm with EE and already called them and narrowed the issue to my p30 pro which is hogging all my internet basically.
What can I do to fix this?
Userlevel 4
Badge +1
Hi @Kpreston8 do you use BT WiFi at home? If so, please use a browser to use the set-up or disable via the router's interface. If you haven't done this, the router will not be usable for your phone. You only need to go through the initial setup once for each new device.
no I'm with EE broadband
Userlevel 4
Badge +1
Hi @Kpreston8 I just replied to your other topic regarding the broadband issue.
I too have the Huawei P30 Pro, it's on EE network and my home broadband is with BT.

My phone connects to my mum's internet (she's not with BT) but when I try and connect to my wifi at home it displays the message connected (no internet access). It's so frustrating I've tried absolutely everything, restarting my phone, resetting the network connection, forgetting the network connection, clearing cache and rebooting phone. I've changed my BT internet channel and been on to them about the problem. I've reset my Hub, forgot network, rest hub again then tried to reconnect. I've tried adding connection manually and tried to connect both via password and WPS. Still nothing!

I wish I'd never got the phone at the minute because I never had this problem with my previous phone 😭

Could somebody please help me (using basic terminology)? I'm not sure what else to do.

Thanks in advance.
I contacted BT in the end and they did something at their end that solved the problem. I hope you find solution.
I found this elsewhere and it worked a treat...I use BT

1. Open a Web Browser Window.
2. Type the BT HUB 5 router homepage address (192.168.1.254).
3. Type in the Admin password
4. Click on Advanced Settings
5. Click on Home Network
6. Look for the Enable Smart Setup Wizard tab
7. It's likely to be already enabled (i.e. Yes is ON). If it is, click on the No button and select Apply. This switches OFF the Smart Setup Wizard
8. Switch off your phone's Wi-Fi. Wait for a few seconds. Switch it back on.
9. Search for your BT HUB 5 and reconnect.
10. You should find your P30 works perfectly with the Wi-FI (whether it's the 2.4Ghz or 5GHz channel).
Just picked up my new P30 Lite & all is well but it did not want to connect to internet via BT hub. I followed Tony D's advice and spot on connected with no issues...bloody BT!!

Cheers for sharing!
I just got a y6 2019 and had this problem. Disabling smart setup as described above worked for. Seems the bthub5 smart setup is not so smart after all!

Nick

Reply