Answered

Huawei P30 doesn't connect to public wifi via web page login

  • 24 April 2019
  • 12 replies
  • 10328 views

Userlevel 1
  • Fearless Explorer
  • 6 replies
I'm afraid with my P30 Pro I have the same problem as already described here:
https://uk.community.huawei.com/p20-series-31/huawei-p20-doesn-t-recognise-public-wifi-333

I discovered this issue while on holiday in Italy, but it's not working in public places at home either.

What is the reason I'm first directed to http://connectivitycheck.platform.hicloud.com instead of the login page?
icon

Best answer by jimy 12 May 2019, 12:56

I have just bought a Mate 20X, and I have got the same issue.

Finally, I have tried this and it's work for me :

Go in the setup, Wifi & Network when Wifi is Off, you can view and change Private DNS settings from :1dot1dot1dot1.cloudflare-dns.com to automatic. Save. Put the Wifi On. It should work now.

Let me know if it works also for you.

BR
Jimy
View original

12 replies

Userlevel 7
Badge +11
Hi rbo01,

Welcome on the community. I hope you are having a great time in Italy! :)

I flagged your question for our support team. They have some outstanding questions so it might take a while before they reply. Please phone the hotline if you cannot wait any longer: 08000 886 700 Mon - Fri 09:00 - 21:00, Sat. 9:00 - 17:00 (except bank holidays).

Did you try the steps provided in the other thread?

1. Settings > Wireless and networks > Wi-Fi > Configure > Keep Wi-Fi on during sleep > Always.
2. Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > you must disable it.
3. Settings > System > Reset > Network settings reset > Network settings reset again to confirm.
Userlevel 1
Thanks Amy,

The menu system seems slightly different on my P30 Pro.

Do you mean:
1. Settings > Battery > More battery settings > Stay connected when device sleeps > On
2. Settings > Wireless and networks > Wi-Fi > Wi-Fi+ > you must disable it.
3. Settings > System > Reset > Network settings reset > Network settings reset again to confirm.

I reset the network settings and restarted my phone, but I'm still getting an error message when being automatically forwarded to http://connectivitycheck.platform.hicloud.com.
Userlevel 6
Badge +4
Hi @rbo01 ,

Yeah, there's probably a slight difference in the menu. Your post is flagged with support, so hopefully they can assist further.
Userlevel 1
I also saw below topic, discussing public wifi networks:
https://uk.community.huawei.com/software-40/everything-about-public-wi-fi-and-it-s-dangers-881

Sadly installing Firefox and directly entering the URL of the public wifi at my work still gives an error message (both in Firefox and Huawei browser).

Where in the Firefox Android app would I be able to enter a trusted site? I can't find this in the menu structure of the Android app, and online I only find explanations on how to do this in Firefox for desktops.
Same for my p20 pro. None of the steps above did the trick
Userlevel 1
Today I brought my Mediapad M5 8.4 tablet to work (where we also have public wifi with web login), and I was able to log in.

My tablet still has EMUI 8.0.0.196 firmware.

Could the issue be related to EMUI 9 firmware?
I have just bought a Mate 20X, and I have got the same issue.

Finally, I have tried this and it's work for me :

Go in the setup, Wifi & Network when Wifi is Off, you can view and change Private DNS settings from :1dot1dot1dot1.cloudflare-dns.com to automatic. Save. Put the Wifi On. It should work now.

Let me know if it works also for you.

BR
Jimy
Userlevel 1
@jimy , I was able to check this morning at work, and setting Private DNS Settings to "Automatic" also works for me!

Thank you so much, and best regards!
@jimy , I was able to check this morning at work, and setting Private DNS Settings to "Automatic" also works for me!

Thank you so much, and best regards!


rbo01, happy that's work for you also.... 🙂 !

Enjoy free wifi anywhere !
Same problem with my new Huawei P30 pro

None of the workarounds above work

In my opinion, the bottomline here is that this version of android is configured to check wifi / internet connectivity by loading a hicloud.com url, which is blocked by the WiFi provider.

where can this URL be changed to something universally whitelisted? (or with more chances, like google.com or smt)
Userlevel 7
Badge +11
Hey Dizzly,

Sorry for the lack of replies in this thread. As you've not had a response yet we'd suggest you reach out to our official support channels here https://consumer.huawei.com/uk/support/. The support team is happy to assist you! 🙂
Userlevel 1
I have recently solved this problem on my Huawei P20 (I had the same one). It is something to do with the way the browsers interact with the login portal and the phone. I have tried every browser u til I stumbled upon the bing browser. I used the bing browser to login to a login portal whilst other browsers such as chrome, Edge and Firefox rejected the login portal.
Try bing.

Reply