Answered

NM Memory card disappears on P30 Pro


Huawei P30 pro 128gb VOG-L29 with NM card 128GB
All works perfectly, then the memory card randomly disappears in all apps, can't see in file manager or gallery.
Is there some power setting causing this to switch off?
Reset the phone and it reappears - so not a physical connection issue
icon

Best answer by BarneyT 5 August 2019, 14:59

Hey @Dagoof, welcome to the community!

Thank you for your feedback!

Could you please provide me your name, phone number, e-mail address, the serial number and the build number of your device in Private Message?

I'm looking forward to your message! Please don't hesitate to contact us if you have any kind of problems in the future.

All the best,
BarneyT
View original

10 replies

Userlevel 4
Badge +4
Hi @Dagoof
not sure if you would be able to check, on your computer (preferably), how the nano card is formatted? Is it in FAT format or FAT32 . On a separate note, some users encountered difficulties in using their OTG with a card to transfer files/photos etc when using the FAT format (Huawei phones prefer FAT32 format).

See this thread: https://uk.community.huawei.com/mate-20-series-20/mate-20-pro-usb-otg-problem-1932#post27822

Alternatively if it still persists you could also playaround to see if manage to accidentally solve the issue: you can try to remove the card, switch off your phone, switch on and put the card back into the phone.

let us know how it goes.
Due to the purchase of the 128GB P30 Pro model and the love of photography, I felt the need to purchase a 128GB nano memory card from Huawei. A day after it is installed and formatted, I see a warning message on my phone: "You need to restart your phone because the memory card has changed its location" (the message was not exactly this one but it was of this kind). This message only had one option which was the OK key. After pressing the key the phone restarted... I went to check and all data on the nano card was still there. It seemed to have been a one-time situation. But it wasn't... the nano card constantly lost contact with the phone even without the warning message again. I contacted Huawei Mobile Support in Portugal and was told that I had to go to the Lisbon office. Then they found that the nano memory card was in the slot and that for the phone it was just as if I had only the internal memory of it. It was in testing for about 3 hours and they came to the conclusion that everything was fine with the phone and that problem must be with the card... as the card was under warranty I took a statement from Huawei support saying that it was damaged. I went to exchange for a new one ... and now, with a new card, everything is starting all over. The memory card keeps losing connection with the phone constantly and to have it back I need to always be restarting it all the time. There are a lot of complains on this issue. I have noticed that the times when the nano memory card turns off more often is when the phone is "warmer" by the intensity of use or when it is charging the battery ... and what now Huawei Mobile ???
Userlevel 3
Badge +2
Hey @Dagoof, welcome to the community!

Thank you for your feedback!

Could you please provide me your name, phone number, e-mail address, the serial number and the build number of your device in Private Message?

I'm looking forward to your message! Please don't hesitate to contact us if you have any kind of problems in the future.

All the best,
BarneyT
I am using exactly the same phone, Huawei P30 Pro VOG-L29, and the NM card that is AFAICS properly inserted (on the back side of the nano SIM card in the same tray, with the angle aligned and the writing thus invisible) is never detected by the phone at all. Also neither the menu nor the quickstart guide nor the manual contains any hints as to how to check for it.
PS my phone is a dual SIM, but that shouldn't AFAICS prevent the second slot from being used for an NM card rather than a 2nd SIM. The 2nd SIM slot was intended for use during stays in China when I have a local SIM card.
Bought a Huawei 128g NM card. Put it in my phone and nothing. Nada. Phone doesn't see it.

Help please!
Userlevel 6
Badge +4
@judeep - I moved your post here. Please DM @BarneyT with the details he requests and a short overview of the issue. Thanks.

Hey @Dagoof, welcome to the community!

Thank you for your feedback!

Could you please provide me your name, phone number, e-mail address, the serial number and the build number of your device in Private Message?

I'm looking forward to your message! Please don't hesitate to contact us if you have any kind of problems in the future.

All the best,
BarneyT
@Danjl thanks. Pm'd @BarneyT yesterday 👍
I put a 128g sandisc in my m5 tablet. Worked great for months now suddenly stopped.. Look on settings and storage and memory tab is now called storage cleaner.. Still saying default storage setting is memory card. Bought a new card 64g and it's still the same. Go to app settings and no options to change from using internal to external storage. Wondering if the recent android update has anything to do with it?
Userlevel 6
Badge +4
@Lornaw3 - please provide BarneyT with the following information so he can raise with the development team.

Hey @Dagoof, welcome to the community!

Thank you for your feedback!

Could you please provide me your name, phone number, e-mail address, the serial number and the build number of your device in Private Message?

I'm looking forward to your message! Please don't hesitate to contact us if you have any kind of problems in the future.

All the best,
BarneyT

Reply