Answered

P30 Pro Bluetooth Volume Too Low


Userlevel 1
  • Fearless Explorer
  • 4 replies
Earphones Bluetooth Volume is too low, tried everything, also tried same earphones with other phone and were OK (volume was even too much), so definitely device/huawei problem. Checked forum and there should be same troubles with Mate 20 model and no solution? What is that, some new sound policy of top huawei models? Really do something about it, its destroying my customer experience with otherwise excellent phone... 😞
icon

Best answer by ClogPower 15 May 2019, 20:56

Hello @Anton
In developer mode you can check option for 'Bluetooth absolute volume'. See if that helps.

You can also try to use software to adjust volume;
https://play.google.com/store/apps/details?id=com.devdnua.equalizer.free
I used this on a different phone, haven't tried on P30 yet.

I hope above tips help
View original

13 replies

Userlevel 4
Badge +1
Hello @Anton
In developer mode you can check option for 'Bluetooth absolute volume'. See if that helps.

You can also try to use software to adjust volume;
https://play.google.com/store/apps/details?id=com.devdnua.equalizer.free
I used this on a different phone, haven't tried on P30 yet.

I hope above tips help
Userlevel 1
Hello @ClogPower,

problem solved in developer mode, earphones volume's great now, thank you very very much for advice! 🙂

Userlevel 4
Badge +1
@Anton great it solved the issue. Happy to help. Enjoy your phone 🙂
Userlevel 1
@Anton thanks, fixed it for me too
My phone sound, input + output, is far too low, when I use it via pairing with my car radio system, to make & receive calls
have tried amending car audio settings to max, still far from ideal, my prior HTC handset was great, as is I just can't use the P30, far from ideal

many thanks in advance for any ideas
Userlevel 6
Badge +4
@Bojangles , I moved your post here as this topic relates to low volume with bluetooth. Hopefully the answer will help:

Hello @Anton
In developer mode you can check option for 'Bluetooth absolute volume'. See if that helps.

You can also try to use software to adjust volume;
https://play.google.com/store/apps/details?id=com.devdnua.equalizer.free
I used this on a different phone, haven't tried on P30 yet.

I hope above tips help
I don't have that option. What else can I do to solve this issue. It's really annoying.

Userlevel 6
Badge +4
@Nayblinny365 - hmm strange - it looks in the screenshot from @Anton that the option is further down the screen, but you don't have the option. Sorry that didn't help. Hopefully someone else from the community can help out.
Firmware 9.1.0.178
Volume settings in developer options changed to recommend in other questions like this

Volume quite low, comparing to when headphones where connected to my previous phone.
Doesn't change anything if I try to configure equilizer.
All of my other phones just show a warning that it's not recommended to turn the volume so loud, this one has no warning that I could bypass even with developer options.

If I turn off noise cancelation on headphones I can hear everything trough - and I mean everything - quite annoying when traveling when you can hear the car trough and everyone talking. With noise cancelation at least only if someone talks loudly I can hear which still defeats the purpose of headphones (which I've had for more than 6 months and are supposed to be quite loud even when connected to phone, not only computer) .

In addition it seems that on Bluetooth headphones the bass is lower than it should be. I'm quite afraid what will be with Bluetooth speakers.

It would be nice to be able to sleep when on road and not bother with bringing 2 phones because of software issue.

How can I get the volume on this phone to the one I paid for when bought quality Bluetooth headphones and upgrading to premium priced phone?
Userlevel 7
Badge +11
Hey @Fallen,

I moved your post here to avoid double threads.
Hi

I did turn on the "bluetooth absolute volume" but I see no difference when the BT headphones are connected , it is still pretty low.

Should I do something more?

Thanks
Having the same issue as @Nayblinny365 on P30 lite

Hi, I ve a similar problem with my p30 pro. Today I paired my Cardo headset with Bluetooth and there the output volume is much much to low. With my old smartphone it was no problem.
I already was in the developer and activated the option "maximum volume for Bluetooth" but with no difference.

I hope there is anybody who has an idea, because I need this for navigation and communication on my next tour in a few days

Reply