Question

P30 Pro headphone jack not responsive

  • 5 August 2019
  • 5 replies
  • 2260 views

So during calls, listening to music, using axillary in the car the sound will cut out whatever device its using be that headphones or through the car speakers and starts to play through the phone speaker. Now during a call this is annoying, not sitting in a busy office listening to your music and suddenly it starts belting out your phone is quite professionally embarrassing. I have had this phone 2 to 3 months tops. Why is it doing this. I have wiped cache partition, cleaned the jack, tried different USB c headphones. By the way that was a stupid move not putting a 3.5mm jack on your top spec phone.

5 replies

Userlevel 3
Badge +2
Hello @DazzyG1989, welcome to the community!

We appreciate the customer's input and are very thankful that you took the time to write these suggestions regarding the jack input.

Your requests have been passed on to the development team and we can assure you that they will be taken into account for future updates & development.

Thank you for your feedback!

Please don't hesitate to contact me if you have further issues! You can send a private message as well, if you want this kind of assistance!

Have a lovely day!

All the best,
BarneyT
Hi I also have a similar problem where by when I insert my earphones the phone doesn't recognise I have inserted them or it does and and then cuts off and won't work again. The earphones are fine as they work on other devices.
Hi, I have a similar issue, while listening to my music through the headset it just keeps cutting out and stops playing?
I have the exact same issue from one day to another my headset stop being detected by my p30 pro. Any solution??

Same problem over here. I recently bought my p30 pro and my headphones were working at the very beginnig.. it also had an update the very same day I put the heaphones on the phone. Since then, I’ve taken a bluetooth headphones. I wanted to check the difference between bluetooth and USB C headphones and they are no more recognized.

I tried to wipe the phone...nothing happened. I hope the new EMUI will solve the problem. 

Reply