Question

P30 Pro - Keep WiFi connection but use Carrier's data for internet


Hello Huawei community, I have a P30 Pro that I connect to my car through wifi to stream music. The car does not have internet so I know why I am not getting any internet through the wifi. However, the phone still wants to use this wifi connection for the internet. How to I get the phone to use my carrier's network for internet instead of the wifi connection but keep the wifi connection so I can still stream music?

15 replies

Userlevel 4
Badge +1
Hello @Brian1969 you can configure the type of network applications can use.

Go to 'Settings', 'Wireless & Networks', 'Data Usage', 'Network Access'. Ensure 'Network Access' is selected at the top of the page.
This will bring up a list of installed applications and a tick box for the type of network it is allowed to use.

I hope this helps with your issue
Thank you for your response @ClogPower however, I have been to that screen and the problem is that the browsers are not listed as an "Installed App" but as a "System App." In the Installed App list it gives you the checkboxes for "Mobile Data" and "Wi-Fi." However, under the "System Apps" there is only one checkbox for "Mobile Data" and it is already ticked on for Chrome and the Huawei browser yet both still try to use the wifi connection to reach the internet instead of the mobile network.
Userlevel 4
Badge +1
@Brian1969 I use Brave browser (Chrome engine) and the network settings work. Give that a try and see if it's OK for you as well
Userlevel 7
Badge +6
Hey @Brian1969 , welcome back!

Have you tried @ClogPower's solution?

Please let us know if that helped!

Cheers
Would this work for a printer..?

i wish to connect to my printer via the phones wifi option, however i'd also still like to have 4g access to the internet so i can download courier labels from ebay then print directly to my printer.

My printer is a canon mg3600 series that does have canon print.
Userlevel 4
Badge +1
@aj2703 I think it would work if you install a browser such as Brave, Opera or Firefox and configure the phone to use 4G as suggested in my earlier message.
Probably this is a bug but even if I turn off the wifi+ my phone still uses my mobile data when my home internet connection is down while i am still connected to my wifi access point.

Another thing is that even if i turn off mobile data... Its not actually turned off and the phone still connects to the internet.

I am on the latest emui... Anyone else experiencing this?
Userlevel 7
Badge +11
Hi @Dannykay,

Welcome on the community. I moved your question to this thread. Please read the comments and let us know if you need help.
@Amy No this does not solve the problem!!! when my wi-fi is on, under no circumstace I want the phone to use mobile data to connect to the internet, even if the wi-fi has bad or no internet connection. This is how it has been forever implemented in phones. For my purposes, it has nothing to do with a specific application as it is for this thread.
Wi-fi+ is supposed to resolve this issue but apparently in the case of p30 pro is not.

Danny
Hi everyone.
Not sure if someone found the solution for this problem yet.
I bought my P30 lite while on a trip in S. Africa. I had no issues using it there over the Vodacom network. No issues connecting to any wifi without problems and without "leaking" data over the mobile network. Then I returned home (Canada) and started using the phone with my existing mobile network provider. After a couple of days, I noticed that my mobile data was being drained even though I was connected 95% of this time to wifi. I started to keep an eye on the usage and to make things easier to track, I turned on *Display Network Speed*. Basically that little icon lets me see when the internet is active and at what speed. That includes uploads and downloads.
Well, every time I was opening an app, my mobile data was being accessed too, although I was still connected to a strong wifi signal. Rebooted the phone a number of times but that only seemed to work temporarily. What to do?
The last thing I wanted to do is to *Factory Reset* the phone. That prompted me to investigate a little more *Connections, Network, WiFi*... and that is how I go to *Reset Network Settings*. That can be found in Settings > System > Reset. So I tried that... and now its been over 2 days and when I pick up a wifi connection, the mobile data is disengaged, as it should be everytime the phone is connected to wifi.
Well, I hope this may help others.

Good Luck
Userlevel 4
Badge +1
@Dannykay have you tried resetting the network settings? This has helped others in the past (such as @LesDrive on this thread).
yes tried all kind of pain in the arm resets. I am sure this is a bug. Make sure you are connected to your wifi access point at home, then go to your internet router and unplug your dsl/cable/whatever connects your modem/router to the ISP. now you are connected to a wifi that has no Internet connectivity and you get an exclamation point near the wifi icon on the top left. HOWEVER, you will still access the Internet as if nothing happened via your mobile data. This behavior is called WIFI+ and if you turn that setting off, the phone should not use mobile data if you have an active wifi connection even if it has no access to the Internet. So I guess that WIFI+ toggle on/off is not really working and it is ON all the time.
Userlevel 4
Badge
We are sorry, unfortunately the community do not seem to have an answer for your query. We'd suggest you reach out to our official support channels here https://consumer.huawei.com/uk/support/
Userlevel 6
Badge +7
yes tried all kind of pain in the arm resets. I am sure this is a bug. Make sure you are connected to your wifi access point at home, then go to your internet router and unplug your dsl/cable/whatever connects your modem/router to the ISP. now you are connected to a wifi that has no Internet connectivity and you get an exclamation point near the wifi icon on the top left. HOWEVER, you will still access the Internet as if nothing happened via your mobile data. This behavior is called WIFI+ and if you turn that setting off, the phone should not use mobile data if you have an active wifi connection even if it has no access to the Internet. So I guess that WIFI+ toggle on/off is not really working and it is ON all the time.
Your miss understanding the function of WiFi+ , it's to switch quicky and seamlessly between whichever data signal is the fastest and best quality effectively bridging the two sources and using whichever is best. Switching it off does not disable mobile data, your phone will just use one or the other, whatever data signal is available, if it sees there's no data via WiFi it switches to mobile. Hope that makes sense.
Regards Jase
I have a thread with a similar issue. Here is an example of the issue I'm experiencing https://youtu.be/rXMe8vkl0Yk
You'll notice that the app that I set to not work over Cell Data fails as soon as I turn on the cell data and reconnects right away when I turn off cell data ... and this happens while standing right under my access point.

I hope this helps others explain what they're experiencing.

Reply