Answered

P30 Pro not honouring silent mode or do not disturb mode



Show first post

38 replies

Also no cards anymore among other things. I personally like getting them, so this "fix" isn't gonna work for me. What I wish for is Huawei to acknowledge this issue, at the very least.
At least for me the EMUI 9.0.0.223 update fixed the bug, hope you guys aren't suffering anymore either.
Facing same sound issues on my P20. Whatever I tried (DND / reboot / volume slider) did not solve the problem. Pretty useless phone this way, when in a meeting I just turn off my phone which is not really comfortable.

Huawei / Android: please fix!
Copied from Reddit.com and WORKING fix for me! (I now remember I recently allowed google to send voice messages to my Sony WH1000 headset!):

Turn off "notification access" of "Google" (Apps & notifications > special app access, or via search)
Of course you do not get notifications via your Bluetooth headset now. But it is much better than being awakened at 4am by some weird email (happened to me twice)
I suspect that the recent "Google" app update (on May 30, which matches when these posts begin to pop up here) messed up the whole thing
EDIT: fixed my crappy word choice, be more accurate about some details
Userlevel 6
Badge +4
@Nielsert , glad you've found a work around solution. Thanks for sharing this.
This was my issue and fix, post here

Hello everyone. Someone else mentioned Sony headphones, so I started doing some testing. So after a fresh reboot, my phone is fine. Notifications and vibrate and silent mode work fine. However, I have the Sony WF1000X, and as soon as I connect them, it causes the problem as many mentioned above.

After using my headphones, on normal notification mode, there is a double notification tone. On vibrate or silent, there is a single notification tone. Reboot the phone, back to normal.

I've tried with other Bluetooth headphones, and it is fine. I've tried with the Sony Headphones app un-installed, and re-pairing the headphones, the issue still comes up.

However this does seem to be a new issue, and I see the Sony Headphones app was just updated recently, so I think that app has caused something.

So I think I'll stop using these headphones for a bit (I don't really like them anyway).

Best of luck.
Copied from Reddit.com and WORKING fix for me! (I now remember I recently allowed google to send voice messages to my Sony WH1000 headset!):

Turn off "notification access" of "Google" (Apps & notifications > special app access, or via search)
Of course you do not get notifications via your Bluetooth headset now. But it is much better than being awakened at 4am by some weird email (happened to me twice)
I suspect that the recent "Google" app update (on May 30, which matches when these posts begin to pop up here) messed up the whole thing
EDIT: fixed my crappy word choice, be more accurate about some details


Where do you find this "notification access"? I've turned off all notifications for Google app and it's still coming up

Copied from Reddit.com and WORKING fix for me! (I now remember I recently allowed google to send voice messages to my Sony WH1000 headset!):

Turn off "notification access" of "Google" (Apps & notifications > special app access, or via search)
Of course you do not get notifications via your Bluetooth headset now. But it is much better than being awakened at 4am by some weird email (happened to me twice)
I suspect that the recent "Google" app update (on May 30, which matches when these posts begin to pop up here) messed up the whole thing
EDIT: fixed my crappy word choice, be more accurate about some details
Where do you find this "notification access"? I've turned off all notifications for Google app and it's still coming up

Hi, just search for 'special access' in settings and look for something like notification access. I have Dutch language selected, please see screenshot. This workaround is now in place for 2 days and it still works, even when connecting and disconnecting my Sony headphones. Good thing is I was already looking for ways to mute the assistent, because erverytine I received an app, it would propose to read it out loud, brutely interrupting music I was listening to. That is now also solved!

Userlevel 1
At least for me the EMUI 9.0.0.223 update fixed the bug, hope you guys aren't suffering anymore either.
That update is not available for me. I'm at 9.1.0.153, and it says I'm "up-to-date". Was that a typo or are you really on 9.0 rather than 9.1?
Wanted to share, I spoke to support like the Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

Try First: Clean your cache

  1. To wipe the cache of the device , you simply have to power off the device in question.
  2. Once it is off please press and hold the Volume Up Key and the Power Button for about 30 seconds.
  3. The device will then boot into a new menu with only 3 visible options. The first option from the top is the one that we are looking for in this list.
  4. Once the process has ended the device will come back to this menu.
  5. In order to leave the menu simply tap Reboot System Now ( the last option on the bottom of the list )
No luck: Hard reset your phone (I luckily didn't have to do this)
  1. If this will not help then we recommend a factory reset. This will erase all data on the internal storage and will turn the device back to its factory settings.
  2. Therefore, before doing this, make sure that you back up all of your files and data (documents, photos, videos, contacts, notes, media files etc.) on the SD card (in Settings > Advanced settings > Backup & reset, or via the Backup App), on the PC (using HiSuite), or on the Google account, and that you know the Google account and password with which you have previously signed in or remove it in Settings > Accounts > select the account > Remove.
Hope that helps someone.
Userlevel 1
Wanted to share, I spoke to support like the Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

This is just their scripted standard answer to everything when they don't know what the actual cause is. Useless first line helpdesk stuff, it does nothing when the problem is an actual bug, like in this case.
For everyone still facing this problem, since none of the solutions suggested above worked for me, I've found a different temporary fix that made silent mode actually silent again, and it's really simple:

Go to:
Settings > Sound > Default volume button control
Select "Ringtone volume".

Hope this helps some of you!
For everyone still facing this problem, since none of the solutions suggested above worked for me, I've found a different temporary fix that made silent mode actually silent again, and it's really simple:

Go to:
Settings > Sound > Default volume button control
Select "Ringtone volume".

Hope this helps some of you!

I got no idea how this actually works but it does for me as well. Nothing of the previous work arounds does but this is legit. Thanks a bunch for sharing.

Reply