Answered

P30 Pro not honouring silent mode or do not disturb mode


Userlevel 1
My P30 Pro has suddenly, since a few days, started loudly playing sound for all notifications, even if it is in "silent", "vibrate" or "do not disturb" mode! It evens seems that it plays sounds for all incoming notifications at once if there are multiple, through one another, adding to the din. As you can imagine this is extremely irritating.

How can I resolve this problem?

The phone is fully up to date and has had nothing out of the ordinary installed on it. A reboot does not help. This is the default "bongo" notification sound and it plays for all notifications, it has nothing to do with one particular app.
icon

Best answer by teunvw 14 June 2019, 15:36

For everyone still facing this problem, since none of the solutions suggested above worked for me, I've found a different temporary fix that made silent mode actually silent again, and it's really simple:

Go to:
Settings > Sound > Default volume button control
Select "Ringtone volume".

Hope this helps some of you!
View original

38 replies

For everyone still facing this problem, since none of the solutions suggested above worked for me, I've found a different temporary fix that made silent mode actually silent again, and it's really simple:

Go to:
Settings > Sound > Default volume button control
Select "Ringtone volume".

Hope this helps some of you!

I got no idea how this actually works but it does for me as well. Nothing of the previous work arounds does but this is legit. Thanks a bunch for sharing.
For everyone still facing this problem, since none of the solutions suggested above worked for me, I've found a different temporary fix that made silent mode actually silent again, and it's really simple:

Go to:
Settings > Sound > Default volume button control
Select "Ringtone volume".

Hope this helps some of you!
Userlevel 1
Wanted to share, I spoke to support like the Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

This is just their scripted standard answer to everything when they don't know what the actual cause is. Useless first line helpdesk stuff, it does nothing when the problem is an actual bug, like in this case.
Wanted to share, I spoke to support like the Question "answer" said to do, they told me this, and it doesn't appear to be in the answers:

Try First: Clean your cache

  1. To wipe the cache of the device , you simply have to power off the device in question.
  2. Once it is off please press and hold the Volume Up Key and the Power Button for about 30 seconds.
  3. The device will then boot into a new menu with only 3 visible options. The first option from the top is the one that we are looking for in this list.
  4. Once the process has ended the device will come back to this menu.
  5. In order to leave the menu simply tap Reboot System Now ( the last option on the bottom of the list )
No luck: Hard reset your phone (I luckily didn't have to do this)
  1. If this will not help then we recommend a factory reset. This will erase all data on the internal storage and will turn the device back to its factory settings.
  2. Therefore, before doing this, make sure that you back up all of your files and data (documents, photos, videos, contacts, notes, media files etc.) on the SD card (in Settings > Advanced settings > Backup & reset, or via the Backup App), on the PC (using HiSuite), or on the Google account, and that you know the Google account and password with which you have previously signed in or remove it in Settings > Accounts > select the account > Remove.
Hope that helps someone.
Userlevel 1
At least for me the EMUI 9.0.0.223 update fixed the bug, hope you guys aren't suffering anymore either.
That update is not available for me. I'm at 9.1.0.153, and it says I'm "up-to-date". Was that a typo or are you really on 9.0 rather than 9.1?

Copied from Reddit.com and WORKING fix for me! (I now remember I recently allowed google to send voice messages to my Sony WH1000 headset!):

Turn off "notification access" of "Google" (Apps & notifications > special app access, or via search)
Of course you do not get notifications via your Bluetooth headset now. But it is much better than being awakened at 4am by some weird email (happened to me twice)
I suspect that the recent "Google" app update (on May 30, which matches when these posts begin to pop up here) messed up the whole thing
EDIT: fixed my crappy word choice, be more accurate about some details
Where do you find this "notification access"? I've turned off all notifications for Google app and it's still coming up

Hi, just search for 'special access' in settings and look for something like notification access. I have Dutch language selected, please see screenshot. This workaround is now in place for 2 days and it still works, even when connecting and disconnecting my Sony headphones. Good thing is I was already looking for ways to mute the assistent, because erverytine I received an app, it would propose to read it out loud, brutely interrupting music I was listening to. That is now also solved!

Copied from Reddit.com and WORKING fix for me! (I now remember I recently allowed google to send voice messages to my Sony WH1000 headset!):

Turn off "notification access" of "Google" (Apps & notifications > special app access, or via search)
Of course you do not get notifications via your Bluetooth headset now. But it is much better than being awakened at 4am by some weird email (happened to me twice)
I suspect that the recent "Google" app update (on May 30, which matches when these posts begin to pop up here) messed up the whole thing
EDIT: fixed my crappy word choice, be more accurate about some details


Where do you find this "notification access"? I've turned off all notifications for Google app and it's still coming up
This was my issue and fix, post here

Hello everyone. Someone else mentioned Sony headphones, so I started doing some testing. So after a fresh reboot, my phone is fine. Notifications and vibrate and silent mode work fine. However, I have the Sony WF1000X, and as soon as I connect them, it causes the problem as many mentioned above.

After using my headphones, on normal notification mode, there is a double notification tone. On vibrate or silent, there is a single notification tone. Reboot the phone, back to normal.

I've tried with other Bluetooth headphones, and it is fine. I've tried with the Sony Headphones app un-installed, and re-pairing the headphones, the issue still comes up.

However this does seem to be a new issue, and I see the Sony Headphones app was just updated recently, so I think that app has caused something.

So I think I'll stop using these headphones for a bit (I don't really like them anyway).

Best of luck.
Userlevel 6
Badge +4
@Nielsert , glad you've found a work around solution. Thanks for sharing this.
Copied from Reddit.com and WORKING fix for me! (I now remember I recently allowed google to send voice messages to my Sony WH1000 headset!):

Turn off "notification access" of "Google" (Apps & notifications > special app access, or via search)
Of course you do not get notifications via your Bluetooth headset now. But it is much better than being awakened at 4am by some weird email (happened to me twice)
I suspect that the recent "Google" app update (on May 30, which matches when these posts begin to pop up here) messed up the whole thing
EDIT: fixed my crappy word choice, be more accurate about some details
Facing same sound issues on my P20. Whatever I tried (DND / reboot / volume slider) did not solve the problem. Pretty useless phone this way, when in a meeting I just turn off my phone which is not really comfortable.

Huawei / Android: please fix!
At least for me the EMUI 9.0.0.223 update fixed the bug, hope you guys aren't suffering anymore either.
Also no cards anymore among other things. I personally like getting them, so this "fix" isn't gonna work for me. What I wish for is Huawei to acknowledge this issue, at the very least.
For a temporary workaround you can disable the "Google" app in the settings (Apps/Apps/Google).

While this is disabled you won't be able to use the assistant.

Edit: as mentioned below it might affect a few other things as well, didn't notice because I don't use them
Userlevel 1
And an update: it's back :/

Did you connect a Bluetooth device around the time it came back?
Userlevel 1
Has anyone had any luck with a factory reset?

Probably won't work. I did a normal reset, and it fixed the problem for a short while but it soon returned. But see my previous answer for news.
Userlevel 1
I have news! Apparently this is an Android bug, and it's affecting many people (including Pixel phone users, which is pure Android).

Reddit post: https://www.reddit.com/r/GooglePixel/comments/buqmtg/notificationringermedia_volume_bug/
Bug report in Google's issue tracker: https://issuetracker.google.com/issues/134214639

The media and ringer volumes have somehow got linked, causing notifications to be played at the volume of the media volume. If you lower the media volume, you can silence the phone. It's also somehow linked to Bluetooth. Clearing all settings or resetting the phone makes the problem go away, but when you connect a Bluetooth device again it will recur.

I hope Google will fix this quickly. I also hope that Huawei phones will actually get the fix. If not, it's back to the store for mine, 'cause this is not usable.
And an update: it's back 😕
UPDATE: strangely enough, the issue seems to be gone on my phone. Notifications are back to normal. I've done NOTHING special in order to fix it, so sadly no useful info for you guys.
Has anyone had any luck with a factory reset? I don't want to go through the effort of doing one to find the issue is still there.

As a temporary fix, I've managed to stop the notification sounds by activating do not disturb mode and turning the media volume down to zero. Obviously this isn't helpful if you want to listen to music, but it does mean you can leave your phone when in meetings etc.
I have the exact same issue!!! It's so infuriating. Updating the software fixed it for a day but now it's back. Please please please fix this bug Huawei!!!!!!
Userlevel 1
Thanks @Amy It seems pretty clear that this has nothing to do with do not disturb settings, since it also happens when the phone is in silent or vibrate mode. I've also tried those official support channels, but I had hoped Huawei would show a little more interest in a major bug in their thousand dollar smartphone...
Userlevel 7
Badge +11
Hi all,

I unmarked @mamu178's comment as the best answer.

Back to the issue:
there is a variety of settings around DND. First and foremost head to Settings> Sounds >Do Not Disturb. Ensure it is turned on, not scheduled, ensure settings for calls and messages are correct. Secondly head to Settings> Apps> Apps>(chose an app)> Notifications and ensure "allow interruptions" is not selected.

If all of that still fails then you may have a bug or a badly coded third party app. Please contact our official channels for more info: https://consumer.huawei.com/uk/support/
Userlevel 1
Its been a couple of days and customer service have done nothing, absolutely unacceptable.
Sorry @mamu178 , I accidentally marked your comment as the answer (just takes one wrong mouse click, and this stupid forum software does not ask for confirmation or allow you to undo it).
Reckon it's a sunking ship and we are one of the few survivors still on it. Time to jump ship.

Reply