Answered

P30 Pro won't connect to my home WiFi.

  • 8 April 2019
  • 26 replies
  • 20013 views

  • Fearless Explorer
  • 8 replies
Hi,
I did see a post on here the other day about this that I now cant find! My phone is finding my WiFi and says signal is excellent but when I try to connect it says (no internet connection) all my other devices connect fine but not my P30. Please help, its driving me mad. I have reset my router and phone, I have tried all the basics with no success 😒
icon

Best answer by Tony D 9 May 2019, 19:53

I found this posted elsewhere and it worked a treat for me as a BT user

1. Open a Web Browser Window.
2. Type the BT HUB 5 router homepage address (192.168.1.254).
3. Type in the Admin password
4. Click on Advanced Settings
5. Click on Home Network
6. Look for the Enable Smart Setup Wizard tab
7. It's likely to be already enabled (i.e. Yes is ON). If it is, click on the No button and select Apply. This switches OFF the Smart Setup Wizard
8. Switch off your phone's Wi-Fi. Wait for a few seconds. Switch it back on.
9. Search for your BT HUB 5 and reconnect.
10. You should find your P30 works perfectly with the Wi-FI (whether it's the 2.4Ghz or 5GHz channel).
View original

26 replies

Userlevel 6
Badge +7
Can you actually connect to the internet, or is it not connecting at all?

Regards Jase
Hi Jase,
Thanks for your response.
It says "connected (no internet access)
All other devices connected fine and working OK.
Userlevel 6
Badge +7
Have you tried connecting using the WPS button on your router Instead of typing in the password manually?
Just tried that following your message. Still no joy πŸ€”
Userlevel 6
Badge +7
Just tried that following your message. Still no joy πŸ€”
Super strange as it's obviously connected to the router but has no internet accessπŸ€”. Which router do you have and which internet company are you with? I Wonder if there's some setting needing changed on the router rather than the phone

Regards Jase
BT infinity we use. It is very odd. Never had trouble with it before! I've tried searching the IP address to check parental settings which was solution I saw in here the other day but the search doesn't work as no internet connection! Very fristrating. Been trying to sort since Saturday.
I am also a Bt broadband user and having the exact same issues. Really frustrating!
Userlevel 6
Badge +7
Sometimes it can be an app on your phone causing conflicts when trying to connect to the internet, easiest way to check that is to start up your phone in safe mode and then try to connect to the internet, if it works fine then you've got some app causing the trouble, then it's a process of elimination to find which one it is.
I will give that a try thank you. How do i start up in safe mode (save me googleing)
Userlevel 6
Badge +7
I think it's the same as mate 20 pro which is

  1. Power off the phone by holding down the power button for a few seconds.
  2. Now Just Press and hold the power button and release it when you see the Huawei on screen.
  3. After releasing the Power key, immediately press and hold the Volume down key.
Userlevel 6
Badge +7
Also if you are connected to the router can you check that your device hasn't been restricted for any reason by accessing these settings via your phone

http://bt.custhelp.com/app/answers/detail/a_id/11372/~/how-do-i-use-bt-access-controls%3F

Edit , just check your phones IP address isn't restricted
I messaged BT chat using your link and they responded and sorted my problem within 5 minutes so all sorted. Thank you for your time and help Jase. Much appreciated.
Userlevel 6
Badge +7
Your very welcome, glad it's all fixed so you can enjoy your new phone 😁
Hi I'm having this exact same issue. New p30 pro and anytime I connect to the WiFi it slows everything making everything run extremely slowly. If I want to use my phone I need to use my data which isn't ideal. I'm with EE and already called them and narrowed the issue to my p30 pro which is hogging all my internet basically.
What can I do to fix this? Or I'll need to sell the phone and go back to my old one.
hi, i have problem with home wifi connection, after i completing key in wifi password, the 'connect' button turn grey and unable to proceed further. kindly help.
Userlevel 4
Badge +4

hi, i have problem with home wifi connection, after i completing key in wifi password, the 'connect' button turn grey and unable to proceed further. kindly help.


have you tried to connect with WPS instead of typing password? check tutorial here: https://www.youtube.com/watch?v=av9gZVMpYvA
Really odd. Can't connect to WiFi with my new p30 Pro.just wondering if anyone can help.
It shows up on the phone. Put WiFi password in then it just tells me I can't connect. Judging by what I'm seeing on this forum it looks like a really common issue. I wonder if Huawei will be upgrading software to rectify this issue. In the meantime does anyone have any ideas?
My P30 Pro kept using my mobile data even I am connected to WiFi. Later I found out there is a feature called WiFi+ where it will use mobile data when WiFi connection is not good. This option was enabled by default. So I switch it off.
But even I switched off WiFi+ option, my phone still using mobile data when both WiFi and Mobile data are enabled and WiFi is connected. This drained by mobile data quota.
My previous Samsung phone had similar WiFi+ feature called "auto network switch". When this feature is disabled, when phone connected to WiFi, phone will not use mobile data, even if WiFi connection is unstable or WiFi network do not have internet access.
I expect it will behave the same when WiFi+ is disabled on Huawei phone. But it's not. It is still using mobile data when WiFi is connected. Seem like regardless if WiFi+ is enabled or disabled, it will always use mobile data even if WiFi is connected. It seem like a software bug to me.

Anyone having the same issue? And someone help to check if he/she is able to reproduce this issue on P30 Pro?
I am using EMUI version 9.1.0.140
Userlevel 4
Badge +4
My P30 Pro kept using my mobile data even I am connected to WiFi. Later I found out there is a feature called WiFi+ where it will use mobile data when WiFi connection is not good. This option was enabled by default. So I switch it off.
But even I switched off WiFi+ option, my phone still using mobile data when both WiFi and Mobile data are enabled and WiFi is connected. This drained by mobile data quota.
My previous Samsung phone had similar WiFi+ feature called "auto network switch". When this feature is disabled, when phone connected to WiFi, phone will not use mobile data, even if WiFi connection is unstable or WiFi network do not have internet access.
I expect it will behave the same when WiFi+ is disabled on Huawei phone. But it's not. It is still using mobile data when WiFi is connected. Seem like regardless if WiFi+ is enabled or disabled, it will always use mobile data even if WiFi is connected. It seem like a software bug to me.

Anyone having the same issue? And someone help to check if he/she is able to reproduce this issue on P30 Pro?
I am using EMUI version 9.1.0.140

switch off the wifi+ option and restart your phone. it will not use mobile data anymore.
I found this posted elsewhere and it worked a treat for me as a BT user

1. Open a Web Browser Window.
2. Type the BT HUB 5 router homepage address (192.168.1.254).
3. Type in the Admin password
4. Click on Advanced Settings
5. Click on Home Network
6. Look for the Enable Smart Setup Wizard tab
7. It's likely to be already enabled (i.e. Yes is ON). If it is, click on the No button and select Apply. This switches OFF the Smart Setup Wizard
8. Switch off your phone's Wi-Fi. Wait for a few seconds. Switch it back on.
9. Search for your BT HUB 5 and reconnect.
10. You should find your P30 works perfectly with the Wi-FI (whether it's the 2.4Ghz or 5GHz channel).
I'm having a similar problem but I'm using virgin media as my provider. My phone will connect but a few times a night its like it forgets it's connected even tho the phone says I am. I have to turn connection off and back on again on my phone then it'll work again. Anyone help with this please?
I messaged BT chat using your link and they responded and sorted my problem within 5 minutes so all sorted. Thank you for your time and help Jase. Much appreciated.
How did BT resolve this? have spent the best part of the day trying to connect to the internet via my BT hub and they told me it was a phone issue?
Userlevel 4
Badge +4

I messaged BT chat using your link and they responded and sorted my problem within 5 minutes so all sorted. Thank you for your time and help Jase. Much appreciated.How did BT resolve this? have spent the best part of the day trying to connect to the internet via my BT hub and they told me it was a phone issue?


follow @Tony D guide on the post above, it will resolve your issue.
I had the problem of my phone not detecting my home wifi. Everybody else at home connected fine. Solved it my changing the broadcast channel setting on my router from "auto" (the default setting) to channel 1. Now it's working 100%.
I'm having the same issue but with virgin media.
Any fixes for non BT hub users?

Reply