Question

P30 wi-fi issue


Hi,

I have a problem when P30 connects to my home WIFI network. I have a 20mbit fiber and WIFI router that delivers signal to all home devices. As soon as P30 connects to a home network, browsing speed drops drastically for ALL devices currently in the network (including P30) and it becomes just impossible to use internet. As soon as P30 disconnects - everything works great. Also, if the P30 is the only device in the network, it works fine. I assume that it happens because P30 is overtaking all available bandwidth. Did anyone face such a problem? Is there any possibility to configure the device itself without changing the router configs?

26 replies

Userlevel 5
Badge +1
Hi @SergeLUX ,

Nobody wants wifi issues! Seems odd, but I'm not an expert, so I've raised this with the support team. Not sure @AlexL , but can you shed any light on the question of taking all the bandwidth? Suspect it's more likely a setting somewhere.
If you can, log into your router and have a look at what's happening when you notice the slow down.
Extremely disappointed have picked up new p30 phone today and cannot connect it to the internet. It will see the router but won't allow access to the internet. Have contacted yourselves and then was told to contact BT. Neither has been successful. Appears that this phone is not fit for use in its current state and will be taking it back to the shop tomorrow. All other devices are working including the P10 I am upgrading from. I hope others do not have the same problem
Hi sanders. Do you get an IP address on your phone?
yes we do have been through using IP address got one phone to work but having done exactly the same with the other p30 it still is not working. All settings on both phones are exactly the same
Sanders, I'd really recommend starting a new thread for this issue, as it's different to the original thread issue. Hopefully someone will be able to pick it up and take it to their support team.
I have just had an update come through for my p30 though. Perhaps you could give that a go before abandoning?
Userlevel 7
Badge +6
Hey all!

Thanks for taking your time reporting this to us!

We're sorry that you're experiencing this! It must be very disappointing.

Have you tried resetting the network settings from Settings > System > Reset > Network settings reset?

Let us know if that resulted in any changes!

Kind regards,
Max
My P30 suffers the same issue. I did the network reset as suggested above, but the problem persists.
Userlevel 3
Badge +1
yes we do have been through using IP address got one phone to work but having done exactly the same with the other p30 it still is not working. All settings on both phones are exactly the same

have you tried following this tutorial: https://uk.community.huawei.com/p30-series-30/p30-pro-and-bt-hub5-3921

@SergeLUX have you tried to separate enabling channels for the wifi (ie. 2.4GHZ and 5GHZ as separate channels) rather than simply one standard wi-fi when you connect and letting the router decide? give it a try and report back your findings.
Hi, is there a fix for the slow wifi? Just got my P30 yesterday but already considering sending back under my cooling off period. The Internet is slow on WiFi and it slows down all other devices too. Its actually not usable on my home WiFi. I have tried all the troubleshooting guides but it's still the same and it's infuriating
Userlevel 3
Badge +1
try connecting to wi-fi in airplane mode. it is likely connecting to 2.4ghz instead of 5ghz wifi
try connecting to wi-fi in airplane mode. it is likely connecting to 2.4ghz instead of 5ghz wifi
I'll monitor it over the next day or so. Appreciate the help. In simple as simple terms as possible, how do I check which ghz setting its connecting to?
Userlevel 3
Badge +1

try connecting to wi-fi in airplane mode. it is likely connecting to 2.4ghz instead of 5ghz wifiI'll monitor it over the next day or so. Appreciate the help. In simple as simple terms as possible, how do I check which ghz setting its connecting to?

when you admin login to your wi-fi router it usually details devices connected and the frequency (2.4 or 5). Some other routers assign the prefix 2.4ghz and 5ghz after the wi-fi name.
i believe the same information can be found under network settings on your phone too.


try connecting to wi-fi in airplane mode. it is likely connecting to 2.4ghz instead of 5ghz wifiI'll monitor it over the next day or so. Appreciate the help. In simple as simple terms as possible, how do I check which ghz setting its connecting to?
when you admin login to your wi-fi router it usually details devices connected and the frequency (2.4 or 5). Some other routers assign the prefix 2.4ghz and 5ghz after the wi-fi name.
i believe the same information can be found under network settings on your phone too.

Really helpful. Appreciate that. Thank you
Userlevel 4
Badge +1
@Matty8114 you can check the frequency the phone connected to under Settings, Wirelessl & Networks, WiFi. If you select the network here, you can check the frequency.
@Matty8114 you can check the frequency the phone connected to under Settings, Wirelessl & Networks, WiFi. If you select the network here, you can check the frequency.
I changed the WiFi router from 5ghz to 2.4ghz last night. It seems slightly better today but still at times the phone takes an age to load a video and simply won't play it on WiFi. Won't even load a Web page, just times out and eventually says Web page unavailable. It's not as bad as it was but I think I'll still swap it for a different handset. I do like the phone though. Also that you can't connect to a bt router without changing settings is annoying.
Userlevel 4
Badge +1
@Matty8114 I have a BT router and P30, am not experiencing any issues. I've split out the 2 and 5 GHz bands. My phone connected on the 5 GHz.
Usually 2GhZ has better reach but 5 GHz has more bandwidth.
Which internet provider do you use?
@Matty8114 I have a BT router and P30, am not experiencing any issues. I've split out the 2 and 5 GHz bands. My phone connected on the 5 GHz.
Usually 2GhZ has better reach but 5 GHz has more bandwidth.
Which internet provider do you use?

Think I should try connecting it through just 5ghz rather that 2.4? It was on auto before.. I was at my sister in laws yesterday and the bt router wouldn't accept the password. So I googled it and seen a few people having the same issues. I personally have a sky router. I get 10mbps which is the best in my area, but my galaxy s8 worked perfect on the WiFi. As does every other electrical component. It's just so slow it's becoming unusable
Userlevel 3
Badge +1

@Matty8114 I have a BT router and P30, am not experiencing any issues. I've split out the 2 and 5 GHz bands. My phone connected on the 5 GHz.
Usually 2GhZ has better reach but 5 GHz has more bandwidth.
Which internet provider do you use?
Think I should try connecting it through just 5ghz rather that 2.4? It was on auto before.. I was at my sister in laws yesterday and the bt router wouldn't accept the password. So I googled it and seen a few people having the same issues. I personally have a sky router. I get 10mbps which is the best in my area, but my galaxy s8 worked perfect on the WiFi. As does every other electrical component. It's just so slow it's becoming unusable


try one more thing:
have you tried to connect using WPS? On your router click the WPS button. On your phone go to wifi > advanced settings > there should be a WPS option. Click there and it should connect automatically without using any password.
Userlevel 4
Badge +1
@Matty8114 , BT routers have a page that's loaded the first time you connect (unless disabled on the router) and some phones don't work well with this. Unfortunately the P30 is one of these phones. There are a few articles on this site about this specific issue.

I don't have a Sky router, so not sure on what you can check. If you can, please check if one on the bands has a lot of devices, this can create contention. I'm not sure why this is an issue with the P30 and not your S8.

Perhaps a silly suggestion, but have you rebooted (power off/on) your router recently?
@Matty8114 , BT routers have a page that's loaded the first time you connect (unless disabled on the router) and some phones don't work well with this. Unfortunately the P30 is one of these phones. There are a few articles on this site about this specific issue.

I don't have a Sky router, so not sure on what you can check. If you can, please check if one on the bands has a lot of devices, this can create contention. I'm not sure why this is an issue with the P30 and not your S8.

Perhaps a silly suggestion, but have you rebooted (power off/on) your router recently?

I've powered it on/off a few times trying to get the problem sorted. It's definitely a strange one,but something I've seen a few people having a problem with when googling the issue. I'll have a play around over the next few days with the settings. Thank you for your help though 😊
Has anyone got any other suggestions? I've spoke to sky and EE. Sky say its my phone that's the problem, EE say its my Internet. The ping on my wifi is up to 1000ms which is ridiculous. I have literally no idea what to do now? The WiFi is so so poor for all devices now with the p30 connected
Userlevel 4
Badge +1
Hib@Matty8114 someone else on the forum had a similar issue which was resolved by turning off the cloud backup. Can you give this a try?
Userlevel 3
Badge +1
Hib@Matty8114 someone else on the forum had a similar issue which was resolved by turning off the cloud backup. Can you give this a try?

you beat me to it. was going to say the same. I was trying to find the thread but cannot seem to find.

The app can be found at settings > apps > cloud or cloud backup > click on the app then click disable.
You should see some improvement.

Hope this helps
Thanks again @drhouse and @ClogPower I will monitor that now. I think I've found the cause.. I turned each device off individually that is connected to the wifi, found that with one of my kids' tablets being turned off cures the problem. With everything disconnected apart from my phone and his tablet, the problem exists. Just need to figure out what on his tablet is causing it now. Im useless with this sort of thing. Is there an easy way to see what on his tablet is using most WiFi?

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings