Answered

P30 wifi problem - password / connect button grey

  • 23 April 2019
  • 9 replies
  • 4346 views

When i try to connect my house wifi, during key password, i haven't finish type my password, the connect button does not grey out but when i finish typed the correct password, "connect" button grey out. How to solve this problem?
icon

Best answer by drhouse 9 May 2019, 13:06

this issue can be solved by connecting via WPS, Click the WPS button on your Wifi router and on your phone do the following:
  • Go to the Start screen.
  • Choose Settings.
  • Scroll down.
  • Choose Wireless & networks.
  • Choose Wi-Fi.
  • Enable Wi-Fi.
  • Choose the options symbol (the three dots at the top right corner)
  • Choose Settings.
  • Choose WPS connection.
Hope this solves your problem!
View original

9 replies

Userlevel 4
Badge +1
@peiwen1121 the password needs to be a minimum of 8 characters after which you can connect to the access point. Are you using any non-ASCII characters? The maximum length is 63 characters assuming you are using WPA2-PSK
i am facing the same problem, my wifi password i just number with character, but when completing the password the 'connect' button turn grey and unable to press
Userlevel 7
Badge +6
Hey everyone!

Does that happen with all wifi networks?
This exact same thing happens to me with my P30 Pro

The connect button is greyed out

when I have entered 5 characters of the WiFi password the connect button becomes enabled, when I type the 6, 7, 8, 9th characters its disabled again

When I type the 10th character of the password it becomes enabled again

Sadly my WiFi password isnt 5 or 10 characters long its 12!!!

so as I type the 11th and 12th characters the connect button again is disabled

This is really annoying, I have many other android devices (Pixel, Pixel2, Pixel C and Samsung s10) which all can connect to the exact same WiFi

What is wrong with Huawei phones they cannot connect to a WiFi network?
I am having identical issue with my P20 Pro.

It will only allow me to attempt to connect to WiFi if my password is 5 characters long or 13 characters.

My password is definitely only 8 characters long. This is very frustrating.

Is this due to an update? Any solutions?
Userlevel 4
Badge +4
this issue can be solved by connecting via WPS, Click the WPS button on your Wifi router and on your phone do the following:
  • Go to the Start screen.
  • Choose Settings.
  • Scroll down.
  • Choose Wireless & networks.
  • Choose Wi-Fi.
  • Enable Wi-Fi.
  • Choose the options symbol (the three dots at the top right corner)
  • Choose Settings.
  • Choose WPS connection.
Hope this solves your problem!
@drhouse what if my Wifi router doesn't have a WPS button?

I have an old AirPort Extreme - there is no WPS button and the airport application on my mac doesn't support the old model anymore so I can't change the password. My password is only 7 characters. 😞

Does anyone have any suggestions to resolve this issue or do I have to buy a new router?

Thanks!
Hi
I followed above instructions and the solution does not work
Router is Netgear DGN2200 - it has a WPS button (icon looks different to your example)

WPS router button was already on & glowing green - did not show connect button on my phone so I pressed router wps button off/on again

This time my phone appeared to be trying to enable WPS connection (blue progress bar got to the end this time) then received a fail message - " failed to enable WPS, please try again in a few minutes "

I've tried this 3 times now & no joy

How else can I connect please ?
Userlevel 7
Badge +11
Hi all,

Sorry for the lack of replies in this thread! Are you still having these issues?

If so, please contact our support team directly, as the community do not seem to have an answer for your query: https://consumer.huawei.com/uk/support/

Reply