Question

Unable to disable to unlock sound for finger ID

  • 25 April 2019
  • 5 replies
  • 312 views

I am unable to disable the unlocking sound when I use finger print ID to unlock it. I have the latest firmware and have tried to disable the screen lock sound from the sound settings. Please assist.

5 replies

Userlevel 6
Badge +4
Hi @Akbar Sheikh

Sorry to hear you're having issues. I've flagged this for assistance from the support team, who hopefully can help you. This thread about a similar issue might also help.
Userlevel 1
Badge
Hello,

Sorry its not possible right now, you can wait to next update and maybe then will be option to turn it of.
Ot you can disable it by turning off nortifications sounds off

Best regards.
Userlevel 7
Badge +6
Hey @Akbar Sheikh, greetings!

Please try wiping the cache partition of your device in order to attempt troubleshooting the issue.

1. Turn the device off completely.
2. Press and hold the volume up + power key at the same time, until you get into the recovery menu.
3. Select "Wipe cache partition" (navigate by using the volume keys and power button to select).
4. Confirm the action by selecting "Wipe cache partition" again.
5. At the end of this process, the recovery menu appears for the second time - select "Reboot system now".


Note: Please make sure to select Wipe cache partition, and not Wipe data/factory reset - the latter will erase all data on the internal storage of the device.

Cheers
Hi @Max ,

Many thanks for providing your expert guidance.

I have tried the steps as advised but unfortunately nothing has change.

Any further advise would be appreciated.

Thanks,
Akbar Sheikh
Userlevel 4
Badge +4
just wondering if you have attempted this:
https://uk.community.huawei.com/p20-series-31/p20-turn-off-unlock-sound-1641#post11063

Hey,Go into SETTINGS > Sounds > More (down the bottom) > Select the screen lock and it will turn off this sound for both locking and unlocking.

Troubleshooting a little:
Also when you unlock it on silent mode and/or aeroplane mode, does it make any unlock noise? Try setting the above (disable unlock sounds in silent mode) and then restart your phone then revert back to sound and/or non-aeroplane mode. It might just work.

Also in this thread this user claims to have turn off the unlock sound sucessfully: https://uk.community.huawei.com/p20-series-31/p20-turn-off-unlock-sound-1641#post12791
I think I've cracked it. WiFi calling. WiFi calling became available to me only after version 9 was installed and if I enable it I get a notification that WiFi calling is enabled every time I unlock the phone. My problem with the unlock sound went away when I disabled WiFi calling!
So I have a choice. Use WiFi calling and put up with the notification or keep it disabled. I did try suppressing notification s for WiFi calling but that didn't seem to disable the audio notification just the visual one.

Reply