Question

WiFi problem on P30 Pro

  • 4 May 2019
  • 9 replies
  • 4101 views

  • Fearless Explorer
  • 6 replies
Hi, I've had my p30pro nearly a month and I'm having very noticeable drops in WiFi connection.
I can be on a webpage or playing a game and I'll get "not connected to internet". If I pull the drop box down from top of the screen and turn WiFi off then back on it works again for half an hour or so then I'll have to do it again.
This is what I've tried so far
My router and speed is working fine (checked via other devices)
I've changed channel.
I've tried connecting to 2ghz as well as 5ghz
I've reset network settings and reconnected.
Nothing has made a difference. I'm I had a p10plus before this and never had to do any of the above so thinking of taking the phone back tomorrow which will be a shame as I love everything else about p30pro. I'm not very technical so finding this problem very frustrating.
Thanks for reading

9 replies

Userlevel 4
Badge +4
hi pjone,

Welcome to the forums!

Just wondering is your broadband provider BT by any chance?
hi pjone,

Welcome to the forums!

Just wondering is your broadband provider BT by any chance?

No buddy, virgin media.
Userlevel 4
Badge +4

hi pjone,

Welcome to the forums!

Just wondering is your broadband provider BT by any chance?
No buddy, virgin media.


can you go to settings > network settings > advanced settings > Wifi+ and disable it.

also try connecting using WPS. click the wps button on your hub and go the above settings on your phone and choose WPS. it should pair with your phone near instantly without adding password.

Wifi+ is a tool which helps you leverage the best connection either from your mobile data or wifi according to its strength. maybe that is the reason why it drops.
I disabled WiFi+ last week to no avail. Will try the WPS button.
Switched on the WPS on front of my router. Then went into phone WiFi settings and clicked WPS connection. It's connected under the 2ghz instead of normal 5ghz. Is that correct?
Userlevel 4
Badge +4
your phone should ideally connect to 5ghz.
do you have the wi-fi to show two separate channels (ie VM00000-2.4ghz and VM00000-5ghz) or simply VM000000
let us know if the problem still persists, after WPS

If the problem persists try putting your phone on airplane mode and then connect to wi-fi.
Hi, problem is still the same. I have 2ghz and 5ghz both showing in my list of available connections but it automatically connects to the 2 when I select the WPS in WiFi settings. Starting to wish I'd stuck with my p10plus lol
Have just put into airplane mode and connected to wifi. Should I be trying it as it is or do I turn airplane mode off now it's connected ?
Userlevel 7
Badge +11
Hi all,

There are a few similar topics about wifi issues on the P30 Pro on the community. I closed this topic to avoid double topics. Please continue the discussion in this thread. Thanks! 🙂

Reply