Dual shock 4 connects by Bluetooth but button registers fail. Can't play games over Bluetooth

  • 10 April 2019
  • 18 replies
  • 1037 views

Hi I have a p20 and a PS4. I have tried to play games with my dual shock4 over Bluetooth and although the remote connects to the phone it does not register button presses therefor rendering it useless. I have read a bit around the net and it seems a lot of people are having this issue with no solution. Can someone tell me why this is , would it be a driver issue and from who's end. Thanks in advance.

18 replies

Hi there I was just wondering if you had a definitive answer as to why the Sony dual shock 4 doesn't work when connected to Bluetooth. I have a p20 it connect to the remote but the button presses do not register. I have tried with multiple remotes to no avail. Thank you.
Userlevel 7
Badge +11
Hi Tazceltic,

Welcome on the community!

I merged your topics to avoid double topics and asked our support team to assist you in this thread.
Thank you.
Userlevel 7
Badge +6
Hi @all
If you can pm me with the details of the Phone - build number, serial number; alongside the details of the controllers you are experiencing this issue with, we will gladly look further into this matter.

Best wishes,
Max
So I have a huawei p20 pro and I read that I can connect a ps4 dualshock via Bluetooth to my phone by pressing the ps and share buttons on the dualshock... OK after a pair with it and connect successfuly.. The dualshock does nothing I tried to reconnect but still it doesn't work... I also tried it via a USB to Go and it doesn't work also.. I have reached a few p20 pro users and they said the same... I hope huawei can see this and fix it in a patch or something. Asap..
Im glad someone else has stated this on here lol it's quite an oversight if you ask me. This feature should be the least we expect in 2019. Yes the p20 is a 2018 phone but you get my point. Phones I've had in the past 7 years have been able to do this flawlessly. I was actually going to buy an otg cable glad I didn't now.
Hi is there an update regarding this?

My phone also connects to bluetooth but no input from the controller works. Bought an OTG cable thinking it would help but this does nothing other than charge the controller with no option to make it an input.
Hi there,

Same issue with the Mediapad M5 and Ps4 Controller.
code:
The problem persists after todays update. 
Userlevel 7
Badge +11
Hey @Kadser,

What software version are you on now?
Hi @Amy,

I am on build 9.0.1.190 (C432E5R1P5).
Userlevel 7
Badge +11
Thanks for the quick reply. I flagged this for our support team. :)

If you need help now, please contact them directly: https://consumer.huawei.com/uk/support/
Push
Userlevel 7
Badge +11
Hey Kadser,

Sorry for the lack of replies in this thread. Seems like the community does not have a solution for your problem.

Please contact our support team directly for help.
I too have the same problem. The wireless controller connects to my phone but there is no input i tried several different games like minecraft or much more different gamen on the myboy gba emulator but nothing did work.
I have the RNE-L21.
@Amy Amy i fixed this problem by adding controller support to my rom but i want to play it on my bootloader locked p20 pro too but you guys don`t support it yet in the official firmware people have been complaining about this problem for months and still its there.... could you give me a bootloader unlock code so i can unlock my p20 pro and be able to use basic function like controller support for my p20 pro please?

would be great if huawei listens to their customers for once its been a while....
Userlevel 1
Badge +1
Hello @chinchan9, welcome back to us!

We are truly sorry for this inconveniences you are experiencing at this moment!

Unfortunately, we can't give you boot loader unlock codes any more due to security reasons.

Please don't hesitate to contact me if you have further issues! You can send a private message as well, if you want this kind of assistance!

Have a lovely day!

All the best,
BarneyT
@BarneyT huawei has to turn this around and start giving out bootloader unlock codes then because allot of the issues people are having are easily fixed by doing that and since huawei doesnt want to take the time to help their customers with simple things like controller support for their expensive phones we should be able to fix it ourselfs but even that u don't allow i think this is a real step back in Huawei's customer support and a set back for us all in the growth of huawei, especially with all the nasty news about huawei the last years u guys should be more open about your stuff and not lock bootloaders as that raises more suspicion about your software, and i dont blame them how sketchy is it that as soon all this news about huawei spying on their customers is getting out huawei locks down their software.... its a bit how do u say... it really makes it allot more sketchy in my eyes and i really cannot recommend huawei anymore to my customers because of this. and @BarneyT could you explain to me why u guys locked everyones bootloader and refuse to give us the codes for what exact security reason? because my rooted phones are way more secure then ur stock phones. they are way easier to recover if something would happen to them aswell so take a look at all the other phone manufacturers out there they all let people unlock their phones potential, but not huawei..... the thing that bothers me most is that i bought a phone at u guys and u never told me u stopped bootloader support and now im stuck with an expensive phone that i cannot unlock and i've been doing this for over 10 years now and u guys tell me its unsafe..... never ever have i had a bricked phone.. u guys are just lying to your customers about it and i don't like liars epecially if its a company that does it. so @BarneyT i hope you could elaborate on this because im really interested to hear what huawei has to say.

Reply