HiSuite: Why release software without completed translations?

  • 29 November 2018
  • 8 replies
  • 130 views

Userlevel 4
This is software included with the phone (the installer). Why would company operating internationally forget to complete the English translations, the most commonly understood in the West, for software included with a 'flagship' series? I've reported this via email to the development team but heard nothing back.


8 replies

Userlevel 7
Badge +11
Hi Piers,

I like your 'Laziness'-tag 😉.

Please let us know when you hear anything back from the development team!
It could be because of your Windows Language settings. There is one Unicode language setting (in control panel) and one OS Language setting (in Settings App). Try checking those, and adjusting those settings accordingly.

Hope this helps 🙂
Userlevel 4
It could be because of your Windows Language settings. There is one Unicode language setting (in control panel) and one OS Language setting (in Settings App). Try checking those, and adjusting those settings accordingly.

Hope this helps :)


There are three language options 😊 All three are set to English (en_GB).
Userlevel 4
Hi Piers,

I like your 'Laziness'-tag 😉.

Please let us know when you hear anything back from the development team!


Well, for the second-largest phone manufacturer, it is lazy 😢
Userlevel 4
Hi Piers,

I like your 'Laziness'-tag 😉.

Please let us know when you hear anything back from the development team!


The email was sent on the 16th November. No reply as of yet. If there an ETA for replies?
Userlevel 7
Badge +6
Hi Piers,

Thank you for pointing this out, I will also forward this up the line and if you can PM me with more info I will do my best to track down the email that you have sent and urgent it.

Best wishes,
Max
Userlevel 4
Hi Piers,

Thank you for pointing this out, I will also forward this up the line and if you can PM me with more info I will do my best to track down the email that you have sent and urgent it.

Best wishes,
Max


Thank you Max. I'm not sure what additional information I can provide. The issue appears when creating a backup. The version is displayed in the image.
Userlevel 4
The issue appears to have been fixed with HiSuite 9.0.2.301. Although lazy to not offer complete translations on software that comes with the phone, just over three weeks is a good resolution time.

Reply