Answered

Switching between 2.4ghz and 5ghz wifi issues


Hi,

Got a p20 pro last week and so far, not so good! I keep finding that if the wifi signal in my flat switches from 2.4 to 5ghz wifi then the phone will say 'connected to wifi' but that there was no internet connection.

I tested signal strength, download speeds all to no avail, but then I noticed that on the info section of the network you're connected to it will say if 2.4 or 5ghz. I noticed the change and this coincided with the issue of not connecting, almost like an authentication error.

I have a virgin superhub 3 (UK) and it runs permanent dual band and switches between the best signal itself. my workaround for now is to disable 5ghz, but this doesn't seem right. Is this an issue with the update to emui9 or does the phone have an issue?

Is anyone else experiencing this?
icon

Best answer by scabbydan 5 March 2019, 19:07

Hi Max,

Thanks for the reply.

I tried that and a full reset, the issue maintained! My fix is working for now though. Suspect it's a bug with the update, or an authentication issue with the router.

I will try it on a different branded router when I get chance to test.
View original

5 replies

Userlevel 7
Badge +6
Hi @scabbydan,

I am glad to hear that you are using a Huawei product! I hope you find it useful!

Now, to ensure that the device works perfectly for you, let's solve the issue. What I would advise you to do regarding this is reset the network settings. In that way, the settings will be reverted to their initial state and it should be working properly for you.

To do that, go to Settings > System > Reset > Network settings reset (you will have to re-enter the WiFi network credentials).

I trust this information will help on your inquiry. Nevertheless, if you still have any other questions or issues, please let me know!

Best wishes,
Max
Hi Max,

Thanks for the reply.

I tried that and a full reset, the issue maintained! My fix is working for now though. Suspect it's a bug with the update, or an authentication issue with the router.

I will try it on a different branded router when I get chance to test.
Userlevel 7
Badge +6
Hi @scabbydan,

Thanks for letting me know of the outcome!

Happy to hear everything is working for now, please do keep me updated on the situation!

Best regards,
Max
Userlevel 6
Badge +3
Dunno if it's any help, but Acrylic wifi is really good. It will show you the channels and you can see if one of your wifi sources has a channel conflict. I don't use the router's auto channel feature, I use Acrylic and make sure my channel is at least 2 channels away from a close source.

Acrylic Wifi

Cheers

Steve
Userlevel 6
Badge +7
I've dual band wifi and haven't had problems, I think this is the Virgin router trying to be too clever and give you best signal, switching between them, when you should just have 2 constant wifi signals, which everone you connect should be your choice.

Try disabling the 2ghz one which is slower or change the wifi band to another channel, see if it's conflicting with neighbours.

Reply

    Cookie policy

    By browsing our website, you accept the use of cookies on our site to perform analytics, provide you with ads tailored to your preferences and interests, and allow you to share content on social networks. Learn more about our cookies and manage them

    Accept cookies Cookie settings