Answered

Why doesn't Google Pay work on my P20 (Pro)?

  • 23 August 2018
  • 62 replies
  • 32764 views


Show first post

62 replies

@mrQQ I have same problem in Lithuania with P20 Pro. My operator is also Telia I am still looking for solution, but can't believe that it can be related with operator because on my samusng s7 works fine.

@Max Also tried to unistall google services update by I get message: Uninstall unsuccessful.


Still no solution 😞 contacted Huawei but haven't got back. Did you try factory reset?

@mrQQ I have same problem in Lithuania with P20 Pro. My operator is also Telia I am still looking for solution, but can't believe that it can be related with operator because on my samusng s7 works fine.

@Max Also tried to unistall google services update by I get message: Uninstall unsuccessful.
Still no solution 😞 contacted Huawei but haven't got back. Did you try factory reset?

Not yet. What about you?


@mrQQ I have same problem in Lithuania with P20 Pro. My operator is also Telia I am still looking for solution, but can't believe that it can be related with operator because on my samusng s7 works fine.

@Max Also tried to unistall google services update by I get message: Uninstall unsuccessful.
Still no solution 😞 contacted Huawei but haven't got back. Did you try factory reset?
Not yet. What about you?

No, this is a work phone, difficult to reinstall everything. Can you try?

Got response from Huawei that Google Pay is not supported in Lithuania (which is crap, as it works on other phones) and that Swedbank app should be fixed by the developer (which is also crap because it also works on other P20s :()
Hi,

I own a p20 pro too. I've tried everything and nothing worked. (play beta, updating settings, manual battery control etc.) Until I've come across a workaround. Just put your sim card into slot 2 instead of slot 1. And it started working with no glitch. Hope this helps!
Hi,

I own a p20 pro too. I've tried everything and nothing worked. (play beta, updating settings, manual battery control etc.) Until I've come across a workaround. Just put your sim card into slot 2 instead of slot 1. And it started working with no glitch. Hope this helps!


OH my God, you are my hero! This has worked! I was pulling my hair and biting my nails trying to fix this and you did it! Huawei support and bank support had no clue, so much use of them! You know, I even had thought about this before, but I just checked if it was in sim1 slot, thinking that should be the main slot. So I just checked, and it was. And didn't even think to try sim2. I guess that sim1 slot could be somehow blocking rfid antenna or something like that?

In any case - thank you!
Userlevel 7
Badge +11
@mrQQ, Thank you for letting us know that this fixed this issue! And @muntix thank you for sharing.

@MariusPoskus, @Karlcanaries @Gre @Nico @Sfchow128, please try the above fix and let us know if it helped. 🙂
I'm with Vodafone UK and had an old aim that had contactless function on it. I changed to a new sim and it has been working since
@mrQQ, Thank you for letting us know that this fixed this issue! And @muntix thank you for sharing.

@MariusPoskus, @Karlcanaries @Gre @Nico @Sfchow128, please try the above fix and let us know if it helped. :)

Hey, I put my Sim card in SIM2 slot and it works!
Hi guys, I bought a Mate 20 Pro back in November off the official Amazon UK website (LYA-L09) and I've been having problems with downloading specific popular apps like Snapchat and Spotify which Google Play Store states "are not available in my country" (even though I'm in the UK) . I've checked everything from Google payments/ Google Play Store country to the wiping the cache data from my phone and it still doesn't seem to recognise that I'm in the UK...

Every applicable setting is set to UK, so I'm not understanding what the problem is. My friend has the same phone and hasn't had a problem with. I've also been in touch with Huawei and their advice was to clear cache from everything and reboot the phone and wipe cache dat and I've still had no luck.

Can anyone suggest anything else before I get in touch with Amazon?

Thanks!
Userlevel 6
Badge +4
Hi @zoeiom ,

I've moved your post to this thread as it seems others had issues with google play store and have resolved this. See the answer from muntix, "Just put your sim card into slot 2 instead of slot 1." hope this works for you.
Hi @zoeiom ,

I've moved your post to this thread as it seems others had issues with google play store and have resolved this. See the answer from muntix, "Just put your sim card into slot 2 instead of slot 1." hope this works for you.


Hi Danjl,
Thanks for the advice however this still hasn't solved the issue as my Huawei is a single sim version rather than LYA L29! I hope that there'll be another suggestion soon.
Userlevel 7
Badge +11
Hi @zoeiom,

Thank you for your reply. I flagged this topic for our support team. They still have a few outstanding questions so it might take a few days before they respond. Please contact our support team directly if you need help now, that is the fastest way to get assistance from the service team: https://consumer.huawei.com/uk/support/

Please keep us updated! 🙂

Reply