WiFi not working Mate 20 Pro


WiFi is cutting off on my Huawei mate 20 pro. I'm having to use my phone data to much. Any one else having this issue?? Paul in Leeds UK.

11 replies

Userlevel 4
Badge
Hi Paul,

Does it happen in different locations or just at home? Also, is it just your phone or other devices that lose WiFi?

First off, and the quickest fix, try turning off WiFi+ in your phone's WiFi settings.

Next up, and slightly more involving:
Basically most routers give out two frequencies, one for speed and one for range. With mobile devices this can be an issue as the phone could potentially drop connection whilst switching between networks. The fix is to give the 2.4 and 5GHz frequencies different names to effectively force the phone to stay on one or the other. This is done by going in to your router settings. I'd recommend 2.4 GHz for mobile devices for the better range.

I work for an internet company as a technical support advisor so feel free to ask if you're unsure.

Regards,

Rik.
Hi Rik, it only happens at home.
Iv restarted my sky WiFi router so that's good, for some reason it's just my Huawei mate 20 pro that's seems to suffer in the evenings!
Ta Paul in Leeds UK
Userlevel 4
Badge
Hi Rik, it only happens at home.
Iv restarted my sky WiFi router so that's good, for some reason it's just my Huawei mate 20 pro that's seems to suffer in the evenings!
Ta Paul in Leeds UK


Thanks for the extra info Paul.

Does it happen in all parts of the house or just certain rooms?

It may also be worth checking the wireless channel in your router as too many on the same channel in your area will reduce your signal quality.
Userlevel 6
Badge +7
Definitely switch off WiFi+ as suggested by Rik, the phone might just think that it's getting a better mobile signal and that's why it's switching your WiFi off.

Regards Jase
Huawei mate 20 pro WiFi issue's still. 😭😭😭Anyone else experience this were the wifi cuts off and its saying "no connection". Leeds UK
Userlevel 6
Badge +7
Have you switched off WiFi+ in the settings?, this can definitely cause issues with WiFi.

Regards Jase
Hi @Jase yes iv done that and iv restarted my phone. Next step I think is to contact my WiFi provider. 🙄 It's weird cos it works most of t'time but every now and then cuts off.
Mate 20 Pro.

Doesn't like talking to my WiFi hub.

Had the phone 6 months all was fine at first.

But after the last update, I'm now finding that I'm constantly having to start/restart WiFi, on my phone.

I've reset connections. Restarted the hub. Even done a factory reset (not doing that again).

Still not working properly, even when I'm on top of my WiFi, and the connection is showing as excellent, I'm seeing regular 'could not connect' type error messages when trying to interact with web based services.

Hugely frustrating.

Any ideas please.
Userlevel 6
Badge +4
@MattWaring , i've moved your post here as the topic covers wifi issues with Mate 20 Pro, can you check and confirm if changing the setting for Wifi+ works?

First off, and the quickest fix, try turning off WiFi+ in your phone's WiFi settings.

Next up, and slightly more involving:
Basically most routers give out two frequencies, one for speed and one for range. With mobile devices this can be an issue as the phone could potentially drop connection whilst switching between networks. The fix is to give the 2.4 and 5GHz frequencies different names to effectively force the phone to stay on one or the other. This is done by going in to your router settings. I'd recommend 2.4 GHz for mobile devices for the better range.

I work for an internet company as a technical support advisor so feel free to ask if you're unsure.

Regards,

Rik.
Many thanks. I've tried the above, hasn't fixed the issue unfortunately.

Still finding I'm having to turn WiFi on and off 4 or 5 time a day (via my mobile).

It's a Virgin Media router, super hub 2 - I don't think Huawei likes talking to my Virgin router!
Userlevel 6
Badge +4
@MattWaring , If you're still having issues, you should contact https:// https://consumer.huawei.com/en/contact-us/.

Reply