Answered

How to activate/disable GPS on Watch GT

  • 9 February 2019
  • 26 replies
  • 5697 views

Userlevel 4
Hi

I have my Watch GT since today, and i am very satisfied of my first experience with it : fast (no lag), simple way of use it, very good battery, beautiful look.

But i don't understand how GPS mode is activate. Is the GPS automatically activate when we make a training / sport session ? And it is disabled when this session stop ?

Thanks for yours responses.
icon

Best answer by Max 12 April 2019, 21:24

Hi all,

Can you please PM me the serial number of your watches so I can look into this further?

You can find this info either on the back of the watch or on the box.

Looking forward to your replies!

Best wishes,
Max
View original

26 replies

Userlevel 7
Badge +7
Open huawei health app

Click me bottom right

Click settings

Enable auto track to have GPS on all the time.
This will reduce battery life.

If disabled when you enable a fitness activity the watch will seek GPS before allowing you to start the activity.
Userlevel 4
chillphone, thanks for your response.

But i don't have the "enable auto track to have GPS on all the time" option (or i don't find it ...)

But i understand the gps iss enable when the fitness activity begin.
Userlevel 7
Badge +7
Userlevel 4
Thanks Chillphone for the evidence !

But I don't have this menu ! My version is 9.0.4.320 (french)

Here is the screen settings :

Userlevel 4
It's strange, I have the last version of the google play 9.0.4.320.
Are there differences between language version apps ?
Userlevel 7
Badge +6
Hey @Olrik,

Good to hear that you are using the Watch GT!

Have you tried wiping the cache and data of the Health app? You can do that by opening Settings > Apps&Notifications > Apps> Health > Storage and pressing CLEAR DATA and CLEAR CACHE.

No matter which language you are using the app in, the settings should appear the same, only translated.

I trust this information is of assistance. Should you have any further questions, please do not hesitate to contact us!
Max
Userlevel 4
Hi Max,

I tried your solution, but no success.
Userlevel 7
Badge +6
Hey @Olrik,

Thanks for coming back to us!

Would you mind switching your phone's language to English (UK)? This might trigger the bug that's causing the option not to appear. If it does appear please make sure to screenshot it then send it to us so we can send it to the right department.

I believe we can sort this out together!
Best wishes,
Max!
Userlevel 4
Hi @Max

I already tried but if i uninstall/install the app, french language came automatically even if i clear the cache after uninstall or in the app. I think the app recognize the language of my phone.
I just made a new try one minute ago and i have the same result.
How switch to English language ?
I can confirm that I don't have those options either. I have Health app version 9.0.4.332 and the language is set to English (UK). I also did a full application data wipe (storage and cache) with no luck.

I am using a Nokia 7 Plus, Android One device with Android 9.
Userlevel 4
Thanks silviu001 ! So it confirms change language isn't the solution to this issue.
My opinion is that depends of the GPS model, perhaps ?

My phone : Motorola Nexus 6 with Android 7.1.1 (so Android stock)

It would be nice if Huawei fix all this issues (option gps, autonomy, notification during workout, etc) 🤒
I also think it is related to EMUI or similar ROM that allows more advanced controls over the hardware.
Userlevel 2
That option isn't there on iPhone
Userlevel 7
Badge +6
Hi all,

Could you please check if you have the "Huawei Wear" App available for download on your devices?

If you do, kindly check if you have the feature you are looking for available on Huawei Wear.

Screenshots would also help if possible!

Best regards,
Max
Can someone confirm if that option is supposed to be there in the last version of firmare/huawei health?
Userlevel 4
I confirm this option supposed to be there.

For information, i just changed my smartphone. With the previous one, i didn't have the option, but with the new one, i have got it.... With the same version of huawei health. I think the devlopment team is in holidays...
with a pixel 1 the option is nowhere to be found, just installed everything 2 days ago
This option is not available with OS Lite on the iPhone
WTF !! Today my clock Huawei Watch GT arrived and it is not possible to deactivate the GPS from IPHONE, I will return it... any solution ???
I confirm this option supposed to be there.

For information, i just changed my smartphone. With the previous one, i didn't have the option, but with the new one, i have got it.... With the same version of huawei health. I think the devlopment team is in holidays...


The developers simply removed it. They do not know the damage they do to the brand. In my iphone and my Android can not see this option. 😡
The product/brand/watch/app is a fraud
Userlevel 7
Badge +6
Hi all,

Can you please PM me the serial number of your watches so I can look into this further?

You can find this info either on the back of the watch or on the box.

Looking forward to your replies!

Best wishes,
Max
Same issue for me, just bought the watch yesterday.
Running on Galaxy S8+, rest of technical details sent via PM to @Max
Same issue on Xiaomi Redmi 5 Plus with latest watch firmware and Health app version. Provided details to @Max.
Userlevel 1
Same issue for me. This is insane.. another Huawei bug that they haven't been able to fix in five months!
Same, i dont see that option. Pixel 2XL. Health app ver 9.0.4.420 installed from playstore.

Reply