Standby Watch Face and DND


Userlevel 3
The stand-by watch face is pretty cool, however it should respect the DND times.

I have the DND times set for when I usually sleep, and I don't want the light from the AOD watch to disturb me. This is also a waste of battery and screen.

Please add an option to turn off the stand-by watch face when DND is ON.

15 replies

Which watch do you have?
Setting DND on the watch itself is supposed to stop all notifications and is also supposed to stop the watch face from lighting up when you move your wrist during sleep. I always had it turned on and even 'Raise wrist to wake screen' in the Huawei Health app doesn't override it as it states in the option. I wonder why it doesn't work for you.

Userlevel 3
Which watch do you have?

I have the Watch GT. DND worked fine with the normal watch face, it stops it coming on even if I flick my wrist which is good and expected.

However yesterday I had DND on, and the stand-by watch face (not the normal watch face) was still on, which is disturbing at night. I had to switch off the stand-by watch face manually.
Oh no. I'll mine again tonight
Userlevel 6
Badge +4
@giorgoXXI, Hope the following helps: First and foremost head to Settings>Sounds>Do Not Disturb. Ensure it is turned on, not scheduled, ensure settings for calls and messages are correct. Secondly head to Settings>Apps>Apps>(chose an app)>Notifications and ensure "allow interruptions" is not selected. If all of that still fails then you should contact the support team direct:

  • Hotline: 08000 886 700
  • Support Language: English
  • Support Time: Mon - Fri 09:00 - 21:00, Sat. 9:00~17:00 (Except bank holidays)
Userlevel 1
The stand-by watch face is pretty cool, however it should respect the DND times.

I have the DND times set for when I usually sleep, and I don't want the light from the AOD watch to disturb me. This is also a waste of battery and screen.

Please add an option to turn off the stand-by watch face when DND is ON.


I've got the same issue...
Userlevel 7
Badge +11
Hi @lcp,

Sorry to see that you are having the same issue. Have you tried the above suggestions?
Userlevel 1
Hi @lcp,

Sorry to see that you are having the same issue. Have you tried the above suggestions?


Yes I did. Actually is not a big problem for me, I can switch off the stand-by watch face manually
Userlevel 3
Hi @lcp,

Sorry to see that you are having the same issue. Have you tried the above suggestions?


The suggestion seems to miss the point of the issue.

To be clear, these are the steps to reproduce:

  1. Make sure a standby watch face is active
  2. Turn on DND
  3. The standby watch face remains active/on rather than going off
This is a problem at night for 2 reasons:

  1. The standby watch face still emits enough light to be distracting while sleeping
  2. It is a waste of battery to have the standby watch face on while I am sleeping
Either disable the standby watch face when DND is ON, or at least make it an option.
Userlevel 5
Badge +3

Hi @lcp,

Sorry to see that you are having the same issue. Have you tried the above suggestions?
The suggestion seems to miss the point of the issue.

To be clear, these are the steps to reproduce:

  1. Make sure a standby watch face is active
  2. Turn on DND
  3. The standby watch face remains active/on rather than going off
This is a problem at night for 2 reasons:

  1. The standby watch face still emits enough light to be distracting while sleeping
  2. It is a waste of battery to have the standby watch face on while I am sleeping
Either disable the standby watch face when DND is ON, or at least make it an option.

I got you, thanks for your feedback.
Userlevel 1
One solution for that
1. turn on DND
2. swipe down back to clock face
3. turn off your display with your flat of the hand (put your hand on the screen)
Userlevel 3
I didn't know there was an AOD option, how do I get access to this 'Standby Watchface' ? Did it come with a particular firmware update ? I've seen no new faces in the watchface 'store' since launch.
Userlevel 1
I didn't know there was an AOD option, how do I get access to this 'Standby Watchface' ? Did it come with a particular firmware update ? I've seen no new faces in the watchface 'store' since launch.

Firmware version 1.0.8.34. Read point 1 to find AOD.
[img]https://d38av1t9zrt96v.cloudfront.net/huawei-en/attachment/6c06b4fb-9a3e-4549-a38e-ac5b6938d1bc.jpg[/img]
One solution for that
1. turn on DND
2. swipe down back to clock face
3. turn off your display with your flat of the hand (put your hand on the screen)


This one worked well for me, although it would be nicer if the standby face would turn off automatically when DND is active.

Reply